Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
XFree 4.0.1: Modeline-Frage an die XF-Gurus

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Roman B.
Gast





BeitragVerfasst am: 06. Nov 2000 15:55   Titel: XFree 4.0.1: Modeline-Frage an die XF-Gurus

Guten Abend!

Samstags habe ich Brandens XFree 4.0.1 Pakete installiert und
konfiguriert und bis jetzt läuft (fast) alles ausgezeichnet, wenn da
nicht ein kleines Problem wäre...

Zur Einleitung meine Hardware:
1. Monitor:
Sony GDM-F500 (21") mit Vertikalfrequenzbereich 48-160Hz und
Horizontalfrequenzbereich 30-121kHz.

2. Graphikkarte:
Matrox Millenium G400MAX mit 32MB SGRAM und RAMDAC 360MHz.


* PROBLEMBESCHREIBUNG: *

Meine verwendete Arbeitsauflösung ist 1280x1024. Diese möchte ich
mit 100Hz ansteuern. Sowohl Monitor als auch GFX-Karte unterstützen
diesen Modus!

Unter XFree 3.3.6 hat XF86Setup den 1280x1024@100Hz Modus
*defaultmäßig* eingestellt und folgenden Eintrag in /etc/X11/XF86Config
gemacht (inklusive 1600x1200@85Hz):

Modeline "1600x1200" 220.00 1600 1616 1808 2080 1200 1204 1207 1244 +hsync +vsync
Modeline "1280x1024" 181.75 1280 1312 1440 1696 1024 1031 1046 1072 -hsync -vsync

UNTER XFree 3.3.6 HAT DAS SUPER FUNKTIONIERT!

Den XFree 4.0.1 G400-Treiber habe ich gegen das Modul mga_drv.o von
der Matrox-Homepage ausgetauscht. Wenn ich unter 4.0.1 diese beiden
Modelines in /etc/X11/XF86Config eintrage, dann startet der X-Server
mit 60Hz! Weglassen des 1600x1200er-Eintrags und Ändern von
hsync/vsync hilft auch nix.

Ohne Modelineeinträge startet X mit der VESA-Einstellung 1280x1024@85Hz.

Ich habe die Modelines auch selbst neu berechnet (mit dem
Taschenrechner ; mit http://zaph.com/Modeline/ und mit
http://www-sop.inria.fr/cgi-bin/koala/nph-colas-modelines) ; ein netter
Kollege hat sie ebenfalls berechnet, aber leider auch ohne
Erfolg.

Hier ein Ausschnitt aus meiner XF86Config:

++++ Schnipp ++++

# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

Identifier "GDM-F500"

# HorizSync is in kHz unless units are specified.

HorizSync 30-121

# VertRefresh is in Hz unless units are specified.

VertRefresh 48-160

# Verschiedene Probedurchläufe

# 1280x1024 @ 100Hz, 107.90 kHz hsync
# Mode "1280x1024"
# DotClock 205.44
# HTimings 1280 1336 1544 1904
# VTimings 1024 1029 1034 1079
# EndMode

#Modeline "1280x1024" 222.47 1280 1336 1616 1728 1024 1026 1038 1064
#Modeline "1280x1024" 181.75 1280 1312 1440 1696 1024 1031 1046 1072
#ModeLine "1280x960" 209.08 1280 1336 1616 1728 960 962 974 1000 #121Hz

EndSection

++++ Schnapp ++++

FRAGE:
1. Kennt jemand dieses/solche Probleme?
2. Verwendet jemand eine ähnliche Hardware (Sony G500 oder F500 und
G400) bzw. Konfiguration? Wenn ja, bitte eine Email an mich mit
Eurer XF86Config bzw. Euren Einträgen! -> Danke schon mal in voraus...
3. Sind die Modelineeinträge zwischen 3.3.6 und 4.0.1 nicht mehr
kompatibel?
4. Theoretisch könnte es sich auch um einen Bug in XFree 4.0.1
handeln, aber bevor ich denen die Schuld gebe suche ich den Fehler
vorerst mal bei mir. Wenn's wirklich ein Bug ist, dann wäre die
nächste logische Instanz die "debian-x"-Liste.

Danke, schon mal im voraus!

MfG Roman!
--
Roman BEIGELBECK
rbeigelb@comet.nt.tuwien.ac.at
Technische Universität Wien - IEMW
LinuX is like a wigwam: No Windows, no Gates and an Apache inside.
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 07. Nov 2000 0:08   Titel: Re: XFree 4.0.1: Modeline-Frage an die XF-Gurus

Hi,

erster Tip: verwende 1280x960. Denn dein Monitor hat ein Seitenverhältnis von 4:3 (wie 1280x960), während 1280x1024 5:4 sind. Verzerrungen sind die Folge.

Schau dir die Xfree86 Logdatei in /var/log an. Da steht, welche Modi aus welchen Gründen abgelehnt werden.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Roman B.
Gast





BeitragVerfasst am: 07. Nov 2000 1:17   Titel: Re: XFree 4.0.1: Modeline-Frage an die XF-Gurus

Hallo HJB!

Mir persönlich ist 1280x1024, trotz 5:4 Seitenverhältnis, lieber als 1024x960, aber das ist wohl reine Geschmackssache!

Funktioniert haben die Modi in den meisten Fällen, allerdings nicht mit 100Hz sondern mit 60Hz. Die LOG'S habe ich auch immer kontrolliert.

Mich würde zwar noch immer interessieren an was es definitiv gelegen ist, allerdings habe ich das Problem schon mit der "Holzhammermethode" gelöst!

Hierzu habe ich auf eine neue Partition SuSE 7.0 Pro installiert (erschreckend ist das die Standardinstallation ca. 1.7GB hat!! -> SuSE wandelt auf den Spuren von M$ ) und X mit Yast konfiguriert. Anschließend habe ich Debian gebootet, die SuSE Rootpartition eingebunden und die SuSE-XF86Config-Einträge ins Debian /etc/X11/XF86Config übertragen und jetzt funktioniert alles...

Fußnote:
Höchstwahrscheinlich sind die XF4.0.1 und die XF3.3.6 Modelines nicht 100%ig kompatibel oder es hängt mit dem "originalen" Matroxtreiber (mga_drv.o) zusammen.

MfG Roman!
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy