Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
SQuid friert ein

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Matthias Tinnemeier
Gast





BeitragVerfasst am: 21. Dez 2000 2:04   Titel: SQuid friert ein

Ich betreibe in unserer Schule und auch zu Hause in meinem privaten Netz je einen Proxyserver unter SuSE 7.0. Mein Heimrechner ist ein PII-266, 128 MB, ... der in der Schule ein Athlon 800mit 256 und u2W-Scsi. Beide dürften hardwareseitig mehr als überproportioniert für die wenigen Clients sein, ein Hardwareproblem ist also auszuschließen.
Das SuSE System ist je eine Installation im Profi-Modus per Yast 1, es laufen parallel noch Firewall, Mailserver, SMB, DHCP, DNS, ... auf beiden Kisten. Beide Konfigurationen wurden unabhängig von einander erstellt und beide Male tritt folgendes Problem auf:
Der Server startet, der Rechner wählt sich ein (T-Flat) und ich kann ganz normal über Lan von den Clients aus surfen. Nach einiger Zeit in denen die Verbindung nicht über den Proxy genutzt wurde, wohl aber über den Mailserver Mails abgeholt wurden (die Verbindung steht also noch und auf der Leitung selbst herrscht noch Traffic!!) friert die WWW-Verbindung über squid ein. D.h. ich kann wenn ich auf meinem Win client z.B. den Internetexplorer starte nicht mehr ins Internet. Stattdessen werden squid-Fehlermeldungen ausgegeben, dass die Namensauflösung nicht funktionieren würde. Die funktioniert aber sicherlich, denn ich kann sowohl im internen Netz, als auch z.B. über FTP-Clients oder einfach per Ping Rechner im Internet erreichen. Das einzige was nicht klappt ist das surfen über squid. Starte ich squid dann mit "rcsquid restart" neu funktioniert es sofort wieder!!!

WORAN KANN DAS LIEGEN?!

Matthias
tinne@squild.com
 

zwatz



Anmeldungsdatum: 19.04.2000
Beiträge: 144
Wohnort: OOE

BeitragVerfasst am: 21. Dez 2000 9:13   Titel: Re: SQuid friert ein

hallo,
der squid startet zusätzliche Prozesse zur Namensauflösung.
(sieh dir mal die Prozesse an, die unter dem User squid laufen )

Lies dir die dazugehörige Doku durch und passe gegebenenfalls diese Parameter an.

Auch ein Blick in die SuSE Supportdatenbank könnte vielleicht helfen.

Gruß
Thomas
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 21. Dez 2000 13:02   Titel: Re: SQuid friert ein

Hi,

war vielleicht die Verbindung kurz down und wurde wieder neu aufgebaut? Das kann natürlich Probleme geben, wenn Squid es nicht richtig mitbekommt. Lies mal die SuSE Support-DB zu den Themen dynamische IP und RST-Provoking.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Labba
Gast





BeitragVerfasst am: 21. Dez 2000 21:51   Titel: Re: SQuid friert ein

Ich hatte das Problem bei unserem "Schulserver" ebenfalls ( unter SUSE 6.3 ).
Die einzige Lösung bei mir war den Cache komplett zu leeren, warum das geholfen hat weiss ich bis heute noch nicht ( auf der Festplatte waren noch 18 GB frei !!! ). Jetzt läuft er wieder einwandfrei.

Ps.: Das Problem mit dem kurzen Verbindungsabruch läßt sich doch einfach durch Dial-on-demand lösen .
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy