Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Kann QT-Progs nicht compilieren

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Felix
Gast





BeitragVerfasst am: 22. Nov 2001 15:33   Titel: Kann QT-Progs nicht compilieren

Moin!

Seit dem ich Mandrake 8.0 drauf habe (3 Monate), kann ich kein einziges QT Programm mehr compilieren.
Configure sagt mir immer das QT nicht gefunden werden kann.
Das nervt richtig!

Standartmäsig ist bei mir QT 2.3.2 installiert.
Das Devel-rpm ist natürlich auch drauf.
QTDIR,PATH und LD_LIBRARY_PATH ist natürlich auch gesetzt.

Ich habe zu Testzwecken mal QT3 selber compiliert und parallel installiert.
Genau das gleiche Problem für Programme die QT3 verlangen, obwohl es sogar selber compilert ist...
Bei LFS funkte das bestens.

Ich verstehe die Welt nicht mehr.

Ich habe auch versucht bei configure QT Direkt anzugeben (--with-qt-dir=/usr/lib/qt2).
Das bringt auch garnichts.

Ich meine mal gehört zu haben, daß es viellleicht mit automake o. autoconf zu tun hat.
Weis leider nicht mehr, wo ich das gelesen habe.
Und was es genau war..

Kann mir jemand helfen?
Bitte, bitte, bitte!! :)

Gruss

Felix
 

tj
Gast





BeitragVerfasst am: 22. Nov 2001 17:34   Titel: Re: Kann QT-Progs nicht compilieren

moin, moin,

also ne direkte Antwort weiss ich jetzt nicht, aber guck dir mal das file 'config.log' an. Dort steht dann meist am Ende ein kleines Tesprogramm, dass er nicht kompilieren konnte. Du kannst das ja mal separat kompilieren zur Fehlersuche ...

Viel glueck, tj
 

Felix
Gast





BeitragVerfasst am: 22. Nov 2001 19:19   Titel: Re: Kann QT-Progs nicht compilieren

Jau, es geht.
Ich hatte natürlich in der config.log nachgeschaut.
Irgendwie hatte ich nur diese Zeile übersehen:

/usr/bin/ld: cannot find -lqt-mt

Schnell nen Symlink auf libqt-mt.so.2.3.2 und jetzt klappst!

Danke nochmal für den Hinweis!

Jetzt habe ich nur noch ein anderes Problem.
Ich möchte eine QT Programm compileren, welches die Version 3 braucht.
QT3 habe ich erfolgreich installiert.
Aber beim compilieren tritt genau der gleiche Fehler wie bei der V2 auf.
Das Problem ist aber, daß es garkeine libqt-mt bei der V3 gibt!
Aufjedenfall nicht bei mir...
Was soll das?
Oder, woher bekomme ich libqt-mt.so.3?

Gruss

Felix
 

Felix
Gast





BeitragVerfasst am: 22. Nov 2001 23:32   Titel: Re: Kann QT-Progs nicht compilieren

Problem behoben..

Ich muss natürlich mit threading-support compilieren..
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy