Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
KDE will nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 30. Mai 2002 20:55   Titel: KDE will nicht

Hi,

ich habe schon mal einen Post abgegeben (und keine Antwort bekommen), allerdings war damals das Problem KDE 3.0, jetzt ist es 3.0.1 :

Ich habe

code:
qt
kdesupport
arts
kdelibs
kdebase



compiliert, ldconfig ausgeführt, alle PATH`s und DIR`s etc. gesetzt, "exec startkde" in die ~/.xinitrc eingetragen und starte nun KDE 3.0.1 :

Ich sehe den Splashscreen, dann kommt eine Meldung das der dcopserver nicht gestartet werden konnte. Daraufhin erscheint ein kleines Fenster, in dem steht, dass kcmserver(?) nicht gestartet werden konnte. Ich klicke auf den "OK"-Button, und XFree86 4.1 beendet sich.

Wenn ich mit Strg + Alt + F1 auf die Console wechsle, von der aus ich KDE mittels "startx" gestartet habe, kann ich folgenden Text lesen:


DCOPClient::attachInternal. Attach failed Could not open network socket


Übrigens habe ich eine früher von mir compilierte Version von QT-3.0.4 verwendet, die damals mit GCC-3.0.4 compiliert wurde, während ich KDE komplett mit GCC-3.1 compiliert habe (alles übrigens mit objprelink).

Frage:

Wie bringe ich mein schönes selbstcompiliertes KDE zum laufen???

Vielen Dank für jede Bemühung

cu


Zuletzt bearbeitet von peterm am 30. Mai 2002 20:55, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Jochen
Gast





BeitragVerfasst am: 30. Mai 2002 21:07   Titel: Re: KDE will nicht

Zu dem Problem mit den unterschiedlichen Compilern - keine Ahnung. Aber hast Du Dir einen eigenen Kernel gebaut? Dann hast Du vielleicht "Networking options/Unix domain sockets" vergessen oder aber das passende Modul nicht geladen. Der DCOPServer macht nämlich einen UNIX-Domain-Socket auf (der nur lokal funktioniert, da im Dateisystem abgelegt, namens /tmp/.ICE-unix/dcop*). Wenn der Kernel dafür keine Unterstützung bietet, kann er den nicht aufmachen usw.

Jochen
 

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 31. Mai 2002 9:36   Titel: Re: KDE will nicht

Hi Jochen,

nein, das war es leider nicht. Ich habe sicherhaltshalber einen neuen Kernel mit Unix Domain Sockets compiliert und das Problem ist das gleiche geblieben.

In dem Fenster steht "ksmserver" und nicht "kcmserver".

Weiß jemand einen Rat?

cu
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 31. Mai 2002 13:08   Titel: Re: KDE will nicht

Weitere Info:

manueller Aufruf von dcopserver als normaler user:

code:
DCOP: register 'anonymous-559' -> number of clients is now 1
ICE default IO error handler doing an exit(), pid = 559, errno = 2



Eine Datei namens /tmp/.ICE-unix/dcop5 konnte angelegt werden, also funktionieren die domain sockets.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

mvo
Gast





BeitragVerfasst am: 07. Jun 2002 7:38   Titel: Re: KDE will nicht

Hallo,
lief KDE vorher schon mal unter dem User? Wenn ja, versuch mal das ~/.kde Verzeichnis zu loeschen oder erstmal umzubenennen (alle KDE Einstellungen sind dann futsch).
 

matias
Gast





BeitragVerfasst am: 07. Jun 2002 13:09   Titel: Re: KDE will nicht

Glaub mal das gleiche Problem gehabt zu haben. Damals war mein Problem eine zweite installierte arts. Nach dem deinstallieren von arts liefs.
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 07. Jun 2002 21:28   Titel: Re: KDE will nicht

räume /tmp auf, vielleicht permission-probleme
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 09. Jun 2002 16:33   Titel: Re: KDE will nicht

Hi,

ich habe alle Debian-Packete, die irgendetwas mit KDE zu tun haben, gelöscht, ebenso .kde, außerdem habe ich /tmp aufgeräumt.
Ergebniss:

Der splash screen bleibt bei "initializing peripherals" stehen (er friert nicht ein, sondern das Symbol für die peripherals blinkt), und nach einiger Zeit verschwindet er, KDE wird jedoch nicht weitergeladen.

Ich habe noch nie so ein Problem mit KDE (2) gehabt. Warum will KDE 3 bei mir nicht?

google hilft mir übrigens auch nicht weiter.

Hat jemand noch gute Lösungsvorschläge parat?

cu
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Coogee
Gast





BeitragVerfasst am: 10. Jun 2002 18:22   Titel: Re: KDE will nicht

kdesupport bei KDE 3.0.x? Dieses Paket gibt's bei mir nicht...
 

mvo
Gast





BeitragVerfasst am: 10. Jun 2002 18:48   Titel: Re: KDE will nicht

Hallo,
ist Dein "loopback interface" richtig konfiguriert? Das wird vom dcopserver benoetigt, habe ich irgendwo mal gelesen.
 

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 11. Jun 2002 18:08   Titel: Re: KDE will nicht

@Coogee:

Ich habe mir kdesupport aus dem CVS geholt. Vielleicht könnte eine inkompatible Version von kdesupport tatsächlich schuld sein am Problem. Ich werde mir das mal anschauen.

@mbo:

modprobe loop

Das müsste AFAIK reichen.

Übrigens:

startx &> output.txt

Ausgabe von "startx"

(Am Schluss habe ich den X-Server gekillt)

cu
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 11. Jun 2002 21:10   Titel: Re: KDE will nicht

---------------------------------
It looks like dcopserver is already running. If you are sure
that it is not already running, remove /home/user/.DCOPserver_debian__0
and start dcopserver again.
---------------------------------
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy