Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
libc-Probleme bei Maple 6 mit Debian unstable

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Barross
Gast





BeitragVerfasst am: 05. Dez 2002 12:54   Titel: libc-Probleme bei Maple 6 mit Debian unstable

Hallo,

da ich Student bin, brauche ich doch hin und wieder Maple, was ich mir mal als Campus-Version gekauft habe. Leider wird ja aber nun langsam alle Software auf die neue libc-2.3.1 umgestellt. Leider ist Maple nicht statisch gelinkt, so daß es die libc-2.2.x haben will (bei der neuen wird mit einem Fehler abgebrochen). Da ich die Sourcen von Maple nicht habe, kann ich es natürlich nicht einfach neu kompilieren. Gibt es nicht eine möglichkeit, die alten libc, ld und so weiter in anderen verzeichnis zu kopieren und maple zu sagen, daß es nur dort noch den bibliotheken suchen soll? Wenn mir jemand sagen könnte, wie das genau geht, wäre ich sehr dankbar.

Grüße,

Barross
 

Barross
Gast





BeitragVerfasst am: 05. Dez 2002 13:23   Titel: Re: libc-Probleme bei Maple 6 mit Debian unstable

Was zum Beispiel nicht funktioniert, ist, alle dateien vor dem libc update per apt-get aus /lib nach /usr/local/baklib zu kopieren und dann mal export LD_LIBRARY_PATH=/usr/local/baklib zu setzen. Dann funktioniert schon ls nicht mehr und sagt:
ls: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found (required by /usr/local/baklib/libc.so.6)
ls: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found (required by /usr/local/baklib/libc.so.6)
ls: /lib/ld-linux.so.2: version `GLIBC_2.2' not found (required by /usr/local/baklib/libc.so.6)

 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy