Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
X11: [Alt-Gr] funzt nicht und Probleme mit debian xfree86 4.2.1-6

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Sven
Gast





BeitragVerfasst am: 14. Mai 2003 20:19   Titel: X11: [Alt-Gr] funzt nicht und Probleme mit debian xfree86 4.2.1-6

Ich verwende debian-testing.
Bis vor Kurzem hatte ich noch das xfree86 Release 4.2.1-3. Hier funktionierte alle bestens. Dann konnte ich updaten auf 4.2.1-6.
Jedoch sponn nun der TFT Bildschirm meines Notebook. Immer wenn ich mit der Maus etwas bewegt habe, flackerte er ziemlich übel. Es gab aber nirgendwo eine Fehlermeldung.

Aus diesem Grund habe ich von dem Debian FTP Server die 4.2.1-3 folgenden Types wieder herunter geladen:

xlibs-4.2.1-3
xbase-clients-4.2.1-3
xfree86-common-4.2.1-3
xserver-common-4.2.1-3
xserver-xfree86-4.2.1-3
xterm-4.2.1-3
xutils-4.2.1-3

Die habe ich anstelle der neueren Pakete installiert. Nun ist zwar das flackern weg, jedoch habe ich ein Probleme mit den Fonts (es stehen mir nicht mehr die selben zur Verfügung) und, das ist viel gravierender, die [Alt-Gr] Taste für die Sonderzeichen "\" "|" ... geht überhaupt nicht mehr.

In meiner /var/log/XFree86.8.log
taucht dabei auf:
"Couldn't load XKB keymap, falling back to pre-XKB keymap"

Weiß jemand, wie ich das Problem behoben bekomme?
Im Idealfall vielleicht auch noch, wie ich dir 4.2.1-6 Pakete ohne diesen Fehler verwenden kann
 

jj



Anmeldungsdatum: 03.12.2002
Beiträge: 5

BeitragVerfasst am: 14. Mai 2003 22:32   Titel: Re: X11: [Alt-Gr] funzt nicht und Probleme mit debian xfree86 4.2.1-6

Hallo Sven,
dieses Problem (kein AltGr) hat mich schonmal in den Wahnsinn getrieben. Ursache habe ich nie gefunden, aber mir wie folgt beholfen:

In der ~/.xinitrc wird ~/.Xmodmap gesourced, die folgenden Inhalt hat:


-------------
#!/bin/sh

# Shift-Lock abstellen, weil sie nervt
xmodmap -e "remove lock = Caps_Lock"

# Sicherstellen, dass AltGr funktioniert
xmodmap -e "keycode 113 = Mode_switch" #AltGr als Mode_switch

xmodmap -e "keycode 16 = 7 slash braceleft" #geschweifte Klammer auf

xmodmap -e "keycode 17 = 8 parenleft bracketleft" #eckige Klammer auf

xmodmap -e "keycode 18 = 9 parenright bracketright" #eckige Klammer zu

xmodmap -e "keycode 19 = 0 equal braceright" #geschweifte Klammer zu

xmodmap -e "keycode 20 = ssharp question backslash" #Backslash

xmodmap -e "keycode 24 = q Q at" #@

xmodmap -e "keycode 26 = e E currency" #Euro

xmodmap -e "keycode 35 = plus asterisk asciitilde" #Tilde

xmodmap -e "keycode 54 = c C cent" #¢

xmodmap -e "keycode 94 = less greater bar" #bar (Pipe-Zeichen"

-------------


Die keycodes findest Du mit xenv raus, die aktuelle Belegung mit xmodmap -pke. Der Rest steht in man xmodmap.

gruss
jj
 
Benutzer-Profile anzeigen Private Nachricht senden

Sven
Gast





BeitragVerfasst am: 16. Mai 2003 7:24   Titel: Re: X11: [Alt-Gr] funzt nicht und Probleme mit debian xfree86 4.2.1-6

Danke, der Tipp funktioniert.
Ich hatte es noch einmal versucht die 4.2.1-6pre7v2 Pakete zu installieren.
Da ist zwar das Problem mit dem flackernden Bildschirm behoben, aber die ALT-GR Taste war immernoch kaputt.

Mit Deiner Idee klappt es
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy