Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Java Plugin

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
muecke



Anmeldungsdatum: 14.05.2003
Beiträge: 65

BeitragVerfasst am: 15. Mai 2003 21:38   Titel: Java Plugin

Hi,

ich wollte mal Fragen ob hier jemand weiß, wie man einen Java-Plugin installiert. Ich versuche nämlich seit ich Linux habe (Suse8.1/KDE3.0.3) einen Java-Plugin für meine Browser (Mozilla/Galeon/Konqueror) zu installieren schaffe es aber einfach nicht.
Hier im Forum habe ich gelesen, dass ich bei Sun ein Plugin runterladen kann und das dann verlinken muss.
Für die URL zum Plugin wäre ich froh, muss aber nich sein den finde ich auch so.
Was mich viel mehr interessiert ist: Wie kann ich so einen Link anlegen? Ich hab das schon öfter gelesen, weiß aber nicht wie das geht.
Vielen Dank für die Hilfe.

Gruß Michael
_________________
SuSE9.0; KDE 3.1.4; Architektur: i686; Kernel: 2.4.19-4GB
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen AIM-Name

Andreas B.
Gast





BeitragVerfasst am: 15. Mai 2003 21:54   Titel: Re: Java Plugin

such mal hier in Software, da gab es schon duzende von Threads Smile
 

muecke



Anmeldungsdatum: 14.05.2003
Beiträge: 65

BeitragVerfasst am: 19. Mai 2003 21:44   Titel: Re: Java Plugin

Hi,

erstmal danke für den Tipp mit dem Suchen Ich hab zwar nach Java Plugin gesucht und mich darüber gefreut das ich einen Link setzten muss, aber nach Link zu suchen hat mich dann wohl schon überfordert.
Aber jetzt habe ich ein neues Problem:
Ich hab rausgefunden wie man eine Link setzt aber irgendwie funktioniert das bei mir trotzdem nicht mit dem Java Plugin. Ich hab mir von Sun die Datei j2re-1_4_1_01-linux-i586.bin runtergeladen und installiert und dann einen symbolischen Link gesetzt:
ln -s /pfad/zu/j2re1.4.1_01/plugin/i386/ns610/libjavaplugin_oji.so /usr/lib/mozilla/plugins
Und wenn ich jetzt Mozilla starte habe ich immer noch kein Java-Plugin. Mit Galeon oder Konqueror funktioniert es auch nicht.
Was mach ich denn da falsch?
Danke für die Hilfe.

Gruß Mücke
_________________
SuSE9.0; KDE 3.1.4; Architektur: i686; Kernel: 2.4.19-4GB
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen AIM-Name

Ben
Gast





BeitragVerfasst am: 21. Mai 2003 7:26   Titel: Re: Java Plugin

ich kenne das problem zu gut und ich kann dir da auch weiterhelfen. der mozilla, der mit suse und redhat standardmässig installiert ist, hat probleme mit plugins, das is schon immer ein problem. denn normalerweise erscheint sobald man auf eine seite mit java browst ein popup, das einem anbietet, java übers web installieren zu lassen. bei den mit redhat und suse mitgelieferten mozillas geht das aber nicht.
die lösung: mozilla neu runterladen. wenn du eine schnelle verbindung hast (min. ISDN), kannst du ihn hier runterladen:
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.4b/mozilla-i686-pc-linux-gnu-1.4b-sea.tar.gz

und dann folgendermassen: (am besten als normaler user ein verzeichnis anlegen,wo du programme installierst... beispielsweise /apps oder so, also als root anlegen und dann chown deinuser /apps... oder halt in deinem homeordner z.b. den ordner apps anlegen)

tar xzvf mozilla-i686..
cd mozilla-installer
./mozilla-installer
wähle das verzeichnis aus, wähle custom und mein tipp: wähle den "quality-feedback-agent" und den "chatzilla" ab, die brauchst du nicht und der quality-feedback-agent kann manchmal nervig sein. und der chatzilla bugt bei mir immer rum, deshalb wähle ich den immer ab.
so, nachdem du den installiert hast, springt er selber an.
nun kannst du entweder auf eine seite mit java funktion browsen (z.b. https://banking.rwso.de/ksk-hn/ ) und dann kommt ein popup, das dich java automatisch installieren lässt, oder du machst es genauso wie du oben beschrieben hast mit dem
ln -s /meinjavaordner/jre/plugins/.../ns610/libjavaplugin.so /apps/mozilla/plugins
und gibst danach im browser about:plugins ein, um das abzutesten... dann sollte es meiner erfahrung nach gehen!

ich kann dir auch erklären, wie du sonstige plugins im mozilla hinbekommst (videostreaming, acrobatreader, etc) wenn du möchtest.

im Konqueror Browser gehts auf jeden Fall noch einfacher!
Gehe in "Einstellungen" und "Konqueror einrichten".. dann auf "Konqueror Browser" und "Java".. dann "Java global aktivieren" und als Pfad zum Java den Pfad zu /deinJavaOrdner/jre/bin/java wählen..
dann sollte Java auch im Konqueror laufen! Probiers und berichte mir von deinem Erfolg!

Gruss, Ben alias Somebody
 

muecke



Anmeldungsdatum: 14.05.2003
Beiträge: 65

BeitragVerfasst am: 21. Mai 2003 19:56   Titel: Re: Java Plugin

Hi,


dein Tipp hat leider bei mir überhaupt nicht geklappt.
Ich hab die Datei runtergeladen, mich dann als root eingeloggt
und das Verzeichnis /aps erstellt und die Datei da rein kopiert.
Anschließen habe ich sie mit
tar -xvzf ./mozilla-i686-pc-linux-gnu-1.4b-sea.tar.gz
entpackt.
Dann habe ich ins Verzeichnis /aps/mozilla-installer gewechselt und ./mozilla-installer/
gestartet. Hier ist das Ergebnis:

linux:/aps # cd ./mozilla-installer/
linux:/aps/mozilla-installer # ./mozilla-installer
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


Gtk-WARNING **: cannot open display: :0.0
linux:/aps/mozilla-installer #


Das mit Konqueror hat leider auch nicht funktioniert. Ich bekomme nur ein
graues Feld in dem steht: Minniprogramm wird geladen.
Das kann aber auch daran liegen das ich nicht das richtige Plugin habe.
Aber Konqueror ist mir eh nicht so wichtig. Ich benutze eigentlich am liebsten
Galeon oder Mozilla.
Kannst du mir vielleicht noch mal Helfen oder fällt dir dazu auch nichts mehr ein.
Schonmal danke ich vorraus.



Gruß Mücke, der Verzweifelte
_________________
SuSE9.0; KDE 3.1.4; Architektur: i686; Kernel: 2.4.19-4GB
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen AIM-Name

Ben
Gast





BeitragVerfasst am: 22. Mai 2003 7:11   Titel: Re: Java Plugin

Dieses Problem ist schnell gelöst! (Aber ich hab ja gesagt machs als normaler User)
Das mit dem Cannot open Display liegt daran, dass "root" theoretisch keine Rechte hat, Fenster auf dem X-Server auf zu machen, den du als normaler User gestartet hast.
Also: Entweder du installierst den Mozilla als NORMALER USER mit dem du dich auch am X-Server einloggst in ein Verzeichnis wo du schreiben darfst (z.b. /home/deinuser/apps/mozilla)
ODER du machst folgendes:

als user: xhost+
als root: export DISPLAY=:0.0

und DANN kannst du als root auch Sachen auf dem X-Server starten, den du als normaler User gestartet hast. und ab dann geht meine Anleitung auch wieder
Dann musst du den Mozilla aber IMMER als root starten, um Plugins übers Netz installieren zu können, weil du ihn ja als root installiert hast. Wenn du ihn als User installierst, haste die Probleme nicht und regst dich nachher nicht auf, dass du als normaler User keine Plugins installieren kannst...

Ich empfehle also: Installiere den Mozilla als normaler User!!! So mach ichs immer, ich installier alles als normaler User in ein zentrales Verzeichnis, das ich dem User gebe, dann habe ich nie Probleme, dass ich root werden muss für irgendnen Scheiss (is auch sicherheitstechnisch besser)

also z.b.:
su
mkdir /apps
chown <meinuser> /apps

als normaler user:
./mozilla-installer
und wähle verzeichnis /apps/mozilla als installationsordner...


is immer besser als als root installieren...

erzähl von deinem erfolg, gruss ben
 

Ben
Gast





BeitragVerfasst am: 22. Mai 2003 7:13   Titel: Re: Java Plugin

Das mit dem Konqueror ist NORMAL!!! Bei mir ist es auch so, dass ich die Seite 2-3 mal reloaden muss (auf Reload Button oben klicken) bis das Java Plugin richtig läuft! Probier das mal im Konqueror, du wirst sehen, es geht irgendwann
Aber im Mozilla gehts gleich, der is eh besser von den Plugins her

Du kriegst das hin keine Sorge
 

Ben
Gast





BeitragVerfasst am: 22. Mai 2003 7:14   Titel: Re: Java Plugin

Sorry, das Kommando heisst
"xhost +"

NICHT
"xhost+"

also eine Leerstelle zwischen xhost und +
 

muecke



Anmeldungsdatum: 14.05.2003
Beiträge: 65

BeitragVerfasst am: 24. Mai 2003 15:39   Titel: Re: Java Plugin

Vielen, vielen Dank.

Das Plugin funktioniert jetzt unter Mozilla perfekt.
Weißt du auch zufällig wie man ihn unter Galeon zum laufen bringt?
Wenn nicht ist auch egal.
Nochmal danke, du hast mir echt geholfen.

Gruß Mücke
_________________
SuSE9.0; KDE 3.1.4; Architektur: i686; Kernel: 2.4.19-4GB
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen AIM-Name

ben
Gast





BeitragVerfasst am: 30. Mai 2003 9:45   Titel: Re: Java Plugin

galeon nutzt mozilla......... ich kenne mich mit galeon spezifisch nicht aus, ich weiss nur, dass galeon den installierten mozilla nutzt und deshalb theoretisch dort die plugins auch laufen müssten wenn sie in deinem normalen mozilla laufen.
es sei denn du hast jetzt einen eigenen mozilla installiert, dann nutzt dein galeon halt noch den "original installierten" mozilla und du benutzt aber eigentlich nen eigenen, aktuelleren mozilla.

aber mozilla is eh besser, nutz den

schön, dass ich dir helfen konnte,


gruss, b.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy