Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Installation von GTK 2.2.4

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
acme
Gast





BeitragVerfasst am: 06. Okt 2003 13:51   Titel: Installation von GTK 2.2.4

Hi,

beim Versuch unter SuSE Linux 8.2 das neueste GTK 2.2.4 zu installieren tritt bei mir das folgende Problem auf:
Gemäß der Anleitung auf der Website www.gtk.org habe ich zuerst die neueste Version der GLIB 2.2.3 Bibliothek installiert, was auch noch problemlos funktionierte. Nach der ebenfalls erfolgreichen Installation von PKG-Config 0.15.0 sollte als nächstes laut der Anleitung PANGO 1.2.5 installiert werden, wobei jedoch nach dem Aufruf von "./configure" in der Shell folgende Fehlermeldung auftrat:

checking for GLIB - version >= 2.1.3...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.

Wie die Fehlermeldung sagt, habe ich die LD_LIBRARY_PATH Variable mittels "export LD_LIBRARY_PATH=/usr/local/glib-2.0" geändert und in der "/etc/ld.so.conf" den Pfad "/usr/lib/" eingetragen und "ldconf" ausgeführt. Auch das Deinstallieren der alten GLIB Version 1.2 mittels YaST 2, die mit SuSE 8.2 installiert wurde, hat keine Abhilfe gebracht.
Was muss ich tun um PANGO zu installieren?


Danke,

Markus
 

muellnew
Gast





BeitragVerfasst am: 06. Okt 2003 14:25   Titel: Re: Installation von GTK 2.2.4

Hi,

GLIB2 ist bei SuSE auf mehrere RPMs aufgeteilt - bitte alle Pakete deinstallieren (falls installiert)

rpm -e --nodeps glib2-doc
rpm -e --nodeps glib2-devel
rpm -e --nodeps glib2

+ ev. nochmal ein 'make install' in den GLIB 2.2.3-Sourcen ausführen

... dann sollt's funktionieren!

A propos, die Pakete glib und glib-devel in Version 1.2 sind unabhängig von glib2, d. h. die können
ruhig installiert bleiben.
 

ACME
Gast





BeitragVerfasst am: 07. Okt 2003 16:26   Titel: Re: Installation von GTK 2.2.4

Hi,

damit funktioniert es.


Vielen Dank,

Markus
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy