Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
xtraceroute-0.9.1 fehler bei ./configure (SuSE 8.2)

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
chris
Gast





BeitragVerfasst am: 20. Okt 2003 1:05   Titel: xtraceroute-0.9.1 fehler bei ./configure (SuSE 8.2)

gleich vorweg: ich bin linux-newbie.

zum prob: ich versuche schon seit drei tagen xtraceroute-0.9.1 zum laufen zu bringen.
nach zwei behobenen fehlern die das ./configure ausspuckte, bin ich jetzt aber mit meinem linux-anfänger-latein am ende. jedes mal kommt folgende ausgabe bei ./configure:

--------------------------------------------------------------------
[...]
checking for nl_langinfo and CODESET... yes
checking for LC_MESSAGES... yes
checking for bison... no
checking whether NLS is requested... yes
checking whether included gettext is requested... no
checking for GNU gettext in libc... yes
checking for traceroute... /usr/sbin/traceroute
checking for host... /usr/bin/host
checking for gtk-config... /usr/bin/gtk-config
checking for GTK - version >= 1.0.0... yes
checking for gdk-pixbuf-config... /opt/gnome/bin/gdk-pixbuf-config
checking for GDK_PIXBUF - version >= 0.8.0... yes
checking GL... no
checking Mesa... no
checking Mesa with pthreads... no
configure: error: Cannot find proper gtkgl version
--------------------------------------------------------------------

ich habe erstmal gegoogelt und in einer SuSE-Mailinglist gefunden, dass man angeblich das paket gtkglarea braucht (zwischen version 0.8x und 0.9x hat der autor mal vom paket gtkgl auf gtkglarea umgestellt). so weit, so gut. gtkgl gibts anscheinend garnicht (mehr?) für SuSE, und gtkglarea war eh schon die ganze zeit installiert (habs aber natürlich nochmal neu installiert, um ganz sicherzugehen).

eben hab ich dann noch herausgefunden, dass man die libgtkgl.so.5 braucht, die bei den aktuellen versionen von gtkglarea wohl nicht dabei ist (hab sie auch bei mir in /usr/lib nicht gefunden). ich dachte schon, ich hätte endlich den fehler. also hab ich mir eine ältere gtkglarea version (1.2.2-2) installiert. nun hab ich auch die libgtkgl.so.5 in /usr/lib.
xtraceroute lässt sich aber immernoch nicht konfigurieren. jedesmal kommt derselbe fehler bei ./configure

bei SuSE 8.2 wird standardmäßig version 0.9.0 von xtraceroute als rpm mitgeliefert. die läuft auch einwandfrei (wenn man das suse-rpm installiert).
zum spass habe ich dann aber mal versucht den sourcecode von 0.9.0 und auch den von irgendeiner 0.8er version mit ./configure zu konfigurieren.
ergebnis: genau derselbe fehler (configure: error: Cannot find proper gtkgl version)

ich hoffe es kann jemand helfen.

mfG
 

jj
Gast





BeitragVerfasst am: 20. Okt 2003 17:50   Titel: Re: xtraceroute-0.9.1 fehler bei ./configure (SuSE 8.2)

Hallo chris,

auf http://www.dtek.chalmers.se/~d3august/xt/ wird Dir gesagt, was genau Du brauchst und wo Du es kriegst.

gruss
jj

P.S.: Hab ich uebrigens mit google gefunden - nach xtrceroute suchen, gleich der erste Treffer ist die homepage
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy