Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit GRUB

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Gast






BeitragVerfasst am: 28. Apr 2004 14:08   Titel: Probleme mit GRUB

Hallo!

Ich habe mir Suse 9.0 Professional installiert und ein Problem mit dem Bootmanager GRUB.

Während der Installation gibt es keine Probleme und auch nach einem Reboot komme ich immer problemlos in Linux. Sobald ich allerdings zwischendurch auch nur einmal Windows gebootet habe und anschließennd wieder Linux starten möchte, lande ich nicht im GRUB-Bootmenü, sondern auf der GRUB-Eingabeaufforderung.

Das Problem läßt sich immer wieder reproduzieren, egal ob GRUB auf Diskette oder der Festplatte installiert ist.

Kennt jemand das Problem und weiß eine Lösung dafür.

Für Tipps wäre ich sehr dankbar.

Gruß

Torsten
 

arjo1
Gast





BeitragVerfasst am: 28. Apr 2004 16:23   Titel: gast

Hatte ein ähnliches Problem, weiss aber nicht ob die Lösung bei dir
funktioniert:
Wenn die grub-eingabeaufforderung erscheint, folgendes eingeben:
root (hd0,<dein /-1>) <enter>
kernel (hd0,<dein /-1>)/boot/vmlinuz <enter>
initrd (hd0,<dein /-1>)/boot/initrd <enter>
setup (hd0) <enter>
"anpassen an deine HD"; und es sollten keine Fehlermeldungen
auftauchen.
So hat's bei mir funktioniert, hoffe bei dir auch Very Happy

Gruss arjo
 

Gast






BeitragVerfasst am: 28. Apr 2004 17:39   Titel:

Erstmal Danke für deine Antwort.

Leider kriege ich es nicht gebacken die Befehle richtig einzugeben.

Meine Partition auf der Linux installiert ist, ist hde3. Grub habe ich nicht in den MBR installiert, sondern in den Bootsektor der Partition, also in hde3.

Wie muß ich die Befehle denn eingeben? Kannst du mir die genaue Befehlszeile aufschreiben? Das wäre sehr nett, bin halt ein ziemlicher Linux-Newbie. Embarassed

Gruß

Torsten
 

arjo1
Gast





BeitragVerfasst am: 28. Apr 2004 18:51   Titel: Gast

Wahrscheinlich ist es das Beste, mit der SuseCD nochmal zu
booten, auf Update zu gehen und Grub in den MBR zu
installieren. Suse müsste dann automatisch einen Eintrag
für Windows anlegen.
Mein Vorschlag funktioniert ebenfalls nur mit Grub im MBR.

Viel Spass noch
arjo
 

Bephep



Anmeldungsdatum: 13.04.2004
Beiträge: 50

BeitragVerfasst am: 28. Apr 2004 20:15   Titel: Bephep

SuSE 9 in den mbr, da würde ich vorsichtig sein. Ich habe die SuSE 9 von Computer Bild auf eine Festplatte mit Win 98 SE installiert und dann war im grub Win nicht mehr zu starten.
 
Benutzer-Profile anzeigen Private Nachricht senden

root_tux_linux



Anmeldungsdatum: 07.12.2003
Beiträge: 537
Wohnort: Schweiz

BeitragVerfasst am: 28. Apr 2004 23:32   Titel:

Also mit Grub in der Partition anstelle des MBR hab ich auch nur schlechte erfahrung gemacht, seit dem mach ich sowohl lilo als auch grub nur in den MBR... wenn was ist einfach MBR fixen und gut ist
 
Benutzer-Profile anzeigen Private Nachricht senden MSN Messenger

chlor
Gast





BeitragVerfasst am: 29. Apr 2004 7:24   Titel:

auf der kommandozeile schreibst du grub mit

grub-install /dev/hda

in den mbr der ersten festplatte, dann mußt du nur noch die menu.lst konfigurieren, wenn das noch nicht geschehen ist, dafür findest reihenweise howtos mit google oder der forumssuche, vorausgesetzt die alten einträge wurden alle übernommen.

hier auf prolinux z.b.:
http://www.pl-berichte.de/t_system/grub-howto.html
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy