Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
MPlayer Bildstörung bei DVD

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
christian086
Gast





BeitragVerfasst am: 02. Mai 2004 18:06   Titel: MPlayer Bildstörung bei DVD

Hi.
ich hab mir neulich den MPlayer installiert (selbst kompiliert), läuft auch gnaz gut bis auf 2 Sachen:
Der Sound geht meistens nicht (Could not open/initialze audio device -> no sound)
Der geht erst dan wenn ich den Prozess artsd beende (über shell, kill signal)
Was ist artsd un was muss ich machen um den Prozess nicht mehr abwürgen zu müssen?

Das zweite Problem betrifft das Abspielen von DVD`s.

Wenn ich in den Einstellungen unter Video den treiber xv wähle läuft der Film in Vollbild und flüssig. Nur leiter hab ich an der rechten seite des Bildes starke Bildstörungen, eine Art flimmern.
Mit dem Treiber x11 stockt der Film ab und zu, und vor allem füllt er auch im VollBildmodus nur 50% des Monitores aus. der rest ist ein dicker schwarzer Rand.

Weiss jemadn rat um zumindest eines der Probleme zu lösen??

Danke im Vorraus
 

rattenkind
Gast





BeitragVerfasst am: 03. Mai 2004 15:44   Titel:

manpage lesen schon gemacht?

mplayer -ao help
mplayer -vo help

ratte
 

Gast






BeitragVerfasst am: 03. Mai 2004 18:24   Titel:

Jetzt sehe ich ein Liste der vorhandenen Output-Treiber die ich alle schon durchprobiert habe.


Sonstige Info`s stehen da leider nicht Sad
 

rattenkind
Gast





BeitragVerfasst am: 04. Mai 2004 15:11   Titel:

Also,

artsd ist der Sounddaemon von KDE fuer KDE-Programme bzw. andere Programme, die fuer artsd kompiliert worden sind und sorgt dafuer, dass mehrere Programme gleichzeitig Sound machen koennen, denn wenn ein Programm das Sound device direkt anspricht, ist es fuer andere gesperrt. Der artsd sammelt alle ankommenden Soundrequests und schickt die gemischte Anforderung an das Device. Wenn dein mplayer mit laufendem artsd nicht funktioniert, bedeutet dass, das er dafuer nicht kompiliert wurde, oder du das falsche Sound device ausgesucht hast. (Wieso koennen die Leute eigentlich die Suche-Funktion nicht bedienen?)

Um dein Videoproblem zu loesen, muesste man mehr von deiner Soft- und Hardware wissen.

-Welche Linuxdistribution (ach man, ko****t mich das an, immer wieder diese Standardfragen zu stellen...)?
-Welche Grafikkarte?
-Welche xfree Version?
-Welcher Treiber wird fuer die Grafikkarte verwendet?
-Was sagen:
Code:

   echo "uname -a" ; uname -a
   echo "lspic" ; lspci
   echo "cat /proc/pci" ; cat /proc/pci

Bitte in einem Xterm ausfuerhen und in deiner Antwort einkopieren (in Code einschliessen nicht vergessen).

Dann kann man weitersehen.

ratte
 

christian086
Gast





BeitragVerfasst am: 05. Mai 2004 11:03   Titel:

RedHat 9.0 (hatte aber das gleiche Problem unter Fedora Core 1 auch).

Grafikkarte ist eune Matrox mga g200 an einem AGP 1x Slot(8MB VRAM 3D Beschleunigung: ka). Treiber laut XF86Config: "mga". Die Karte wird die Tage durch eine Nvidia GeForce 2 MX (32MB, TV-out) ersetzt und auch der entsprechende Nvidia Treiber installiert.

XFree Version ist laut Infozentrum 11.0

uname -a ergibt:
Code:

Linux localhost.localdomain 2.4.20-8 #1 Thu Mar 13 17:54:28 EST 2003 i686 i686 i386 GNU/Linux


den Befehl lspci findet er nicht. Auch nicht via cd /sbin;./lspci oder cd /bin; ./lspci.
(Habe bei der Installation alle Pakete mit installiert)

cat /proc/pci ergab:
Code:

PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 3).
      Master Capable.  Latency=64.
      Prefetchable 32 bit memory at 0xf8000000 [0xfbffffff].
  Bus  0, device   1, function  0:
    PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 3).
      Master Capable.  Latency=64.  Min Gnt=140.
  Bus  0, device   7, function  0:
    ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 2).
  Bus  0, device   7, function  1:
    IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 1).
      Master Capable.  Latency=64.
      I/O at 0x7cf0 [0x7cff].
  Bus  0, device   7, function  2:
    USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 1).
      IRQ 9.
      Master Capable.  Latency=64.
      I/O at 0x7800 [0x781f].
  Bus  0, device   7, function  3:
    Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 2).
      IRQ 9.
  Bus  0, device  12, function  0:
    Multimedia audio controller: ESS Technology ES1969 Solo-1 Audiodrive (rev 1).
      IRQ 10.
      Master Capable.  Latency=64.  Min Gnt=2.Max Lat=24.
      I/O at 0x6000 [0x603f].
      I/O at 0x6400 [0x640f].
      I/O at 0x6800 [0x680f].
      I/O at 0x7000 [0x7003].
      I/O at 0x7400 [0x7403].
  Bus  0, device  16, function  0:
    Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 16).
      IRQ 9.
      Master Capable.  Latency=64.  Min Gnt=32.Max Lat=64.
      I/O at 0x5800 [0x58ff].
      Non-prefetchable 32 bit memory at 0xfedffc00 [0xfedffcff].
  Bus  1, device   0, function  0:
    VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP (rev 3).
      IRQ 11.
      Master Capable.  Latency=128.  Min Gnt=16.Max Lat=32.
      Prefetchable 32 bit memory at 0xde000000 [0xdeffffff].
      Non-prefetchable 32 bit memory at 0xfebf8000 [0xfebfbfff].
      Non-prefetchable 32 bit memory at 0xfe000000 [0xfe7fffff].


Danke für die Hilfe
 

christian086
Gast





BeitragVerfasst am: 07. Mai 2004 19:37   Titel:

mit "danke für die Hilfe" wollt ich mich nur schon mal für die erbrachte Hilfe bedanken.
Weiter bin ich nich net Sad

Will aber net hetzen oder so, dachte nur das dass evtl. missverstanden wurde

MfG
Christian
 

christian086
Gast





BeitragVerfasst am: 08. Mai 2004 22:34   Titel:

das Problem hat sich mit der neuen Grafikkarte gelöst
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy