Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme nach Kernel-Update über YOU bei Suse Linux 9.1 Prof.

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Gast






BeitragVerfasst am: 04. Mai 2004 23:14   Titel: Probleme nach Kernel-Update über YOU bei Suse Linux 9.1 Prof.

Hallo!

Vielleicht kann mir jemand einen Tipp bei der Lösung meines Problems geben.

Ich habe vor ein paar Tagen Suse Linux 9.1 Professional installiert, was auch relativ wenig Probleme bereitet hat. Ich habe dann „fleissig“ über YOU die von Suse zur Verfügung stehenden Patches/Updates eingespielt.

Heute habe ich über YOU ein Kernel-Update herunter geladen, was von YOU/YAST2 anschließend installiert wurde. Besondere Hinweise für dieses Update konnte ich YOU nicht entnehmen (falls ich sie nicht übersehen habe).

Nachdem ich den Rechner anschließend neu gestartet hatte, bin ich nicht mehr zum graphischen Login gelangt. Mit „F2“ habe ich dann in die „Details“ umgeschaltet. Dort kann ich mich dann auch über die Konsole einloggen.

Da ich bisher kaum Linux-Kenntnisse besitze würde ich gerne wieder mein ursprüngliches System mit dem graphischen Login und KDE als Oberfläche wiederherstellen (die tieferen Kenntnisse werden hoffentlich mit der Zeit kommen Smile ).

Vielleicht hat ja noch jemand das Kernel-Update über YOU mitgemacht und ist auf ähnliche Probleme gestoßen.

Im Voraus schon mal Vielen Dank!

MfG, Christian Cool
 

root_tux_linux



Anmeldungsdatum: 07.12.2003
Beiträge: 537
Wohnort: Schweiz

BeitragVerfasst am: 05. Mai 2004 7:33   Titel:

Das wird nicht wirklich am Kernel liegen...

Wenn du willst dass das System beim Starten X + GUI startet schau dir mal die inittab an...

Einloggen beim Promt als root... dann mit einem editor (z.B. vi) inittab anschauen z.B.

suse login: root
Passwort: deinpasswort

vi /etc/inittab

Schau ob bei id:3:initdefault: ein 3 oder ein 5 steht!
Wenn 3 steht drücke I (dann kannst du die Datei bearbeiten) und schreibst anstelle eines 3 ein 5 rein damit es so aussieht...

Vorher: id:3:initdefault:
Nachher: id:5:initdefault:

Jetzt drückst du ESC und dann :wq

Nun rebootest du den rechner mit dem Befehl reboot und jetzt sollte dein System wieder wie am Anfang laufen...

Wenns nicht geht meld dich wieder Wink
 
Benutzer-Profile anzeigen Private Nachricht senden MSN Messenger

Gast






BeitragVerfasst am: 05. Mai 2004 9:07   Titel: Re: Probleme nach Kernel-Update über YOU bei Suse Linux 9.1 Prof.

Anonymous hat folgendes geschrieben::
Hallo!

Vielleicht kann mir jemand einen Tipp bei der Lösung meines Problems geben.

Ich habe vor ein paar Tagen Suse Linux 9.1 Professional installiert, was auch relativ wenig Probleme bereitet hat. Ich habe dann „fleissig“ über YOU die von Suse zur Verfügung stehenden Patches/Updates eingespielt.

Heute habe ich über YOU ein Kernel-Update herunter geladen, was von YOU/YAST2 anschließend installiert wurde. Besondere Hinweise für dieses Update konnte ich YOU nicht entnehmen (falls ich sie nicht übersehen habe).

Nachdem ich den Rechner anschließend neu gestartet hatte, bin ich nicht mehr zum graphischen Login gelangt. Mit „F2“ habe ich dann in die „Details“ umgeschaltet. Dort kann ich mich dann auch über die Konsole einloggen.

Da ich bisher kaum Linux-Kenntnisse besitze würde ich gerne wieder mein ursprüngliches System mit dem graphischen Login und KDE als Oberfläche wiederherstellen (die tieferen Kenntnisse werden hoffentlich mit der Zeit kommen Smile ).

Vielleicht hat ja noch jemand das Kernel-Update über YOU mitgemacht und ist auf ähnliche Probleme gestoßen.

Die Lösung ist denkbar einfach:
Log In as root, dann init 3, dann nvidia installer --uninstall &
dann gehe in dein Verzeiczhnis in dem die Nvidia Treiber liegen, solltest du die Treiber via YOU geladen haben gehe zu www.nvidia.com und sauge sie dir.
Jetzt installierst du die Treiber mit sh NVidia-installer.rpg*
dann sax2 -m 0=nvidia
dann Einrichten und zum Schluss init 5

und schwups schon funktioniert alles wieder


Gruß

Uwe

Im Voraus schon mal Vielen Dank!

MfG, Christian Cool
 

Alan
Gast





BeitragVerfasst am: 05. Mai 2004 15:20   Titel:

Hallo "Gast",

kann es sein, dass du bei einem früheren Online-Update den NVidia-Treiber installiert hast?
Wenn ja, musst du nach einem Kernel-Update den Treiber erneut laden.
Ich denke am einfachsten für dich ist, wenn du folgendermassen vorgehst:
1. Da du ja kein graphisches Login mehr hast, meldest du dich als root in der Textkonsole an
2. Per Kommando "init 3" in den Runlevel 3 wechseln
3. sax2 aufrufen
4. Einstellungen vornehmen und evtl. 3D-Beschleunigung deaktivieren
5. Einstellungen testen und speichern
6. Yast beenden
7. Zck. in den Runlevel 5 mit "init 5"
Jetzt solltest du deine graphische Anmeldung wieder sehen.
Wenn du den NVidia Treiber wieder installieren willst, musst du ein Online-Update ausführen und die bereits installierten Updates anzeigen lassen.
Dann musst du beim NVidia-Installer den Status auf aktualisieren setzen.
Übrigens: die Schritte 1-7 kannst du dir sparen, wenn du die Text-Version von Yast und dem Online-Update verwendest, aber ich denke das wird dann ein wenig komplizierter.

Viel Erfolg beim Ausprobieren und lass uns das Ergebnis wissen
Alan
 

Gast






BeitragVerfasst am: 05. Mai 2004 22:55   Titel:

Hallo!

Danke für Eure Tipps!

Bevor ich heute hier ins Forum geschaut habe, hatte ich noch mal ein wenig herumexperimentiert. Und so ähnlich wie Alan es beschrieben hat bin ich auch vorgegangen. Die eingeschaltete 3D-Beschleunigung meiner GeForce 4 - Karte hatte für die Probleme gesorgt (x-server ließ sich ja nicht mehr starten). Also deaktiviert (war einfach mal so ein Versuch von mir, nachdem sich mit eingeschalteter Beschleunigung keine neue Konfigurationsdatei abspeichern ließ), graphische Oberfläche für Download bzw. Aktualisierung des nvidia-Treibers genutzt und nun funktioniert wieder alles wie zuvor!

Also nochmals Vielen Dank für die Tipps!!! Smile

Liebe Grüsse, Christian Very Happy

P.S. Ich bin froh wieder im Internet surfen zu können, ohne mir event. so einen "Microsoft-Wurm" einzufangen! Cool
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy