Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
gtk+ installiern unter suse 8.0pro

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
InFiniTy



Anmeldungsdatum: 04.05.2004
Beiträge: 2

BeitragVerfasst am: 05. Mai 2004 22:32   Titel: gtk+ installiern unter suse 8.0pro

hiho leute,
bin neu hier und nen ziemlicher linux newbie, bastel jetz seit einer woche mit linux rum, vector linux 4.0 soho, hab auch suse 8.0 pro zuhause liegen und hab des im moment drauf, aba das prob is jetz dass bei suse keine aktuellen libs zum compilen dabei sind (gtk+, pango,glib usw), und da ich etz den ed2k-gui compilen will und der auf gtk basiert geht nix, also erst gtk installn, hab die ganzen vorherigen packete (pango,glib,atk usw.) runtergeladen,compiled und installed, hat alles hingehaun (nachdem ich den pkg-config 0.15 installiert hab), aba jetz komm ich zu meinem problem, ich hab pango 1.4.0 installiert, aba in da gtk+ install steht dass pango 1.2.0 gebraucht wird, und das hat mir gtk auch in der config durch diese fehlermeldung al'a:
checking For sufficiently new FreeType (at least 2.0.1)... yes
configure: error: Pango 1.2.0 and Xft backend is required for x11 target
gezeigt. ich hab mir also pango 1.2 gesaugt und auch noch installiert (war viielleicht der fehler an sich), dann kam diese meldung:
checking for pkg-config... /usr/local/bin/pkg-config
checking for glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0... Requested 'pango >= 1.4.0' but version of Pango is 1.2.0

configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
so, nachdem das dann kam hab ich mit make uninstall beide pangos weggehaun und zuerst 1.2 installiert, getestet, ging net, dann runter dann 1.4 drauf und ging logischweise auch wieda net.
so, und da ich noch net rausgefundn und gepeilt hab wie des mit den pfaden geht usw. oder obs ja überhaupt an dem oder an was ganz anderem liegt bitte ich euch ma um hilfe Very Happy

hoffe ihr könnt mir helfen, will net scho wieda meinen rechner plätten und ne andere distri aufziehn.

bye infi
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy