Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
dateien mit umlauten

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
mrvim
Gast





BeitragVerfasst am: 06. Mai 2004 14:11   Titel: dateien mit umlauten

Hallo Leute,

ich habe 2 linux-rechner einmal sue 9.1 und einmal suse 8.1.
wenn ich von dem suse 9.1 rechner dateien mit umlauten mittels scp auf den anderen kopiere, werden die umlaute nicht korrekt dargestellt. wie geht sowas? und wie kann ich das ändern? das ganze hat nichts mit samba zutun...

im detail:

auf dem 9,1 rechner eine datei erstelt: touch düse.txt
danach scp düse.txt root@192.168.0.2:/root/.
dann schau ich auf dem zielrechner nach und dort wird das ü nicht richtig dargestellt.

gruss und danke.................
 

mrvim
Gast





BeitragVerfasst am: 06. Mai 2004 14:26   Titel: re umlaute

hmm... ok...

habe etwas herausgefunden:

putty hat die umlaute falsch dargestellt. in der normalen bash wird alles korrekt angezeigt.
es bleibt aber das problem, dass die dateien mit den umlauten unter windows falsch angezeigt werden (putty oder über einen samba-share).

imklartext heisst das unter linux sehen die umlaute korrekt aus unter windows nicht. lege ich allerdings eine datei von windows aus auf dem share an, werden die umlaute korrekt angezeigt. lege ich die umlaute von linux aus an, werden sie nicht richtig unter windows angezeigt....

thanks for help
 

Scory



Anmeldungsdatum: 16.04.2004
Beiträge: 188

BeitragVerfasst am: 06. Mai 2004 20:13   Titel:

Im Klartext heißt das, daß Umlaute von Zeichensatz zu Zeichensatz verschiedene Codes haben (weswegen ja auch davon abgeraten wird, Umlaute in Dateinamen zu verwenden). Es gibt ca. elfundneunzige Zeichensätze (die heißen UTF-8, ISO-8859-1, ISO-8859-2 usw., Windows-1252, OEM IBM-xx, etc.pp.), und wenn man in einem Dateisystem den einen, in einem anderen Dateisystem den anderen Zeichensatz verwendet, dann hat man Problem beim Übertragen der Dateien. Dazu kommt noch das Problem, welchen Zeichensatz der aktuelle "Viewer" hat; das ist beispielsweise die Konsole, oder ein SSH-Client, oder ein Browser (da kannst Du oben den Zeichensatz auswählen) oder oder oder - auch dort gibt es beliebig viele Möglichkeiten.

Du mußt herausfinden, welche Zeichensätze Du auf welchen Dateisystemen verwendet hast (das hast Du mal selbst festgelegt, wahrscheinlich aber einfach mal auf Return gehauen ohne zu lesen), damit Du die Clients entsprechen einstellen kannst. "Falsch" stellt niemand die Umlaute dar - sondern nur so, wie der Zeichencode in der aktuellen Einstellung aussieht.
 
Benutzer-Profile anzeigen Private Nachricht senden

mrvim
Gast





BeitragVerfasst am: 07. Mai 2004 0:42   Titel: hmmm......

hallo und danke erstmal,

na klar, die darstellung ist natürlich niemals falsch. stell dir ein heterogenes neztwerk vor.
einige leute arbeiten mit windows einige ausschliesslich mit linux.
so, die linux leute erzeugen datein, die die windows leute lesen müsen, und die windows leute erstellen dateien, die die linux leute lesen muessen.
man kann die leute leider nich dazu zwingen, keine umlaute zu verwenden, da viele dateien von dritten erhalten, die umlaute enthalten.
wie löst ihr das problem, wenn ihr einen linux-samba-server habt und linux-heinis und windows-heinis drauf zugreifen????????
ich habe keine lust auf sprüche von den windows-heineis.. "was ist denn das für ein scheiss dateiname von dem linux-heini"!!!!!

also linux-heinis und windows-heinis sollen eine konsistente gemeneinsame grundlage haben.... geht das?

gruss mrvim..... es ist wirklich wichtig.... habe keine lust auf win 2003 mit avtive-directory.... Wink
 

Scory



Anmeldungsdatum: 16.04.2004
Beiträge: 188

BeitragVerfasst am: 07. Mai 2004 12:02   Titel:

Das allerwichtigste wird erstmal sein (und ist ggf. auch schon die Lösung), daß Du die einzelnen Freigaben und Partitions mit dem character set mountest, wie es angelegt ist.

Dafür stehen dir die Parameter "nls=..." und "iocharset=..." zur Verfügung. Gib "man mount" ein und probiere mal aus, was sich machen läßt.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy