Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Samba

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Keine-Ahnung
Gast





BeitragVerfasst am: 27. Mai 2004 15:50   Titel: Samba

Hi,

ich hab kaum Ahnung von Linux.
Mein Problem: Wenn ich den Samba-Server einrichte und von einem anderen PC auf die Freigegebenen Ordner zugreifen will, werd ich nach einem Passwort gefragt. Welches muss ich da eingeben? Bei der Einrichtung des Servers wurde auch nie eins eingestellt.

Bitte helft mir

Danke
 

cruxnor



Anmeldungsdatum: 17.05.2004
Beiträge: 19

BeitragVerfasst am: 27. Mai 2004 17:39   Titel:

Hi,

if(keine_Ahnung == true) {

http://www.google.de/search?q=samba+swat&ie=UTF-8&hl=de&btnG=Google-Suche&meta=
http://www.google.de/search?hl=de&ie=UTF-8&q=webmin&btnG=Suche&meta=

}

ciau, cruxnor
 
Benutzer-Profile anzeigen Private Nachricht senden

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 27. Mai 2004 18:15   Titel:

Versuch es mal mit:
public = yes
in der smb.conf

Aber: lesen bildet ... Wink

Und: poste bei solchen Fragen am besten immer die jeweilige Konfiguartionsdatei (ohne Kommentare!), denn es gibt einige Ursachen, warum dieses oder jenes so funzt oder nicht funzt.

Gruß
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 27. Mai 2004 19:23   Titel:

smbpasswd -a <user>
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Keine-Ahung
Gast





BeitragVerfasst am: 28. Mai 2004 11:31   Titel: geht net

Hi,
um die Passwort abfrage abschalten zu können muss ich doch das obere tun. Ich soll public = yes sagen. Ich hab aber kein Public = x.

Hier mein Config-File:

Code:

[global]
   workgroup = TEST2
   os level = 65
   time server = Yes
   unix extensions = Yes
   encrypt passwords = yes
   map to guest = Bad User
   printing = CUPS
   printcap name = CUPS
   socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
   wins support = No
   veto files = /*.eml/*.nws/riched20.dll/*.{*}/
   server string = Sambaserver unter Suse Linux 8.2 Prowwert
   add user script = /usr/sbin/useradd -c Machine -d /dev/null -s /bin/false  %m$
   domain master = false
   domain logons = no
   local master = yes
   preferred master = yes
;;   ldap server = 127.0.0.1
   security = user
   load printers = no
[root]
   comment = Root-Verzeichnes
   path = /
   browseable = yes
   guest ok = no
   printable = no




Was muss ich ändern??

Gruß
 

ChristianH.
Gast





BeitragVerfasst am: 28. Mai 2004 12:28   Titel:

Wie Du hast kein public = x ????
dann füg einfach eine Zeile ein mit "public = yes"
 

Keine-Ahung
Gast





BeitragVerfasst am: 28. Mai 2004 12:46   Titel: Ok, aber

Ja, das Klappt für einzelne Freigaben. Aber wie mache ich, dass sich das auf Alles Freigaben bezieht?
ICh hab mal versucht es in den [global]-Teil zu schreiben, klappt aber net.

Gruß
PS: Danke für die schnelle Antwort
 

Darki



Anmeldungsdatum: 22.06.2004
Beiträge: 7

BeitragVerfasst am: 06. Jul 2004 14:12   Titel:

dann editiere deine smb.conf folgendermassen.

vi smb.conf

das ist der befehl damit du mit hilfe eines editors die datei umschreiben kannst.
vi ist ein editor unter linux der mir gut gefällt.

nun kannst du für alle freigaben dein public=yes setzen!

wenn du den befehl ausgeführt hast kannst du mit dem editor das machen muss nur wissen wie du mit dem ding umgehst!

gruß DarkRider
 
Benutzer-Profile anzeigen Private Nachricht senden

rbtux



Anmeldungsdatum: 23.06.2004
Beiträge: 69

BeitragVerfasst am: 07. Jul 2004 16:38   Titel:

Kann es vielleicht daran liegen?

guest ok = yes ist gleich public = yes

guest ok = no ist gleich public = no

guest ok = no und public = yes ist nicht gerade eine sinvolle konfiguration


schalte mal guest ok auf yes!

Anderfalls füge mit smbpasswd -a einen benutzer hinzu!

PS: Wenn du auf dem Windows Client zb ein Benutzer test mit dem passwort geheim hast, kannst du mit smbpasswd -a test den Benutzer anlegen und danach geheim als password vergeben. wenn nun in der valid users - Eigenschaft der Freigabe der name test steht, muss wenn du mit test angemeldet bist kein passwort angeben werden, wenn du auf das netzwerklaufwerk verbinden willst
_________________
Computer führen dazu, dass man die alten Fehler jetzt 100 mal schneller macht Wink
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy