Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme beim 2.Kernel

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Albert
Gast





BeitragVerfasst am: 01. Jun 2004 16:31   Titel: Probleme beim 2.Kernel

Hallo Leute,

Ich habe 2 zusätzliche Kernel heruntergeladen,weil ich nicht weiß,ob meine WebCam Logitech pro 4000 mit dem Treiber pwc mit den Kernel zusammenarbeiten können.

Nun,als 2.Kernel benutze ich den 2.4.26-Kernel.Doch beim Booten werden so gut wie gar keine Module geladen.Kein Internet,kein Sound,kein /dev/video0 einfach nix.
Was mache ich falsch?

P.s: der erste Kernel ist ein 2.4.20er. Distro ist Slackware.

Mein Weg zur Compilation lautet so :

Kernel entpackt nach /usr/src
hinzu kommt ein Link ls -s /usr/src/linux-2.4.26 /usr/src/linux

Treiber pwc nach /usr/src/linux-2.4.26/drivers/usb kopiert
Anderer Treiber nach /lib/modules kopiert

in /etc/modules.conf einige Zeilen hinzugefügt

dann mit make oldconfig
make menuconfig--> Module ausgewählt
make bzImage usw usw
cp arch/i386/boot/bzImage/neuer Kernel
lilo aufgerufen

Das war's

Kann mir jemand sagen,warum keine Module geladen werden...

Danke

Albert
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 01. Jun 2004 16:39   Titel:

hi

hast du bevor du
make oldconfig
machst auch die alte
.config
aus /usr/src/1.kernel
nach /usr/src/2.kernel
kopiert?

hast du auch ein
make modules modules_install
gemacht?

bzw. mit mkinitrd
ein initrd.img erstell?

hast du den neuen kernel auch in der /etc/lilo.conf
eingetragen und dann erst lilo aufgerufen.

oder ist das alles in
>>make bzImage usw usw
mit dabei ?
bzw. glaub ich das der befehl
make bzImage usw usw
falsch ist.
bei den make optionen gibts kein usw!! Wink

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Albert
Gast





BeitragVerfasst am: 01. Jun 2004 16:48   Titel:

Hallo Hans,

Vielen Dank für deine Antwort!!
Tja,da sehe ich schon meinen Fehler : die alte.config zum neuen Kernel zu kopieren..

mit mkinitrd habe ich noch nie gehört! Wie erstelle ich denn initrd.img??

Albert
 

Albert
Gast





BeitragVerfasst am: 01. Jun 2004 16:53   Titel:

Ich habe noch etwas vergessen :

die alte Config liegt bei mir NICHT im /usr/src...
liegt sie denn in /boot/ (alter Kernel,mit dem ich zur Zeit arbeite)..??

Albert
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy