Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Slackware: Fehlende Lib:libXinerama.so

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
FR1



Anmeldungsdatum: 17.06.2004
Beiträge: 7

BeitragVerfasst am: 18. Jun 2004 13:32   Titel: Slackware: Fehlende Lib:libXinerama.so

Hallo!

Nun treffen ich zum 3. Male auf ein Problem. nach der installation (mit installpkg) von k3b, bricht das programm mit folgender fehlermeldung ab:
k3b: error while loading shared libraries: libXinerama.so: cannot open shared object file: No such file or directory

Problem ist klar! dies geschah auch, als ich SIM als Slakware paket installiert hatte. Bei SIM habe ich es dann von source kompeliert mit --disable-libXinerama.

Nun möchte ich dies nicht noch einmal machen, da mir dieser workaround auf dauer zu zeitaufendwig ist (gerade bei großen Programmen).

Bisher habe ich rausgefunden, dass die besagte lib in dem paket Xfree86-devel enthalten sein müsste. Ein kurzer blick in pkgtools enthüllte, dass das paket installiert ist!

Nach einigem googlen, stieß ich auf eine seite, die meinte, man müsse version 4.4.0 instalieren.
Also installierte ich swaret und versuchte es mit:
swaret --upgrade Xfree86
,was nur zu folge hatte:

swaret 1.6.2-1

Listing available Packages matching Keyword: Xfree86...
New: xfree86-4.3.0-i486-6 (15565 kB) - Installed: xfree86-4.3.0-i486-5

Upgrade xfree86-4.3.0-i486-5 to xfree86-4.3.0-i486-6? (y/n/A/Q): [y]n


Kann mir bitte einer bei dieem problem weiterhelfen???

Thnx && CU Dennis
 
Benutzer-Profile anzeigen Private Nachricht senden

chaos



Anmeldungsdatum: 04.07.2002
Beiträge: 16

BeitragVerfasst am: 18. Jun 2004 22:09   Titel:

Bei --current hab ich mit selbstgebautem k3b keine Probleme.....

Aber in testing oder extra liegen sogar fertige k3b Pakete.

ciao
chaos

PS --current verwendet inzwischen den xorg Server, die zugehörigen Pakete heißen x11-6.7.0-i486-4
_________________
Slackware will never die!
 
Benutzer-Profile anzeigen Private Nachricht senden

FR1



Anmeldungsdatum: 17.06.2004
Beiträge: 7

BeitragVerfasst am: 24. Jun 2004 10:45   Titel:

habe gestern mit swaret das upgrade zu current gemacht. hat alles 1a geklappt .... nun funktioniert auch alles.

das einzig komisch ist, dass, obwohl ich k3b bei linuxpackages.net für 9.1 runtergeladen habe, dass libXinerama.so schon gebraucht wurde!

CU && Thnx
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy