Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
CD und USB Problem!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
robwag



Anmeldungsdatum: 24.07.2004
Beiträge: 31

BeitragVerfasst am: 04. Aug 2004 11:18   Titel: CD und USB Problem!

Knoppix 3.4
Eigentlich läuft's wunderbar, aber wenn ich eine CD einlege und öffnen will:

mount: Gerätedatei /dev/cdrom existiert nicht
Please check that the disk is entered correctly.

(gut, dass der letzte Satz da schon steht, sonst würde ich ihn jetzt sicher hier von jemandem hören Wink )
Aber ich habe doch auch von CD gebootet und installiert, und auch ansonsten erkennt das
System alle Hardware (Festplatten, Tastatur, Maus, Netzwerkkarte etc. korrekt)?
Vielleicht irgendwas mit DMA-Modus (an oder aus)?
Beim booten wird nämlich neben den HD's auch das CD-Rom (hdc) mit DMA eabled.
Weiss aber nicht mehr, wo ich die Einstellung finde, nur als root?
Ist übrigens ein Uraltlaufwerk.

2. wenn ich meine externe USB-HD anschliesse, wird diese zwar gemounted,
sda1-4 ( obwohl nur 1 part.), aber wenn ich auf eine dieser Part. gehe kommt:
Laufwerk konnte nicht eingebunden werden.
Die Fehlermeldung war:
/dev/sda4: Eingabe-/Ausgabefehler
mount: /dev/sda4: Konnte den Superblock nicht lesen

Treiber? aber wird doch erkannt?

Ich will ja nicht viel von dem OS, aber diese beiden Sachen müssen auf jeden Fall funzen,
vielleicht hat jemand einen Tipp?
Knoppix-Forum (linuxtag) scheint ja erst am 28. wieder online zu sein....

thanx
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 04. Aug 2004 12:31   Titel:

CD-ROM
Poste mal was in der Datei /etc/fstab steht.

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

robwag



Anmeldungsdatum: 24.07.2004
Beiträge: 31

BeitragVerfasst am: 04. Aug 2004 14:45   Titel:

aber gern:

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hdd2 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hda1 none swap defaults 0 0
# Added by KNOPPIX
/dev/hda2 /mnt/hda2 vfat noauto,users,exec,umask=000 0 0
# Added by KNOPPIX
/dev/hdd1 none swap defaults 0 0


Das ist jetzt ohne angeschlossene USB-HD (Kabel ist gerade oben)
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 04. Aug 2004 15:33   Titel:

entweder
Zitat:
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0


in Spalte eins /dev/cdrom ersetzen durch /dev/hdc
...hat den Nachteil das bei vielen Programmen der Pfad in deren
Einstellungen geändert werden muß.

oder
Zitat:
mount: Gerätedatei /dev/cdrom existiert nicht

Link auf /dev/hdc anlegen (der bei Dir kurioserweise nicht vorhanden zu sein scheint)
su
ln /dev/hdc /dev/cdrom


MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

robwag



Anmeldungsdatum: 24.07.2004
Beiträge: 31

BeitragVerfasst am: 04. Aug 2004 16:14   Titel:

Link auf /dev/hdc anlegen (der bei Dir kurioserweise nicht vorhanden zu sein scheint)
su
ln /dev/hdc /dev/cdrom


Link setzen? wie und wo und was ist "su" ? Shocked
bin mal bei dem cd-icon auf Eigenschaften - Adresse und habe mnt/cdrom mit allen
möglichen Kombinationen probiert (mnt...dev...hdc...cdrom etc.).
nix geht, nur bei dev/hdc geht "öffnen mit...." auf (wenn ich dann Konquer auswähle, der
ja bei den hd's auch aufgeht, kommt wieder "öffnen mit...")
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 04. Aug 2004 17:19   Titel:

su = superuser
Wenn Du als User angemeldet bist (grafisch) und eine Konsole
aufmachst wirst Du mit "su" und dessen Passwort root.
Es sei denn Du bist schon als root angemeldet...

Zitat:
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0

/dev/cdrom ist das Geräteverzeichnis (Hardware)
/cdrom ist der Einhängepunkt oder Mountpoint (Software)

Laut Deiner "fstab" wäre das CD-Laufwerk zu mounten mit:
mount /cdrom

aber:
Zitat:
mount: Gerätedatei /dev/cdrom existiert nicht

Deshalb entweder in "fstab" aus /dev/cdrom -> /dev/hdc machen,
also die reelle Gerätedatei eintragen.
Oder den fehlenden Link der in der "fstab" eingetragen ist,
nämlich /dev/cdrom, anlegen.

Und um auf Nummer sicher zu gehen, gibt es bei Dir eine Gerätedetei
/dev/cdrom und wenn ja, worauf zeigt sie wenn sie ein Link ist?
ls -ld /dev/cd*

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

robwag



Anmeldungsdatum: 24.07.2004
Beiträge: 31

BeitragVerfasst am: 04. Aug 2004 20:59   Titel:

meinst du vielleicht dies?
root@knoppers:/home/rowa# ls -ld /dev/cd*
lrwxrwxrwx 1 root root 10 2004-07-29 16:13 /dev/cdaudio -> /dev/cdrom
brw-rw---- 1 root cdrom 24, 0 2001-04-15 02:44 /dev/cdu535

Ich steige durch diese Hieroglyphen nicht durch.

In fstab ist doch schon cdrom (...iso9660.....) ?
einfach nur eine Zeile
/dev/cdrom ohne was dahinter dazuschreiben ? oder
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0 in
/dev/hdc ändern und sichern?

Auf jeden Fall schonmal vielen Dank,
da kommt man doch von alleine nie drauf
 
Benutzer-Profile anzeigen Private Nachricht senden

robwag



Anmeldungsdatum: 24.07.2004
Beiträge: 31

BeitragVerfasst am: 04. Aug 2004 21:36   Titel:

also dev/cdrom in hdc ändern bringt auch nix.
habe zwar ein neues CD-Icon auf Desktop (hdc) aber:

mount: Falscher Dateisystemtyp, ungültige Optionen, der
»Superblock« von /dev/hdc ist beschädigt oder es sind
zu viele Dateisysteme eingehängt
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
Please check that the disk is entered correctly.

wieder dieser Superblock-mist, wie bei der usb-hd.
vielleicht doch der wurm im system?
hatte ja auch nur E/A fehler beim installieren, aber ansonsten funzt ja alles
Confused
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 04. Aug 2004 21:55   Titel:

Wenn jetzt in Deiner "fstab" in der Zeile in der /dev/cdrom stand /dev/hdc steht,
sollte nach dem Befehl
mount /cdrom
das Dateisysteem einer eingelegten CD (mit ISO 9660) über das Verzeichnis
/cdrom zugänglich sein!
Hast Du eine Daten- oder andere CD eingelegt?

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

robwag



Anmeldungsdatum: 24.07.2004
Beiträge: 31

BeitragVerfasst am: 05. Aug 2004 12:15   Titel:

also fstab sieht nun so aus:

# filesystem mountpoint type options dump pass
/dev/hdd2 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/hdc /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hda1 none swap defaults 0 0
# Added by KNOPPIX
/dev/hda2 /mnt/hda2 vfat noauto,users,exec,umask=000 0 0
# Added by KNOPPIX
/dev/hdd1 none swap defaults 0 0

mount/cdrom : Datei oder Verz. nicht gefunden
Die Ordner cdrom und mnt - hdc sind leer.
Ist auch egal, ob Daten oder Audio CD

Beim Hochfahren:
mount und unmount: fs type devfs not supported by Kernel (?)

DMA acceleration enabled hda (seagate hd)
hdc (cdrom)
hdd (ibm hd) ....nicht wörtlich, aber sinngemäß
da erkennt er das cdrom also noch.
Würde DMA bei cdrom gerne mal deaktivieren, finde es aber nicht mehr....

ansonsten wohl mal wieder was anderes installieren Confused
 
Benutzer-Profile anzeigen Private Nachricht senden

kanonenfutter
Gast





BeitragVerfasst am: 05. Aug 2004 12:55   Titel:

> also dev/cdrom in hdc ändern bringt auch nix.

bitte benutz absolute pfade (/dev/cdrom), sonst wissen wir nicht, ob du es richtig machst.

> mount/cdrom : Datei oder Verz. nicht gefunden

nach dem mount muss ein leerzeichen. ein programm "mount/cdrom" existiert nämlich nicht.

> Die Ordner cdrom und mnt - hdc sind leer.

auch hier wieder: bitte genauere angaben. mit "cdrom" bzw "mnt - hdc" kann ich nicht viel anfangen (mit letzterem wohl /mnt/hdc gemeint?)
 

robwag



Anmeldungsdatum: 24.07.2004
Beiträge: 31

BeitragVerfasst am: 05. Aug 2004 14:01   Titel:

hast natürlich Recht, aber mit mount (Leerzeichen)/cdrom kommt wieder
mount: Falscher Dateisystemtyp, ungültige Optionen, der
»Superblock« von /dev/hdc ist beschädigt oder es sind
zu viele Dateisysteme eingehängt
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
Please check that the disk is entered correctly.

und mit mnt-hdc ist Ordner/Unterordner gemeint.
Ist jetzt aber auch egal, hab´die Faxen dicke und mach die Kiste platt.
Mal sehen, ob ich mit ner anderen Distri weiter komme.
Die USB-HD ist nämlich fast noch wichtiger, als CD

Auf jeden Fall vielen Dank für eure Bemühungen!
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy