Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
squid startet nicht!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
sheva
Gast





BeitragVerfasst am: 18. Aug 2004 7:33   Titel: squid startet nicht!

hallo

habe mir das stable 2.4 vom squid runtergeladen und installiert. Nachdem ich die Konf-Datei squid.conf angepasst habe, und ich den dienst starten wollte, bekam ich eine fehlermeldung, dass der "visible_hostname" nicht vorhanden war. habe diese Zeile in der conf-datei gefunden, und habe meinen hostnamen eingegeben.jedoch zeigt er immernoch die gleiche Fehlermeldung.muss ein bestimmter TAG eingegeben werden, oder reicht nur der name meines rechners aus?

Wisst ihr weiter?

gruss
 

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 18. Aug 2004 9:48   Titel:

steht der auch in hosts drin?
 
Benutzer-Profile anzeigen Private Nachricht senden

sheva
Gast





BeitragVerfasst am: 18. Aug 2004 16:29   Titel:

ja er steht im hosts.wenn ich squid starte, kommt folgende Meldung:

FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE1): Terminated abnormally.
CPU Usage: 0.000 seconds = 0.000 user + 0.000 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 325
Aborted

folgendes steht bei mir im cfg-file bei "visible_hostname":


TAG: visible_hostname
# If you want to present a special hostname in error messages, etc,
# then define this. Otherwise, the return value of gethostname()
# will be used. If you have multiple caches in a cluster and
# get errors about IP-forwarding you must set them to have individual
# names with this setting.
#
#Default:
visible_hostname giampa

oder muss ich den Tag anders schreiben?
 

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 19. Aug 2004 7:42   Titel:

aus dem Bauch raus würde ich das mit etwas wie:
visible_hostname localhost.localdomain
probieren.

Es gab da auch mal:
unique_hostname localhost.localdomain

das brauchte squid IMHO wenn er mit anderen Proxys zusammen arbeitet

Wählt sich die Kiste ins Internet ein?
Falls ja, bekommst du doch bestimmt einen FQDN zugewiesen.
Dann benutze den mal, sofern der reverse lookup funktioniert.
Das könnte man dann bestimmt noch bei jeder Einwahl automatisieren, so wäre es dann wirklich korrekt...

Aber gehen solllte es auch so....


Gruß Max; der immer Probleme mit squid hatte....
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy