Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
dhcp + dns

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
meo
Gast





BeitragVerfasst am: 21. Aug 2004 14:57   Titel: dhcp + dns

moin,
folgendes, server SuSE9.0prof usw eigenbau; client WinXpPro. client bekommt ipadresse via dhcp, funzt auch soweit, ping intern supper.
Wird nun versucht mit dem client ins Internet zu kommen funzt dies nicht, host was ist das (not found)??? oder so ist die meldung. Also händisch dns eingegeben, und immer noch nichts.
gebe ich folgenden zweisatz auf dem server ein, geht es:
Code:

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -A POSTROUTING -t nat -s 192.168.0.124 -j MASQUERADE

Jetzt wird aber die IP vom clienten dynamisch vergeben, kommt ein zweiter und soweiter rechner dazu wäre ich ja nur mit ermitteln der jeweiligen IP beschäftig und den ganzen tag am tippen, dies kann ja nicht der weisheit letzter schluss sein.
Wie geht das ohne grösseres rumgetippe, /etc/inet.d/boot.local einträge funzen ja nur bei statischen adressen.
ginge so etwas wie
Code:
 
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -A POSTROUTING -t nat -s 192.168.0.20/125 -j MASQUERADE

aber normalerweise müsste das la schon in der dhcpd.conf eingetragen werden welcher dns genuzt wird oder?
hier meine /etc/dhcpd.conf:
Code:

authoritative ;
ddns-update-style none;
ddns-updates off;
default-lease-time 600;
log-facility local7;
max-lease-time 7200;

subnet 192.168.0.0 netmask 255.255.255.0 {
    option routers 192.168.0.1;
    range 192.168.0.20 192.168.0.125;
}

host 192.168.0.1 {
}


was tun?
gruß meo
 

meo
Gast





BeitragVerfasst am: 22. Aug 2004 13:47   Titel: dhcp

also dass mit dem dns klappt jetzt schon mal, trotzdem kommen die clienten, bzw der test client nicht ins inet.
gebe ich den onbrigen zweisatz ein funzt es, also hat dies mit MASQUERADE zu tun oder? Firewall ist deaktiviert klappt auch nicht. bin netzwerk DAU also was tun gruss usw.
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 23. Aug 2004 8:32   Titel:

hi

masquerade muss aktiviert sein damit das funktioniert
wenn du 192.168.1.0/24 schreibst gilt das für alle rechner im netz
und du kannst das script in die boot.local einfügen.

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy