Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Hilfe: Ich habe ein laufendes System geändert.

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Herb



Anmeldungsdatum: 27.08.2004
Beiträge: 1

BeitragVerfasst am: 27. Aug 2004 10:21   Titel: Hilfe: Ich habe ein laufendes System geändert.

Hallo Leute. Bin noch recht neu bei Linux und komm' grad nicht weiter. Bitte helft mir.

Zunächst mal mein Hauptproblem: Die grafische Oberfläche (kde) wird nicht mehr angezeigt.

Systembeschreibung: mehrere MS-Fenster- und Linux-Partitionen auf einer Festplatte.

Was hab' ich gemacht?: Ich wollt mal wieder mein MS-Fenster aufräumen

--> älteres Backup auf die Programmpartition eingespielt und
--> MS-Fenster 98 (ich weiß ist schon alt, aber für mich reichts) auf die Systempartition neu installiert

anschließend hab ich über die Linux-Installations-CD (Suse 9.0) gebootet - Installation - vorhandenes System starten - den Bootmanager (Grub) neu installiert (zur Ergänzung: ich hatte schon die Patches von der Suse Homepage eingespielt).

Nun dachte ich, dass alles wieder funktioniert; denkste.

Wie oben gesagt, fährt der Rechner nicht mehr in die grafische Oberfläche, sondern bleibt beim nichtgrafischen Login hängen (#bash)

Wenn ich nun erneut das vorhandene System mit der Inst.CD starte kommen folgende Meldungen:

modprobe: can't open dependencies file/lib/modules/2.4.21-99-default/modules.dep (no such file or directory)

iptables v1.2.8:can't initialize iptables table 'filter': iptables who? (do you neet insmod?)

Perhabs iptables or your kernel needs to be upgrades

Weiter erscheint die Meldung:

failed services in runlevel 5 ISDN hotplug

Und damit funktioniert auch die Internetverbindung über KInternet nicht.

Ein Ausschnitt aus dem SystemLog-File hilft vielleicht auch weiter:

Aug 27 09:23:30 linux kernel: Device not ready. Make sure there is a disc in the drive.
Aug 27 09:23:31 linux kernel: sda : READ CAPACITY failed.
Aug 27 09:23:31 linux kernel: sda : status = 1, message = 00, host = 0, driver = 08
Aug 27 09:23:31 linux kernel: Current sd00:00: sense key Not Ready
Aug 27 09:23:31 linux kernel: Additional sense indicates Medium not present
Aug 27 09:23:31 linux kernel: sda : block size assumed to be 512 bytes, disk size 1GB.
Aug 27 09:23:31 linux kernel: sda: Write Protect is off
Aug 27 09:23:31 linux kernel: sda: I/O error: dev 08:00, sector 0
Aug 27 09:23:31 linux kernel: I/O error: dev 08:00, sector 0
Aug 27 09:23:31 linux kernel: I/O error: dev 08:00, sector 2097144
Aug 27 09:23:31 linux kernel: I/O error: dev 08:00, sector 2097144
Aug 27 09:23:31 linux kernel: I/O error: dev 08:00, sector 0
Aug 27 09:23:31 linux kernel: I/O error: dev 08:00, sector 0
Aug 27 09:23:31 linux kernel: unable to read partition table
Aug 27 09:23:31 linux kernel: Device not ready. Make sure there is a disc in the drive.
Aug 27 09:23:31 linux kernel: I/O error: dev 08:00, sector 0
Aug 27 09:23:31 linux kernel: cdrom: open failed.
Aug 27 09:23:35 linux modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.21-99-default/modules.dep (No such file or directory)
Aug 27 09:23:37 linux kdm[2860]: pam_unix2: session started for user herbert, service xdm
Aug 27 09:23:38 linux resmgr[1913]: accepted connection from user root
Aug 27 09:23:38 linux resmgr[1913]: disconnect from root
Aug 27 09:24:11 linux modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.21-99-default/modules.dep (No such file or directory)
Aug 27 09:24:36 linux last message repeated 49 times
Aug 27 09:24:54 linux modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.21-99-default/modules.dep (No such file or directory)
Aug 27 09:25:43 linux su: (to root) herbert on /dev/pts/2
Aug 27 09:25:43 linux su: pam_unix2: session started for user root, service su
Aug 27 09:25:43 linux su: pam_unix2: session finished for user root, service su
Aug 27 09:25:43 linux su: (to root) herbert on /dev/pts/2
Aug 27 09:25:43 linux su: pam_unix2: session started for user root, service su

Sorry das das so viel ist, aber ich denke vielleicht hilfts bei der Hilfe

Vielen Dank im Voraus Herbert
 
Benutzer-Profile anzeigen Private Nachricht senden

arjo1
Gast





BeitragVerfasst am: 27. Aug 2004 14:00   Titel:

Deine Module passen anscheinend nicht zum laufenden kernel.
Das Einfachste dürfte für dich sein, nochmal deine Suse-dvd
als Update drüberlaufen zu lassen, und Grub ebenfalls nochmal
zu installieren, da du nicht in's Internet kommst. Du kannst natürlich
auch versuchen über die Grub-shell deinen alten Kernel (nebst
vorhandener modules) zu booten, oder über knoppix usw.
Have a lot of fun;-)
arjo

Kleiner Tip von mir: hast du mehrere Wins und nur ein Linux, nimm
besser als Bootmanager "bootmagic", denn vermutlich wirst du
dann öfter Win neu installieren als Linux; hast du nur ein Win und
mehrere Linux auf der Platte, kannst du grub nehmen (wie ich z.BWink
 

premier
Gast





BeitragVerfasst am: 01. Sep 2004 7:14   Titel: ein kleiner vorschlag...

Soweit ok aber was soll Grub mit dem Internetzugang zu tun haben..?
Grub ist der Bootloader...

ciao
 

latex



Anmeldungsdatum: 28.04.2004
Beiträge: 63

BeitragVerfasst am: 01. Sep 2004 11:02   Titel: Re: ein kleiner vorschlag...

premier hat folgendes geschrieben::
Soweit ok aber was soll Grub mit dem Internetzugang zu tun haben..?
Grub ist der Bootloader...

ciao


Eben, Grub ist der Bootloader und wurde neu installiert. Warscheinlich wurde dabei ein neuer Kernel erwischt der einwenig Probleme bereitet.
Versuch mal Grub neu zu konfigurieren und pack gleich einpaar Kernel mit rein, dann kannst du beim Booten der Reihe nach einfach Kernel für Kernel ausprobieren bis du wieder deinen funktionierenden hast Wink

Zu KDE: Einloggen und versuchen "startx" in die Konsole einzugeben um damit einen x-Server zu starten. Wenn dass nichts bringt yast im Textmodus starten und x-Server neu Konfigurieren.
Viel Glück,

mfG, latex
_________________
Erst ignorieren sie dich, dann lachen sie über dich, dann bekämpfen sie dich und dann gewinnst du!
 
Benutzer-Profile anzeigen Private Nachricht senden

arjo1
Gast





BeitragVerfasst am: 01. Sep 2004 14:14   Titel:

premier schrieb
<Soweit ok aber was soll Grub mit dem Internetzugang zu tun haben..?
Grub ist der Bootloader...>

Das bezog sich auf den ersten Teil des Satzes, da er das Update
nicht aus dem Internet ziehen kann, muss er den Kernel und auch den Bootloader von der DVD nehmen um sein System wieder mit kernel
und passenden Modulen starten zu können - ausser er kennt sich gut
mit grub aus, dann gibt es natürlich mehrere Möglichkeiten, aber die
gibt's bei Linux immer.
BTW wo ist jetzt schnell wieder der konstruktive
Teil in deinem Posting?

latex schrieb:
<Eben, Grub ist der Bootloader und wurde neu installiert. Warscheinlich wurde dabei ein neuer Kernel erwischt der einwenig Probleme bereitet.Versuch mal Grub neu zu konfigurieren und pack gleich einpaar Kernel mit rein, dann kannst du beim Booten der Reihe nach einfach Kernel für Kernel ausprobieren bis du wieder deinen funktionierenden hast>

Wie kommst du drauf, daß grub neu installiert wurde?
Beim SuSE-kernel-update wird nur der Kernel installiert, Grub muss
auch nicht neu installiert werden (wie zB. lilo).

<Zu KDE: Einloggen und versuchen "startx" in die Konsole einzugeben um damit einen x-Server zu starten. Wenn dass nichts bringt yast im Textmodus starten und x-Server neu Konfigurieren.>

Wenn wegen eines Fehlers beim Kernel-Update die Module fehlen
oder nicht dazu passen bringt ihm das gar nichts (und wird auch nicht funktionieren).

Nixdestotrotz
"Have a lot of fun"

arjo
 

latex



Anmeldungsdatum: 28.04.2004
Beiträge: 63

BeitragVerfasst am: 01. Sep 2004 17:35   Titel: Re: Hilfe: Ich habe ein laufendes System geändert.

arjo1 hat folgendes geschrieben::
Wie kommst du drauf, daß grub neu installiert wurde?


siehe hier:

Herb hat folgendes geschrieben::
... anschließend hab ich über die Linux-Installations-CD (Suse 9.0) gebootet - Installation - vorhandenes System starten - den Bootmanager (Grub) neu installiert (zur Ergänzung: ich hatte schon die Patches von der Suse Homepage eingespielt). ...


Zur Erklärung: Seine Instalation von Win98 hat den MBR überschrieben, und deshalb musste er ja grub neu installieren Wink

mfG,

latex
_________________
Erst ignorieren sie dich, dann lachen sie über dich, dann bekämpfen sie dich und dann gewinnst du!
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy