Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme beim mounten con NTFS /etc/mtab verweigert Zugriff

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
huckfinn
Gast





BeitragVerfasst am: 30. Aug 2004 13:48   Titel: Probleme beim mounten con NTFS /etc/mtab verweigert Zugriff

Ich habe hier einen Rechner mit Suse Linux 9.1
Der Rechner verweigert den Zugriff auf die
Windows-Partitionen (XP) . Und der Bootloader kann das
Windows-System auch nicht starten.

Beim mounten von Hand stellte sich heraus, daß die Datei
/etc/mtab auf das Datum 1.1. 1970 gesetzt und leer ist ist und
auch von root weder geschrieben noch gelesen werden kann.
Der mc zeigt sie als roten Eintrag ?mtab an was wohl mehr oder
weniger bedeuten soll, daß sie in einem kritischen Zustand ist.

Benutzt man den Schalter -n während des mounten kann
man die Einträge in det mtab ja umschiffen und ich bekomme
auch Zugriff auf die genannten Partitionen. Das ist,
jedoch nicht unbedingt der Sinn der Übung oder?

Alle Standard Mount- Routinen (usb stick, cdrom etc)
geben einen Fehler can't access /etc/mtab zurück.
Ein rm -f /etc/mtab ergibt das gleiche. Und ein ln -s
nach /proc/mount ist auch nicht möglich.

Was kann man tun um das System in einen normalen
Zustand hinsichtlich "mounten" zu bekommen? ..doch nicht
etwa wechseln zu fedora ?

Bye HuckFinn
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 30. Aug 2004 16:27   Titel:

hi

ich würd das system mal mit einer rettungscd oder floppy booten.
dann müsste das entfehrnen und neuanlegen der mtab funktionieren.

>>.doch nicht etwa wechseln zu fedora ?
wieso nicht? *gg* halte ich persöhnlich für besser als suse.
aber das ist ein anders thema.

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Dirk
Gast





BeitragVerfasst am: 30. Aug 2004 16:40   Titel:

Hi,

Ich nehme mal an, du hast die Download Version ( SuSE 9.1 Pers ).
Kein Zugriff auf WinXP - NTFS Partitionen , Deutet eher darauf hin, das der
NTFS Support im Kernel fehlt. Muss ich mal nachsehen, es gibt 'nen Eintrag,
welche Filesysteme der Kernel unterstützt.

Den Bootloader sollte man während der Installation per Hand prüfen,
ob die Win-Partition auch eingebunden ist. Und mit grub geht es meiner Erfahrung
nach besser als mit Lilo, obgleich dieser mittlerweile auch Win2K einbinden und
starten kann.

Ein rot gesetzter Eintrag im MC deutet nach meiner Erfahrung auf einen Link,
dessen Ziel nicht gefunden wird. ( also schon ziemlich kritisch bei der Verwaltung
des Filesystems Wink))

Du must deswegen aber nicht gleich zu Fedora wechseln, Mandrake tuts auch Wink

mfg Dirk
 

huckfinn
Gast





BeitragVerfasst am: 30. Aug 2004 17:28   Titel:

Also erst mal danke für die prompte Hilfe.

Die Aktion mit der rescure cd habe ich schon versucht
aber das schlägt ebenfalls fehl.

Ich glaube das Problem liegt tiefer. Der Grub scheint
eine falsche Partitionstabelle zu schreiben , wenn die
erste Platten Partition >= 1024 MByte ist und der
BIOS Eintrag auf AUTO und nicht auf LBA steht.
Offensichtlich läßt sich nicht nur das XP-System nicht
mehr booten sondern auch der mount Vorgang wird
beeinträchtigt. Wie das exakt funzt ist noch zu ergründen.
Die unter Linux üblichen Geräte werden über
/proc/mount Eingeträge altenativ nach einem mount
Fehler umgeleitet. .. wie geht das?

Ich habe jetzt den BIOS Parameter auf LBA gesetzt
und die WIN Systeme winken erst einmal wieder mit
all ihrem bunten Kram.

Ich muß allerdings sagen, daß der Rechner nicht mir
sondern einem Freund gehört, der reichlich nervös war
nachdem alles erst einmal nicht ging. Aber ich hatte dadurch
mal einen Einblick in das neue Suse 9.1 Personal.
Das ist ja noch schriller bunter und langsamer geworden
..ob das gut ist ? Bis Version 7.2 war ja noch alles gut aber
schon die 8. Version war furchtbar langsam ..wolln die den
XP Entwicklern den Rang ablaufen?

Ich selbst habe ein Fedora Core 2 A und bin sehr
zufrieden, obwohl es noch wenig Dokumentation
aufweist!

Also noch mal danke, bis denne HuckFinn
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy