Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
OpenLDAP installation

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
sony
Gast





BeitragVerfasst am: 21. Sep 2004 15:02   Titel: OpenLDAP installation

Hallo, ich bin Linux einsteiger und habe folgendes Problem!

Ich möchte openldap 2.2.17 auf Linux Slackware 2.4.26 installieren. Wenn ich ./configure ausführe, bekomme ich immer diese Fehlermeldung:

checking for db.h... yes
checking for Berkeley DB link (default)... no
checking for Berkeley DB link (-ldb42)... no
checking for Berkeley DB link (-ldb-42)... no
checking for Berkeley DB link (-ldb-4.2)... yes
checking for Berkeley DB version match... Berkeley DB version mismatch
expected: Sleepycat Software: Berkeley DB 3.3.11: (July 12, 2001)
got: Sleepycat Software: Berkeley DB 4.2.52: (December 3, 2003)
no
configure: error: Berkeley DB version mismatch


Ich habe aber bereit eine 4.2.52 version von Sleeycat.com heruntergeladen und installiert. Kann mir einer helfen? Aber bitte ausführlich, da ich, wie gesagt, ein Anfänger bin.

Danke im Voraus!!!
 

rattenkind
Gast





BeitragVerfasst am: 22. Sep 2004 22:16   Titel:

Zitat:
checking for Berkeley DB version match... Berkeley DB version mismatch
expected: Sleepycat Software: Berkeley DB 3.3.11: (July 12, 2001)
got: Sleepycat Software: Berkeley DB 4.2.52: (December 3, 2003)
bedeutet unmissverstaendlich, dass deine installierte Version 4.2.52 nicht passt, weil 3.3.11 verlangt wird.

Wer lesen kann, ist klar im Vorteil.

ratte
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 23. Sep 2004 12:12   Titel:

Hi!

Wahrscheinlich ist irgendwo auf dem System die Include-Datei für Version 3.x, und diese wird dummerweise vor der richtigen gefunden. Die mußt du löschen.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

sony
Gast





BeitragVerfasst am: 23. Sep 2004 12:21   Titel:

das ist mir soweit auch klar, aber ich habe die 4.. version installiert, als auch die 3.3.11.
und troztdem kommt die gleiche fehlermeldung.
 

sony
Gast





BeitragVerfasst am: 23. Sep 2004 12:23   Titel:

wo finde ich denn die "Include Datei", um sie zu löschen???
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy