Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
OpenOffice Matrix-Formeln

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
HarryBO



Anmeldungsdatum: 10.08.2001
Beiträge: 20

BeitragVerfasst am: 30. Sep 2004 23:48   Titel: OpenOffice Matrix-Formeln

Moin,

weiß einer von euch, ob OpenOffice hinsichtlich Matrixformeln einen Bug hat? Ich wollte nämlich, wie ich es von Excel kenne, in einer Spalte über mehrere Zeilen ein und den selben Rechengang wiederholen, und das geht ja eigentlich am einfachsten, indem man alle zellen makiert, in denen diese Berechnung durchgeführt werden soll, dann die Formel eingibt, und mit Umschalt+Steuerung+Eingabe die Formel zur Matrixformel macht.
Z.B. ein ganz einfaches Beispiel, die Werte aus Spalte A und B in Spalte C addieren -> C1:C10 makieren und die Formel
=A1:A10+B1:B10 eingeben und mit Umsch+Strg+Eing abschließen.
Das funktioniert ja noch, aber wenn ich jetzt mit Bedingungen anfange, dann Streikt OpenOffice und gibt den Fehlerwert "Err.:504" zurück.
Also z.B. bei
=WENN(A1:10<B1:10; A1:A10+B1:B10; A1:A10-B1:B10)

kommt die zuvor genannte Fehlermeldung.

Ist das ein Fehler oder gibt es in OOo einfach einen anderen Weg, um so etwas zu bewerkstelligen???

Gruß
HarryBO
 
Benutzer-Profile anzeigen Private Nachricht senden

Ja
Gast





BeitragVerfasst am: 01. Okt 2004 9:25   Titel:

Das scheint wirklich ein Fehler zu sein. Die Formeln ohne Matrix funktionieren, mit Matrix funktionieren sie nicht. Aus der Hilfe bin ich auch nicht schlau geworden. Meine letzte Tabelle habe ich ohne Matrix erstellt, jedes Feld einzeln.
Ich denke mal die Syntax ist ok da ich sie mit dem Formeleditor gemacht habe. Nur wenn ich auf Matrix umschalte dann bekomme ich Error.
Sad
 

HarryBO



Anmeldungsdatum: 10.08.2001
Beiträge: 20

BeitragVerfasst am: 02. Okt 2004 23:05   Titel:

beim OpenOffice-Forum wurde das zwar auch schon diskutiert, aber eine Lösung haben die auch nicht. Geht wohl im Moment nur über den herkömmlichen Weg ... einfach die Formel in alle Zellen kopieren ... frist zwar anscheinend mehr Ressourcen, aber ich habs ja ... Wink

Hoffentlich ändert sich das in zukünftigen OOo Versionen
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy