Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
PC schaltet nicht ab nach Kernel kompilierung

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
ZeuS
Gast





BeitragVerfasst am: 02. Okt 2004 11:27   Titel: PC schaltet nicht ab nach Kernel kompilierung

Tach

Debian Woody 2.4.18-bf2.4

hab meine Kernel-Einstellungen via 'make menuconfig' gemacht
dabei hab ich die Standart-Einstellungen von /boot/config-2.4.18-bf2.4 genommen
und ein paar isdn module zugefügt.

ACPI ist im Kernel standart nicht aktiviert.

Jetzt schaltet er nicht mehr ab bei 'halt' oder 'shutdown -h now' er schaltet nur die HDD ab.

Motherboard unterstützt APM + ACPI

Hab in lilo.conf schon mit apm=on acpi=off und umgekehrt bzw. apm=power-off probiert.

Was kann ich da machen??

MfG ZeuS
 

root_tux_linux



Anmeldungsdatum: 07.12.2003
Beiträge: 537
Wohnort: Schweiz

BeitragVerfasst am: 02. Okt 2004 17:12   Titel:

Mach mal: modprobe apm und dann fahr ihn runter mit z.B. poweroff Smile


Wenns dann geht modprobe.conf konfigurieren.
_________________
#Haupt-Rechner: Gentoo Linux 1.4.16 - 2.6.7
#Backup-Server: Slackware 10.0 - 2.4.26
#Filesharing/Web-Server: Slackware 10.0 - .2.4.26 (sys.homelinux.org)
#Miet-Host/Server: Redhat (2blabla.ch)
 
Benutzer-Profile anzeigen Private Nachricht senden MSN Messenger

ZeuS
Gast





BeitragVerfasst am: 02. Okt 2004 18:01   Titel:

Das APM Modul is natürlich schon eingebunden.
Aber ich check mal 'poweroff'

Bin aber nicht wirklich zuversichtlich.

MfG
 

dhartmann



Anmeldungsdatum: 17.09.2004
Beiträge: 25

BeitragVerfasst am: 04. Okt 2004 12:32   Titel: So funktioniertts:)

Du braucht unter make menuconfig nur den letzten Punkt von APM aktivieren
er heist

USE REAL TIME MODE APM BIOS CALL TO POWER OFF

ohne APM auch kein Power off Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 04. Okt 2004 22:26   Titel:

wo wir schonmal beimThema sind....

Habe da auch ein APM-Problem, bin aber nicht sicher an wen es liegt (BIOS oder Linux)
Wenn ich APM lade kann ich den Rechner auch abschalten, aber im BIOS steht noch nach 15 Minuten Monitor aus.
Egal was ich tue, diese Einstellung wird nicht überschrieben. Es geht nur im Bios zu ändern.
Windows stört sich nicht drum, dort wird der Monitor abgeschaltet wie es angegeben ist.
Nur unter Linux nicht.
 
Benutzer-Profile anzeigen Private Nachricht senden

Zeus
Gast





BeitragVerfasst am: 17. Okt 2004 19:14   Titel:

Sorry, das ich mich erst so spät wieder melde.

Hat leider allles nix gebracht. Sad

Was ich herausgefunden hab ist, dass die apm.o in modules bei gleicher kompilierungs config datei unterschiedlich groß ist wie die orginal vom 2.4.18-bf2.4 bei dem es ja funktioniert

MfG Zeus
 

Zeus
Gast





BeitragVerfasst am: 17. Okt 2004 19:16   Titel:

Sorry, das ich mich erst so spät wieder melde.

Hat leider allles nix gebracht. Sad

Was ich herausgefunden hab ist, dass die apm.o in modules bei gleicher kompilierungs config datei unterschiedlich groß ist wie die orginal vom 2.4.18-bf2.4 bei dem es ja funktioniert
Kann das auf eine fehlerhafte kompilierung hinweisen?? hab aber nix gemerkt.

MfG Zeus
 

Zeus
Gast





BeitragVerfasst am: 17. Okt 2004 20:13   Titel:

Problem gelöst Razz

ich hab apm mit modconf geladen und dabei den parameter "power_off=1" genutzt.

Jetzt gehts. Nicht für ungut. Danke an alle die mir geholfen haben.

Cu
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy