Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Synaptics Touchpad XFree86 -- Verzweiflung!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
AHB



Anmeldungsdatum: 04.10.2004
Beiträge: 2

BeitragVerfasst am: 05. Okt 2004 5:40   Titel: Synaptics Touchpad XFree86 -- Verzweiflung!

Guten Morgen alle miteinander,
da ich neu hier bin erst einmal das übliche Statement:
Ich bin noch mehr oder weniger ein Linux Noob, habe zwar nun seit geraumer Zeit Debian auf allen Heimrechnern laufen und davor schon Red Hat und Fedora, aber eben trotzdem noch recht neu.

Nun aber zum Punkt:

Ich habe auf meinem Laptop (Peacock 2500+) endlich auch Debian zum laufen bekommen, zumindest bis auf das Synaptics Touchpad, welches partu nicht laufen wollte.
Besser gesagt ich kann damit ohne Probleme scrollen, aber klicken auf dem Pad funktioniert nicht.

Daher habe ich mir natürlich nach etwas googeln einfach mit
apt-get install xfree86-driver-synaptics

den Treiber geladen.

ls -l /usr/X11R6/lib/modules/input/synaptics_drv.o
-rwxr-xr-x 1 root root 35078 2004-08-10 07:47 /usr/X11R6/lib/modules/input/synaptics_drv.o

Meine /etc/X11/XF86Config-4 hab ich nach der Anleitung die dem Packet synaptics-0.11.3.tar.gz
beiliegt geändert und leicht angepasst.

So sieht/sah meine XF86Config-4 dann aus:


(..)
Section "Module"
...
Load "synaptics"
...

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[1]"
Option "Device" "/dev/psaux"
Option "Edges" "1900 5400 1800 3900"
Option "Finger" "25 30"
Option "MaxTapTime" "20"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.02"
Option "MaxSpeed" "0.18"
Option "AccelFactor" "0.0010"
# Option "Repeater" "/dev/ps2mouse"
# Option "SHMConfig" "on"
EndSection
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
EndSection
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection

...

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection


Sobald ich dann den Xserver neustarte (oder natürlich das ganze System) dann bleibt der Bildschirm einfach nur schwarz.

Hab es auch schon einmal mit der config von http://www.pro-linux.de/forum/viewtopic.php?t=1008754&highlight=synaptics
versucht, leider hat es lediglich den Xserver dazu veranlasst eine Fehlermeldung anstatt eines schwarzen Bildschirms zubringen.

Vielleicht kann mir wer weiterhelfen.
Mfg
AHB
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy