Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Router unter 9.0 ?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Bl@d€



Anmeldungsdatum: 14.10.2004
Beiträge: 3

BeitragVerfasst am: 14. Okt 2004 13:00   Titel: Router unter 9.0 ?

hi @ all

so bin heute schon durch das ganze forum gedüst und habe sehr viele sachen gefunden die mir weiter helfen konnten
habe es dadurch geschaft das ich mit suse 9.0 ins internet mit eth1 und einen DHCP server mit eth0 auf bauen konnte so die ip für

eth0 ist 192.168.1.0
eth1 ist 192.1.1.1

das funzt wunder bar

so jetzt meine frage wie schafe ich das jetzt und welche sachen muss ich wo eintragen damit die anderen rechner die durch den dhcp server ne ip bekommen haben
das die ins netz dürfen

MFG

Bl@d€
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

CheersMichael
Gast





BeitragVerfasst am: 14. Okt 2004 13:29   Titel:

Du läßt beim DHCP das Gateway (192.1.1.1) mit verteilen. Dann konfigurierst und aktvierst Du noch die SuSEfirewall und ab gehts!

Cheers

Michael
 

dhcp
Gast





BeitragVerfasst am: 14. Okt 2004 14:50   Titel:

hi

und wie mache ich das das er dadrüber routet

ich sach mal wo stehle ich das ein
 

Bl@d€



Anmeldungsdatum: 14.10.2004
Beiträge: 3

BeitragVerfasst am: 14. Okt 2004 14:55   Titel:

so jetzt bin ich wider angemeldet


ich danke dir für die schnell antwort

und wo stehle ich das jetzt ein
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 15. Okt 2004 7:12   Titel:

hi

wie schon gesagt in der suse firewall oder du gibst auf der console

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -A POSTROUTING -t nat -s 192.168.1.0/24 -j MASQUERADE

ein, der eintrag ist aber nach einem reboot weg ausser du machst daraus ein shell-script
und führst es beim starten aus.

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Bl@d€



Anmeldungsdatum: 14.10.2004
Beiträge: 3

BeitragVerfasst am: 16. Okt 2004 12:55   Titel:

hi habe ne lösung gefunden funtz aber net so wie ich es mir gedacht habe

und zwar habe ich folgendes eingegeben

etho 192.168.0.0
eth1 192.168.2.13

Zitat:

rcnamed start echo 1 > /proc/sys/net/ipv4/ip_forward iptables
-t nat -A POSTROUTING -o ppp0 -s 192.168.0.0/16
-j MASQUERADE iptables -A FORWARD -i ppp0 -d
192.168.0.0/24 -j ACCEPT iptables -A FORWARD -o ppp0 -p TCP --tcp-flags SYN,RST SYN
-j TCPMSS --clamp-mss-to-pmtu iptables -t nat -A PREROUTING -i ppp0 -p TCP --dport 4662
-j DNAT --to-destination 192.168.0.2 iptables -t nat -A PREROUTING -i ppp0 -p UDP --dport 5662
-j DNAT --to-destination 192.168.0.2 iptables -t nat -A PREROUTING
-i ppp0 -p TCP --dport 24500:24505 -j DNAT --to-destination 192.168.0.2





mmmmh aber irgend wie macht er das net

liegt das daran das ich suse 9.0 drauf habe

muss ich das am anfang was anderes eingeben


ach ja nnoch was

dem client habe ich folgendes eingeben

ip 192.168.0.2
255.255.255.0
gateway 192.168.0.0
DNS NR 1 192.168.0.12

und dan habe ich noch ne start datei gemacht

Zitat:

#!/bin/sh rcnamed start echo 1 > /proc/sys/net/ipv4/ip_forward iptables -t nat -A POSTROUTING
-o ppp0 -s 192.168.0.0/16 -j MASQUERADE iptables -A FORWARD -i ppp0 -d 192.168.0.0/24 -j ACCEPT
ptables -A FORWARD -o ppp0 -p TCP --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu iptables -t nat
-A PREROUTING -i ppp0 -p TCP --dport 4662 -j DNAT --to-destination 192.168.0.2 iptables -t nat -A PREROUTING
-i ppp0 -p UDP --dport 5662 -j DNAT --to-destination 192.168.0.2 iptables -t nat -A PREROUTING -i ppp0 -p TCP
--dport 24500:24505 -j DNAT --to-destination 192.168.0.2



die ich dan beim booten starten lasse

die habe ich unter etc/init.d/boot.local eingetragen

es funtz auch so weit er greift auch wunder bar beim start auf die datei aber irgend wo in dem befehl ist der wurm drin

vieleicht wist ihr ja was

MFG

Blade
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy