Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Login bei Apache fehlerhaft

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
gharika



Anmeldungsdatum: 12.01.2004
Beiträge: 41

BeitragVerfasst am: 18. Okt 2004 10:26   Titel: Login bei Apache fehlerhaft

Hallo,

ich habe apache2 als WebServer laufen und da drauf diverse Sachen. Unter anderem ein Album, Forum usw.

Jetzt habe ich aber das Problem, daß wenn ich mich z.B. beim Forum einlogge mit einem gültigen Login - kommt der Browser in einen Timeout. Der Login ist aber erfolgreich und ich kann mich innerhalb des vorher "gesperrten Bereichs" bewegen. Am Browser liegt es auch nicht, da ich mit Firefox, IE und Opera das gleiche Verhalten habe.

Wenn ich mich aber mit Absicht mit falschen Daten einlogge, bekomme ich sofort eine Antwort, daß der Login falsch ist.
Woran liegt das und wie kann ich das beheben? Mit der Suche hier und bei Google komme ich nicht weiter.

Es Betrifft auch keine besondere Anwendung, sondern alle. Forum, Album, eigenes PHP-Script. Was die womöglich gemein haben ist PHP.

Zusammenfassung:
Gültiger Login -> Timeout anstatt "Willkommen blah blah".
Ungültiger Login -> kommt Login ungültig, wie es sein sollte.

Das habe ich am laufen:
Code:
Apache/2.0.52 (Debian GNU/Linux) mod_perl/1.99_14 Perl/v5.8.4 mod_python/3.1.3 Python/2.3.4 PHP/4.3.9-1


Habe die Frage auch schon in anderen Foren gestellt, nur leider keine Antwort bis jetzt Sad
_________________
Tue 10 Jahre lang gutes und niemand wird es bemerken, für eine Stunde böse sein und Ruhm ist dir gewiss.
(Alte Samurai Weisheit)
 
Benutzer-Profile anzeigen Private Nachricht senden

Scory



Anmeldungsdatum: 16.04.2004
Beiträge: 188

BeitragVerfasst am: 18. Okt 2004 15:31   Titel:

>Habe die Frage auch schon in anderen Foren gestellt, nur leider keine Antwort bis jetzt

Was daran liegt, dass Du allerwichtigste Grundinformationen nicht erzählst. Wie ist der Login technisch realisiert? Via .htaccess und .htpasswd oder via PHP-Script (eigene Abfrage, nicht durch den Server)? Ohne diese Info ist es völlig unmöglich auch nur einen Tipp zu geben.
 
Benutzer-Profile anzeigen Private Nachricht senden

gharika



Anmeldungsdatum: 12.01.2004
Beiträge: 41

BeitragVerfasst am: 19. Okt 2004 8:12   Titel:

Scory hat folgendes geschrieben::
>Habe die Frage auch schon in anderen Foren gestellt, nur leider keine Antwort bis jetzt

Was daran liegt, dass Du allerwichtigste Grundinformationen nicht erzählst. Wie ist der Login technisch realisiert? Via .htaccess und .htpasswd oder via PHP-Script (eigene Abfrage, nicht durch den Server)? Ohne diese Info ist es völlig unmöglich auch nur einen Tipp zu geben.


Hab ich schon.

Gharika hat folgendes geschrieben::
Es Betrifft auch keine besondere Anwendung, sondern alle. Forum, Album, eigenes PHP-Script. Was die womöglich gemein haben ist PHP.


Nämlich alle Logins, die über den Apache gehen (und evtl. seine Module).
_________________
Tue 10 Jahre lang gutes und niemand wird es bemerken, für eine Stunde böse sein und Ruhm ist dir gewiss.
(Alte Samurai Weisheit)
 
Benutzer-Profile anzeigen Private Nachricht senden

gharika



Anmeldungsdatum: 12.01.2004
Beiträge: 41

BeitragVerfasst am: 19. Okt 2004 10:26   Titel:

Noch als Ergänzung, beim Logout passiert das gleiche. Timeout und kein "Sie wurden erfolgreich ausgeloggt" oder dergleichen.
_________________
Tue 10 Jahre lang gutes und niemand wird es bemerken, für eine Stunde böse sein und Ruhm ist dir gewiss.
(Alte Samurai Weisheit)
 
Benutzer-Profile anzeigen Private Nachricht senden

dns
Gast





BeitragVerfasst am: 19. Okt 2004 10:38   Titel:

d n s
 

Scory



Anmeldungsdatum: 16.04.2004
Beiträge: 188

BeitragVerfasst am: 19. Okt 2004 11:17   Titel:

Ok, wenn Du keine Hilfe (ich frage mich allerdings, wozu Du überhaupt gefragt hast). Aus dem (schlappen) Hinweis, dass alle Scripts gemeinsam haben, dass es PHP-Scripts sind, leite ich auf keinen Fall ab, dass das Apache Login gemeint ist.

Da Du weiterhin etwas von vermißtem "Sie wurden erfolgreich ausgeloggt" schreibst spricht noch mehr dafür, dass es sich nicht um Apache handelt, denn dort gibt es gar keinen Logout - oh!

Dann suche mal fröhlich, ich kann Dir leider nicht helfen wenn Du selbst nichts weißt.
 
Benutzer-Profile anzeigen Private Nachricht senden

gharika



Anmeldungsdatum: 12.01.2004
Beiträge: 41

BeitragVerfasst am: 19. Okt 2004 12:30   Titel:

Scory hat folgendes geschrieben::
Ok, wenn Du keine Hilfe (ich frage mich allerdings, wozu Du überhaupt gefragt hast). Aus dem (schlappen) Hinweis, dass alle Scripts gemeinsam haben, dass es PHP-Scripts sind, leite ich auf keinen Fall ab, dass das Apache Login gemeint ist.

Da Du weiterhin etwas von vermißtem "Sie wurden erfolgreich ausgeloggt" schreibst spricht noch mehr dafür, dass es sich nicht um Apache handelt, denn dort gibt es gar keinen Logout - oh!

Dann suche mal fröhlich, ich kann Dir leider nicht helfen wenn Du selbst nichts weißt.


Deine Antworten klingen ganz schön aggresiv...

Wie soll ich das Problem sonst beschreiben? Das ganze läuft unter Apache... es wird PHP benutzt (phpbb2 - Forum, gallery - Fotoalbum und eigenes simples PHP-Script)... es sind Module von Apache, die involviert sind (php, perl,...), ich weiß nicht woran es liegt das ich mich nicht auf Anhieb z.B. beim Forum (egal welches), der Bildergallery oder eigenes PHP-Script authentifizieren kann. Ich bekomme mich eingeloggt, aber der Server liefert beim erfolgreichen Login einen Timeout.

Wenn der Fehler in meinem Script wäre, würde das bei anderen funktionieren, die anderen Sachen funktionieren aber auch nicht und die werden von 1000den benutzt und funktionieren ohne Probleme, ich denke es ist eher eine Apache Konfiguration die falsch ist, aber welche?

Was ist es wenn nicht Apache? Eines der Module? Habe geschrieben welche ich benutze, wüßte aber nicht, daß die den Login selber machen, das übernimmt der Apache, die rufen den nur auf. Apache ist ein WebServer er bedient die Logins, ich weiß nicht was du damit sagen willst, daß der Apache keinen Logout hat - hat er nicht, aber er bedient den Logout-Vorgang.

dns hat folgendes geschrieben::
d n s

Kannst du das bitte etwas ausführlicher beschreiben, was damit gemeint ist? Das klingt garnicht abwegig, weil das ganze läuft über DynDNS, aber da läuft auch ein TeamSpeak-Server und der hat keine Probleme mit dem Login-/Logout-Verhalten, deswegen hatte ich das ausgeschloßen. Der hat einen eigenen WebServer und somit hat der Apache da keine Karten drin.

Zusatz:
Der normale Login-Vorgang läuft immer gleich und in etwa so ab:
1. Loginpage aufrufen
2. User/Password eingeben und ok drücken
3. Entweder page mit erfolgreich eingeloggt oder beim Forum z.B. automatisch die Übersicht aller Foren

Der Fehler bei mir, nach Schritt 2 kommt ein Timeout. Wenn man allerdings auf den Index wieder geht, wird man als eingeloggt geführt und alles funktioniert. Ich hoffe das war verständlich genug, wenn nicht sagt was noch nicht klar bei dem Problem ist.
_________________
Tue 10 Jahre lang gutes und niemand wird es bemerken, für eine Stunde böse sein und Ruhm ist dir gewiss.
(Alte Samurai Weisheit)
 
Benutzer-Profile anzeigen Private Nachricht senden

gharika



Anmeldungsdatum: 12.01.2004
Beiträge: 41

BeitragVerfasst am: 19. Okt 2004 13:02   Titel:

Folgende Anwendungen haben das Problem (und laufen alle unter Apache):
Fotogallery - Gallery v1.4.4-pl2-debian2
Forum - phpBB 2.0.10-2 (Debian)
PHP-Script - selbst geschrieben zum Testen

Diese Anwendungen laufen auch auf dem Server ohne das besagte Problem (aber haben einen eigenen WebServer)
Webmin - Version 1.160 (Debian GNU/Linux 3.0)
TeamSpeak - Version: v2.0.r20.b1 Linux
_________________
Tue 10 Jahre lang gutes und niemand wird es bemerken, für eine Stunde böse sein und Ruhm ist dir gewiss.
(Alte Samurai Weisheit)
 
Benutzer-Profile anzeigen Private Nachricht senden

Scory



Anmeldungsdatum: 16.04.2004
Beiträge: 188

BeitragVerfasst am: 19. Okt 2004 15:39   Titel:

Na gut, also, erst mal Butter bei die Fische, sonst reden wir aneinander vorbei: du hast nicht die geringste Ahnung, was ein "Apache Login" ist und wie man es technisch realisiert (das hat auch mit PHP nicht das allergeringste zu tun). Man kann mit Apache via .htaccess-Datei einzelne Verzeichnisse schützen, so daß ein Login angegeben werden muss. Vermute ich richtig?

Bei "freien" PHP-Scripts (wie beispielsweise bei phpBB2) wird diese Technik NICHT benutzt (weil sie maschinenabhängig resp. abhängig vom Webserver ist), denn diese Scripts laufen natürlich auch in ganz anderen Umgebungen. Diese Scripts (wie auch dieses Forenscript) betreibt via PHP und MySQL eine eigene Benutzerverwaltung (resp. dann auch das Login).

Zeig doch mal Dein "selbstgeschriebenes" Script und erläutere, was Du dort machen möchtestund was dort schief läuft. Ich vermute, dass eine Einstellung in php.ini falsch ist (oder mehrere), meistens ist es das Fehlen von error_reporting bzw. falsches Level (es wird keine Fehlermeldung angezeigt obwohl ein Fehler aufgetreten ist) und/oder die Einstellung von register_globals.
 
Benutzer-Profile anzeigen Private Nachricht senden

gharika



Anmeldungsdatum: 12.01.2004
Beiträge: 41

BeitragVerfasst am: 19. Okt 2004 18:09   Titel:

Scory hat folgendes geschrieben::
Na gut, also, erst mal Butter bei die Fische, sonst reden wir aneinander vorbei: du hast nicht die geringste Ahnung, was ein "Apache Login" ist und wie man es technisch realisiert (das hat auch mit PHP nicht das allergeringste zu tun). Man kann mit Apache via .htaccess-Datei einzelne Verzeichnisse schützen, so daß ein Login angegeben werden muss. Vermute ich richtig?


Falsch. Erstens finde ich es unhöfflich zu behaupten ich "hätte nicht die geringste Ahnung"... ich weiß sehr wohl die Unterschiede der verschiedenen Authentifizierungsverfahren .htaccess, Datenbankbasierte oder sonstige eigene Implementierungen. Das einzige was mein Fehler ist, ist das ganze als Apache-Login zu nennen... bzw. das Topic als "Login bei Apache fehlerhaft" - sollte eher "Login mit Apache als WebServer fehlerhaft" heißen.

Scory hat folgendes geschrieben::
Bei "freien" PHP-Scripts (wie beispielsweise bei phpBB2) wird diese Technik NICHT benutzt (weil sie maschinenabhängig resp. abhängig vom Webserver ist), denn diese Scripts laufen natürlich auch in ganz anderen Umgebungen. Diese Scripts (wie auch dieses Forenscript) betreibt via PHP und MySQL eine eigene Benutzerverwaltung (resp. dann auch das Login).


Korrekt und war mir auch bekannt, jedoch hab ich mir die Scripte nicht im Detail angeschaut und vermute(te) da auch keinen Fehler.

Scory hat folgendes geschrieben::
Zeig doch mal Dein "selbstgeschriebenes" Script und erläutere, was Du dort machen möchtestund was dort schief läuft. Ich vermute, dass eine Einstellung in php.ini falsch ist (oder mehrere), meistens ist es das Fehlen von error_reporting bzw. falsches Level (es wird keine Fehlermeldung angezeigt obwohl ein Fehler aufgetreten ist) und/oder die Einstellung von register_globals.


php.ini oder sonstige Konfigurationsdateien hatte ich schon eher im Verdacht. error_reporting war der Schlüssel (zumindest zu einem Problem).

Na ja, nichtsdestotrotz, vielen Dank Allen für die Hilfe - ich habe das Problem, bzw. die Probleme gelöst. Es waren drei Teilbereiche betroffen und alle hatten eine andere Fehlerursache und somit eine andere Lösung.


  1. Das Forum
    Hier hatte ich fälschlicherweise den falschen "Domainname" eingetragen und zwar den lokalen Namen und nicht den der von DynDNS verwendet wird - daher hat sich das Script immer totgesucht danach. Bin durch Zufall darauf gestoßen, wo ich zum x-ten mal die Konfiguration inspizierte und nach Fehlern durchsuchte.
  2. Die Bildergallerie
    Hier war es das www in der URL was zuviel bzw. zuwenig war. Man muss die Gallerie so aufrufen wie sie intern konfiguriert ist und ich hab es ohne www konfiguriert aber mit www aufgerufen. Die Lösung stand im FAQ von der Gallery-Homepage.
  3. Mein eigenes PHP-Script
    Das war wie schon zu erwarten mein eigenes Verschulden, die Dateien hatten nicht die richtigen Berechtigungen, bzw. gehörten nicht der richtigen Gruppe an und nach dem aktivieren des Loggings in php.ini war es sofort klar - per Default wird nicht in eine Datei geschrieben sondern auf Display, wieso auch immer.


Hatte zuerst die falsche Fährte aufgenommen und hatte alleine Apache im Verdacht, weil alle das gleiche Fehlverhalten aufwiesen, aber im Endeffekt trotzdem alles verschiedene Probleme waren.

Vielen Dank nochmal Allen und seid nett zueinander Wink

Gharika
_________________
Tue 10 Jahre lang gutes und niemand wird es bemerken, für eine Stunde böse sein und Ruhm ist dir gewiss.
(Alte Samurai Weisheit)
 
Benutzer-Profile anzeigen Private Nachricht senden

Scory



Anmeldungsdatum: 16.04.2004
Beiträge: 188

BeitragVerfasst am: 20. Okt 2004 13:22   Titel:

Zitat:
Das einzige was mein Fehler ist, ist das ganze als Apache-Login zu nennen... bzw. das Topic als "Login bei Apache fehlerhaft" - sollte eher "Login mit Apache als WebServer fehlerhaft" heißen.

Das wäre immer noch genau so falsch, denn schließendlich hatte es rein gar nix mit Apache zu tun. Aber keine Sorge, in Zukunft werde ich Deine Fragen nicht mehr beantworten - Du bist mir zu pampig.
 
Benutzer-Profile anzeigen Private Nachricht senden

gharika



Anmeldungsdatum: 12.01.2004
Beiträge: 41

BeitragVerfasst am: 20. Okt 2004 14:49   Titel:

Scory hat folgendes geschrieben::
Zitat:
Das einzige was mein Fehler ist, ist das ganze als Apache-Login zu nennen... bzw. das Topic als "Login bei Apache fehlerhaft" - sollte eher "Login mit Apache als WebServer fehlerhaft" heißen.

Das wäre immer noch genau so falsch, denn schließendlich hatte es rein gar nix mit Apache zu tun. Aber keine Sorge, in Zukunft werde ich Deine Fragen nicht mehr beantworten - Du bist mir zu pampig.


Richtig, das hatte nichts mit Apache zu tun, aber das weiß man natürlich alles im voraus und Fehler macht man ja auch nie.

Ich hab halt keine Ahnung von nichts und kann nichts Twisted Evil

Danke dir trotzdem für deine Hilfe Very Happy (und das meine ich nicht ironisch, sondern ehrlich - das obere ist schon ironisch gemeint)
_________________
Tue 10 Jahre lang gutes und niemand wird es bemerken, für eine Stunde böse sein und Ruhm ist dir gewiss.
(Alte Samurai Weisheit)
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy