Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Suse9.1 personal - nach Installation keine KDE

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Umstieg auf Linux
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
tylorxp
Gast





BeitragVerfasst am: 28. Okt 2004 11:00   Titel: Suse9.1 personal - nach Installation keine KDE

Hallo,
ich bin WinXp Benutzer und hab mir jetzt mal Suse9.1 besorgt und installiert. So weit so gut, nur nach der Installation bin ich im Textmodus, und sobald ich den Befehl kde eingebe schmeißt der Rechner Fehlermeldungen um sich, von wegen er könnte ein paar Directories nicht finden und somit die KDE nicht laden, obwohl ich sie 100% mitinstalliert hab. (inzwischen 3. Installationsversuch)
Kann mir da vielleicht jemand helfen?
Viele Grüße
Martin
 

chlor
Gast





BeitragVerfasst am: 28. Okt 2004 12:55   Titel:

hi,

wenn fehlermeldungen auftreten ist es oft hilfreich wenn du auzüge davon mitpostest.

hast du bei der installation ein standardsystem ausgewählt?
und kannst du kurz posten was du für hardware benutzt?
 

tylorxp
Gast





BeitragVerfasst am: 28. Okt 2004 13:22   Titel:

ok, also ich hab nen amd athlon XP 2400+ mit 256mb ddram und ner geforce 4 mx 440.
bei der installation hab ich die manuelle gewählt und dann alles so gelassen bis auf die partitionen (hab eine platte, auf der auch windoof drauf ist), außerdem hab ich noch windows als standard für den bootmanager festgelegt, ansonsten kommt's auf gleiche raus als hätte ich die standardversion gewählt.

so, jetzt ein auszug aus den meldungen:

zunächst erzählt er mir, dass ich mich in runlevel 2 befinde, und dann soll ich mich im textmodus einloggen, funktioniert auch. daraufhin hab ich mal den befehl " kde" ausprobiert:

Code:

xset: unable to open display
ksplah: cannot connect to X server
kdeinit: Aborting $DISPLAY is not set
Warning: Connect() failed: No such file or directory
ksmserver: cannot connect to X server
startkde: Shutting down...


das waren (meiner Meinung nach) die wichtigsten Meldungen, auf jeden fall bin ich nachher genau da wo ic angefangen hab.

Ich hoffe das hilft meine situation ein bissl besser zu verstehen!
 

chlor
Gast





BeitragVerfasst am: 28. Okt 2004 14:12   Titel:

vorweg, ich bin nicht unbedingt besonders gut mit suse vertrauti sondern benutze eine andere distri. kann gut sein das dir jemand auch einen speziellen suse weg anbieten kann.

jedenfalls scheint das ein prob mit dem xserver zu sein.

in der suse hardware datenbank ist deine g-karte nicht gelistet.
http://hardwaredb.suse.de/productSearch.php?PHPSESSID=8eecc7b79530a964ae827f574435f266&LANG=de_DE&searchtype=extended&update_session=1&f_manufactor=nvidia&f_vendorId=&f_device=geforce&f_deviceId=&f_method=AND&f_supported=0&f_categories%5B%5D=18&f_dist=&f_arch=
das heißt aber nicht das sie nicht zum "laufen" zu bringen ist. eigentlich sollte das mit dem nicht propritären (also freien) nv treiber gehen.
vielleicht kannst du aber nochmal die etwa letzten 10 zeilen von
/var/log/XFree86.0.log
lesen kannst du sie mit
less /var/log/XFree86.0.log
posten. besonders wichtig sind die zeilen mit EE am anfang.

ansonsten:
die konfigurationsdatei für den xserver liegt unter
/etc/X11/XF86Config
dort gibt es einen abschnitt der für den nv treiber so aussehen sollte

Section "Device"
Identifier "Generic Video Card"
Driver "nv"
...

eine andere und in bezug auf performance sicher bessere lösung ist es,den treiber von
http://www.nvidia.com/object/linux_display_ia32_1.0-6111.html
zu benutzen. eine anleitung dafür findest du hier
http://www.holarse.de/?content=/treiber/grafik/nvidia
aber eventuell guckst du dafür auch erstmal ins suse howto auf der nvidia site.
ist jedenfalls lockerer als es erstmal aussieht.

edit:
was vielleicht auch noch einen versuch wert ist:
du könntest falls vorhanden, knoppix [1] starten und sehen ob der xserver dort funktioniert. falls dem so ist, könntest du die XF86Config kopieren und übernehmen.

[1] falls nicht vorhanden http://www.knopper.net/knoppix-mirrors/
 

tylorxp
Gast





BeitragVerfasst am: 28. Okt 2004 21:39   Titel:

Danke auf jeden Fall für deine ausführliche Antwort!
ich hab schon mal die XFree86.0.log durchsucht, und bin dabei nur auf eine Zeile mit "EE" (Error?) gestoßen:
"(EE)FBDEV(0): FBIOPAN_DISPLAY: Invalid Argument"

Dann hab ich mal die XF86Config "von Hand" geändert und hab da jetzt das hingeschrieben, was du vorgeschlagen hast, und den ganzen anderen Krempel unter "Device" bis zum Ende der Section rausgeschmissen. Hat aber leider nicht viel gebracht.

DIe Idee mit Knoppix gefällt mir, da ich das eh fertig auf CD hab, läuft auch prima, und ich kann auch auf die Suse-Partition zugreifen, jedoch nur lesen.
Jetzt ist halt die Frage, wie ich die XF86Config von Knoppix auf die Suse-Part. bekomme; v.a. da ich noch nicht allzu viel Ahnung von Linux und den (teilweise seltsamen) Kommandos habe.

Der andere Weg mit dem Treiber von Nvidia klingt theoretisch ganz schön, nur komme ich ja nicht mit Linux ins Netz, wie soll krieg ich den dann via Windows auf die Linux-Part.?
 

chlor
Gast





BeitragVerfasst am: 29. Okt 2004 12:28   Titel:

die fehlermeldung hört sich so an, als ob der frambuffer aktiviert ist. hast du eine zeile wie diese in deiner.XF86Config ?

Option "UseFBDev" "true"

dann könntest du versuchen das "true" auf "false" zu setzen oder die zeile durch ein # am anfang auszukommentieren, also

# Option "UseFBDev" "true"

dazu kannst du z.b. den editor vi benutzen, jeder andere geht natürlich auch. ich gehe halt davon aus das du keine graphische oberfläche zur verfügung hast. also mit der konsole arbeitest.

vi /etc/X11/XF86Config

dann zum schreiben i für insert eingeben (zeigt er dann unten an).
wie oben beschrieben die zeile ändern

strg c
wq

für write quit, das wars, und hoffentlich hilfts auch.

wenn das mit der knoppix XF86Config bei dir funktioniert, und dir der weg besser gefällt, gehst du mit einem aktuellen knoppix so vor:
du mußt deine suse partition schreibfähig mounten. also: mit dem konqueror die entsprechende partition öffnen und dann in der konsole.

su
mount -o remount -rw /mnt/hdaX

für root-rechte und zum mounten. für das X die entsprechende partition eingeben

mv /mnt/hdaX/etc/X11/XF86Config /mnt/hdaX/etc/X11/XF86Config.bak
cp /etc/X11/XF86Config-4 /mnt/hdaX/etc/X11/XF86Config

erst ein backup machen, und dann die datei in deine suse kopieren.
ich hoffe das ich das halbwegs verständlich rübergebracht habe, wenn dir was unklar ist, mußt du halt nochmal posten.

bis denn

edit:
Zitat:
Dann hab ich mal die XF86Config "von Hand" geändert und hab da jetzt das hingeschrieben, was du vorgeschlagen hast, und den ganzen anderen Krempel unter "Device" bis zum Ende der Section rausgeschmissen.

das war nicht ganz das, was ich meinte.
 

chlor
Gast





BeitragVerfasst am: 02. Nov 2004 16:12   Titel:

so machts richtig spaß, versuchen zu helfen!
thanx
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Umstieg auf Linux Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy