Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
top zeigt nicht alle Prozesse an

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
bob
Gast





BeitragVerfasst am: 28. Okt 2004 14:42   Titel: top zeigt nicht alle Prozesse an

Hallo Gemeinde,

habe hier ein kleines Problem mit dem Programm top. Manchmal erreicht das System eine ziemlich hohe CPU-Last (~100%), in der von top ezeugten Liste tuacht jedoch kein Programm auf, das diese Last erzeugt!
Hier die Ausgabe von top (nach CPU-usage sortiert):

---
Code:
top - 15:24:34 up  6:20,  4 users,  load average: 0.55, 0.30, 0.20
Tasks:  74 total,   1 running,  73 sleeping,   0 stopped,   0 zombie
Cpu(s): 98.7% us,  1.0% sy,  0.0% ni,  0.0% id,  0.0% wa,  0.3% hi,  0.0% si
Mem:    256688k total,   216456k used,    40232k free,    10804k buffers
Swap:   128512k total,    18560k used,   109952k free,    64136k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
11143 bob  15   0  2692 1204 2476 S  0.7  0.5   0:55.88 wmtop             
11147 bob  15   0 18796 8436  12m S  0.7  3.3   1:40.52 gkrellm           
11032 root      15   0 70272  30m  45m S  0.3 12.2  10:59.06 X                 
12454 bob  15   0 40412  28m  16m S  0.3 11.2   1:09.83 opera             
18917 bob  17   0  1760  904 1540 R  0.3  0.4   0:00.11 top               
    1 root      16   0   588  176  444 S  0.0  0.1   0:05.94 init             
    2 root      34  19     0    0    0 S  0.0  0.0   0:00.12 ksoftirqd/0       
    3 root       5 -10     0    0    0 S  0.0  0.0   0:00.54 events/0         
    4 root       5 -10     0    0    0 S  0.0  0.0   0:00.24 kblockd/0         
    6 root       5 -10     0    0    0 S  0.0  0.0   0:00.00 khelper           
    5 root      15   0     0    0    0 S  0.0  0.0   0:00.02 kapmd             
    7 root      15   0     0    0    0 S  0.0  0.0   0:00.00 pdflush           
    8 root      15   0     0    0    0 S  0.0  0.0   0:00.28 pdflush           
   10 root      14 -10     0    0    0 S  0.0  0.0   0:00.00 aio/0             
    9 root      16   0     0    0    0 S  0.0  0.0   0:01.19 kswapd0
---


In der 3. Zeile sieht man, dass top die "wahre" Auslastung kennt (98.7%) - in der Liste taucht jedoch kein Prozess auf, der diese verursacht.

Habe nach rootkits gesucht und auch das top-Binary von der CD re-installiert - ohne Besserung.

Weiss jemand Rat?
Danke im Vorraus,
bob.

System: SuSE 9.1 (Kernel 2.6.5)
 

scytheman



Anmeldungsdatum: 18.09.2004
Beiträge: 22
Wohnort: Bad Blankenburg

BeitragVerfasst am: 28. Okt 2004 15:45   Titel:

Wie lange hattest du denn top laufen? Bis zur ersten Aktuallisierung (d.h. die ersten 3sec) zeigt top nicht die momentane Auslastung an sondern den Mittelwert seit starten des Systems.
evtl. liegt es ja daran.
_________________
http://www.debian.org/
http://choerbaert.org
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

bob
Gast





BeitragVerfasst am: 29. Okt 2004 8:36   Titel: top läuft länger

Hallo,
leider liegt es nicht daran - der Zustand hält einige 10-Sekunden an.
Habe mittlerweile herausgefunden, das dafür (CPU-Last) scheinbar ein OPERA-Thread verantwortlich ist. Immer wenn er eine komplexe Seite rendert steigt die CPU-Last, wird die Seite angezeigt, fällt die CPU-Last wieder auf 0 zurück. Leider wird der Prozess von top eben nicht angezeigt - warum auch immer???
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy