Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
IP-Umstellung

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Maaak
Gast





BeitragVerfasst am: 28. Okt 2004 15:14   Titel: IP-Umstellung

Hallo,

ich habe einen SuSE Linux Enterprise Server auf einer z800 (Mainframe) als Gastsystem unter z/VM laufen und zur Zeit ist bei uns eine IP-Umstellung des gesamten Werkes. Jetzt habe ich in der /etc/sysconfig/network/ifcfg-eth0 die Einträge ensprechend geändert. Von

BOOTPROTO="static"
STARTMODE="onboot"
IPADDR="yy.yy.66.50"
MTU="1500"
NETMASK="255.255.0.0"
NETWORK="255.255.0.0"
BROADCAST="255.255.0.0"

auf

BOOTPROTO="static"
STARTMODE="onboot"
IPADDR="xx.xx.6.71"
MTU="1500"
NETMASK="255.255.224.0"
NETWORK="255.255.224.0"
BROADCAST="255.255.224.0"

und zusätzlich noch den richtigen Router in der /etc/sysconfig/network/routes eingetragen. Die NETWORK und BROADCAST Einträge kommen mir zwar falsch vor aber nachdem sie in der ursprünglichen File auch so stehen und das System läuft, gehört das scheinbar so (habs allerdings auch mit den richtigen Einträgen probiert:

BOOTPROTO="static"
STARTMODE="onboot"
IPADDR="xx.xx.6.71"
MTU="1500"
NETWORK="xx.xx.0.0"
NETMASK="255.255.224.0"
BROADCAST="xx.xx.31.255"

Wenn ich jetzt das Netzwek neu laden will (mit rc.network restart) kommt nur die Fehlermeldung

Setting up network interfaces:
lo ..done
eth0 IP/Netmask: 10.53.6.71 / 255.255.224.0 ifup-route: Error whi
le excuting:
ifup-route: Command 'ip route replace to default via 10.53.64.1 dev eth0' re
turned:
ifup-route: RTNETLINK answers: Network is unreachable
ifup-route: Configuration line: default 10.53.64.1 0.0.0.0 eth0
..done.

Das VM selber läuft noch mit der alten IP (momentan funktionieren noch alte und neue IPs nebeneinander in der Übergangszeit) aber unser VM Mann meint, dass die Netzwekkommunikation vom Linux nicht beeinflusst wird.

Gibt es noch irgendwelche Daten die ich im Linux ändern muss?

Für paar Anregungen wäre ich dankbar.

Gruß,
Marc
 

N. Etwork
Gast





BeitragVerfasst am: 29. Okt 2004 1:32   Titel:

Richtige Einträge? In sich betrachtet vielleicht, aber dein Host ist mit 10.53.6.71/11 eben nicht im Netz 10.53.64 des Standardgateways:

ifup-route: RTNETLINK answers: Network is unreachable

Vielleicht hilft 64+6?
 

Maaak
Gast





BeitragVerfasst am: 29. Okt 2004 8:36   Titel:

Mist, jetzt tausch ich extra die 10.53 durch xx.xx aus und dann vergess ichs beim Router Smile

Stimmt, da hast Du vollkommen recht. Komisch ist allerdings, dass mein Kollege, der z/OS fährt und im gleichen Subnet ist wie ich mit diesem Gateway kein Problem hat.
Probiers aber auf alle Fälle mit 10.53.0.1 bei mir.

Danke soweit,
Marc
 

Maaak
Gast





BeitragVerfasst am: 29. Okt 2004 16:04   Titel:

Wunderbar, hat geklappt.

Besten Dank für den Hinweis und schönes Wochenende.

Marc
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy