Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Falsches Dateisystem nach Online Update

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Dr.Thodt
Gast





BeitragVerfasst am: 06. Nov 2004 18:32   Titel: Falsches Dateisystem nach Online Update

Hallo, ich hab ein schwerwiegendes Problem und hoffe, mir kann hier jemand helfen:

Ich hab mir die SuSE 9.1 SE parallel zu Win XP auf meinem Rechner installiert.
Nachdem ich ein Online Update von Linux durchgeführt habe, komm ich an mein Windows System nicht mehr dran.
GRUB meldet ein unbekanntes Dateisystem. Laut Linux sind nun alle Partitionen Linux Native und Partition Magic kann mit der Partitionstabelle gar nix mehr anfangen. Verschiedene Diagnose-Programme bestätigen mir aber nach wie vor, daß die Windows Partitionen NTFS sind.

Bin für jede Hilfe Dankbar!

Gruß
Carsten
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 06. Nov 2004 19:16   Titel:

Wie es aussieht, wurde "nur" der Typ in der Partitionstabelle überschrieben.

su
cfdisk


In dem Programm cfdisk die Option Type ausführen und bei deinen NTFS-Partitionen
17 angeben. Um die Einstellung zu übernehmen auf write und mit yes
bestätigen. Danach Reboot um die Partitionstabelle neu einlesen zu lassen.

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Dr.Thodt
Gast





BeitragVerfasst am: 06. Nov 2004 20:36   Titel:

cfdisk meldet:
FATALER FEHLER: Konnte nicht auf die Festplatte zugreifen
eine Taste drücken,um cfdisk zu beenden

Crying or Very sad

Und nu?
 

Dr.Thodt
Gast





BeitragVerfasst am: 06. Nov 2004 20:52   Titel:

Hmm, ich hab einfach mal fdisk ausgeführt und mir die Daten anzeigen lassen.

da steht soweit alles richtig:
hdc1 ist NTFS
hdc2 ist win95ext
hdc5 ist NTFS
hdc6 ist NTFS
hdc7 ist Fat16 (?)
hdc8 ist Linux Swap
hdc9 ist Linux

Zusätzlich zeigt er noch an, daß die Partition 2 nicht an einer Zylindergrenze endet (?)

*verwirrter als je zuvor*
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 06. Nov 2004 21:19   Titel:

Ist bei der Win-Bootpartition ein Bootflag gesetzt ( hdc1(?) )?
Poste mal fdisk -l .

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Dr.Thodt
Gast





BeitragVerfasst am: 06. Nov 2004 21:24   Titel:

fdisk -l
Code:

Platte /dev/hdc: 100.0 GByte, 100030242816 Byte
16 Köpfe, 63 Sektoren/Spuren, 193821 Zylinder
Einheiten = Zylinder von 1008 * 512 = 516096 Bytes

   Gerät Boot      Start         End      Blocks   Id  System
/dev/hdc1   *           1       40641    20483032+   7  HPFS/NTFS
/dev/hdc2           40641      193816    77200357+   f  W95 Ext'd (LBA)
Partition 2 endet nicht an einer Zylindergrenze.
/dev/hdc5           40641       98442    29131861+   7  HPFS/NTFS
/dev/hdc6           98462      179744    40965718+   7  HPFS/NTFS
/dev/hdc7          193785      193816       16033+   4  FAT16 <32M
/dev/hdc8          179744      181792     1032633   82  Linux Swap
/dev/hdc9          181793      193784     6043936+  83  Linux

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 06. Nov 2004 22:46   Titel:

Die Partitionstabelle sieht eigentlich normal aus.
Wenn es meine Platte wäre würd ich mal auf doof probieren:
win-Install-CD rein;
bis zur Konsole (Installation reparieren...bla)
fix mbr

Dann die Suse-Install-CD rein, booten, installiertes System starten
und dann Bootloader neu installieren (Kontrollzentrum, System, Bootmanager) .


Klappts so?

MfG, Klopskuchen

ps. Ist Samstag Nacht, geh jetzt einen heben. Bis morgen. Smile
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Dr.Thodt
Gast





BeitragVerfasst am: 06. Nov 2004 23:02   Titel:

Ja, da ist das Problem... ich find die blöde CD grad nicht.
Ich hatte gehofft, daß meine ach so tolle Bluecon CD das auch kann, kann se aber offensichtlich nicht.

Ein anderer "Spezialist" meinte, ich solle mal fdisk -mbr versuchen...
war sehr spaßig, danach ging nichtmal mehr die susi...

Naja, ich geb's bald auf hier *heul*.. dir trotzdem einen schönen Abend. Ich such derweil mal die Windoof CD *alles auf den kopf stell*
 

Dr.Thodt
Gast





BeitragVerfasst am: 07. Nov 2004 13:47   Titel:

Sodele, da sind wir wieder...
der aktuelle Stand ist folgender:

FIXMBR hat nichts gebracht, ausser daß vom System eben nichts mehr gebootet wurde.
Ich glaube, daß die Ursache für das Problem eine falsche Partitiontabelle ist. Zwei Partitionen überlappen sich wohl.
Ich schätze, daß ich um ne neue installation nicht herum kommen werde Sad
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 07. Nov 2004 14:25   Titel:

So steht es bei Susi geschrieben:

Zitat:
Das Partitionierungswerkzeug parted, welches im Zuge der Installation von YaST verwendet wird, schreibt unter bestimmten Umständen eine falsche Partitionstabelle.

Das Problem tritt auf, wenn

* BIOS und Linux unterschiedliche Plattengeometrien "sehen" UND
* die Windows-Partition größer als ca. 8GB ist (bzw. genauer, wenn die erste Festplattenpartition auf dem Zylinder 1024 endet oder darüber hinausreicht).


Die Lösung steht auch dort.
http://portal.suse.com/sdb/de/2004/05/fhassel_windows_not_booting91.html

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Dr.Thodt
Gast





BeitragVerfasst am: 07. Nov 2004 23:08   Titel:

Das ist sehr sehr schade... weil ich nicht mehr damit gerechnet habe, daß sich das Problem noch irgendwie beheben lässt, hab ich die ganze Platte platt gemacht und dementsprechend sind meine Windows Partitionen weg. Windows lies sich aber auch nicht mehr installieren. Deswegen fahr ich jetzt Linux und kauf mir n neuen Rehcner (so lächerlich das klingt, aber ich mein das ernst)

Vielen Dank für deine Hilfe Crying or Very sad
 

Soulfly



Anmeldungsdatum: 16.04.2003
Beiträge: 137
Wohnort: Buchholz idN

BeitragVerfasst am: 11. Nov 2004 19:28   Titel:

Auch wenn es jetzt zu spät ist...

Windows hat Probleme von Partitionen zu booten die vom Bios nicht in "LBA" angesprochen werden. Hatte auch mal das Problem, und bin fast irre geworden. Aus irgendwelchen Gründen hat das Bios die Platte nicht automatisch in LBA angesprochen, sondern "large".
Hab dann von Auto auf LBA umgestellt, und es lief..
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy