Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
ati treiber

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
poschl



Anmeldungsdatum: 19.06.2004
Beiträge: 141
Wohnort: Böblingen

BeitragVerfasst am: 12. Nov 2004 20:28   Titel: ati treiber

guten abend allerseits....
hab suse 9.2 und vermisse dreide unterstützung für meine
radeon 9600xt. auf der ati seite gibt es zwar treiber zum downloaden -
aber die scheinen alle nicht für meine xf86 version zu passen.
soweit ich das erkennen konnte ist auf der suse distro xf86 in version
4.8 drauf????
gibt es treiber für diese karte - und wenn dann wooooo????
auf der ati seite wird immer nur von xf86 in version 4/4.1/4.2/4.3
gefaselt. kann es sein das die in der entwicklung leicht rückständig sind?

thx im voraus....
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Schnalf
Gast





BeitragVerfasst am: 13. Nov 2004 10:49   Titel:

hi!
hab die selbe karte und die selben probleme. da ich aber suse 9.1 pro hab, hab ich auch xf86 4.3 . mit den treibern von der ati-seite kommt man aber nich weiter. eigentlich müsste man unter dem treiber der 9600-serie verstehen das er für die karte passt. macht er aber nicht. der ist für irgendwelche ganz anderen dinger die nichts mit 9600 zu tun haben.

war zwar keine keine wirkliche hilfe, musste aber gesagt werden

schnalf
 

arthur
Gast





BeitragVerfasst am: 13. Nov 2004 11:17   Titel:

das problem kenne ich. hab nach langen suche was gefunden was unter suse 9.1 funtzt.
hier der text:

Installing ATI 'fglrx' driver (3.12.0) on SuSE 9.1
-------------------------------------------------------

The following instructions explain how to install and enable release
3.12.0 of this driver.

The driver supports RV250, RV280, R200, RV350, R300, R350 chipsets of
ATI. Popular boards using these chipsets are:

- ATI Radeon 8500 / 9100
- ATI FireGL 8700 / 8800 / E1
- ATI FireGL T2
- ATI Radeon 9000
- ATI Radeon 9200
- ATI Radeon 9500
- ATI Radeon 9600
- ATI Radeon 9700
- ATI Radeon 9800
- ATI FireGL Z1 / X1 / X2
- ATI Mobility M9
- ATI Mobility FireGL 9000
- ATI Mobility M9PLUS

HOWTO
-----

1) Update XFree86 drivers

# rpm -Uhv fglrx*.rpm


2) Update kernel module

* prepare kernel module build

- install the following packages with YaST:
+ kernel-source
+ make
+ gcc
- use YaST Online Update (YOU) and - if available - select the
kernel patch to make sure that the kernel sources match the
current running kernel
- configure the kernel sources
# cd /usr/src/linux
# rm -f .config
# make cloneconfig
# make prepare-all (only for kernel-source >= 2.6.5-7.75)

* install kernel module source

# rpm -Uhv km_fglrx*.rpm

* compile kernel module sources

# cd /usr/src/kernel-modules/fglrx
# KERNEL_SOURCE=/usr/src/linux make modules
# KERNEL_SOURCE=/usr/src/linux make install
# depmod -a


3) Configure X11

# sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl


4) Enable 3D support

* edit /etc/X11/XF86Config with your favorite editor

- add

Load "dri"

to Section "Module"


5) Known Issues

- driver only supports 24bit color depth
- enabling of 3D support through SaX2 does not work
- driver cannot be used on AMD64 architecture
- kernel agp support for SiS 648 chipsets seems to be broken. Use

Option "UseInternalAGPGART" "yes"

(instead of Option "UseInternalAGPGART" "no") in Section "Device" of
/etc/X11/XF86Config to use the builtin agp support of the "fglrx"
kernel module. Remove "06" from COLDPLUG_PCI_CLASSES_WHITELIST in
/etc/sysconfig/hotplug. Reboot your machine. In some cases Xserver
needs to be started twice before internal agp support works.


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

PLEASE NOTE THAT THERE IS NO WARRANTY AND THAT WE DO NOT PROVIDE SUPPORT
FOR THESE PACKAGES!

PLEASE USE "http://www.suse.de/feedback" FOR ANY FEEDBACK.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

Fat_Fox_no log
Gast





BeitragVerfasst am: 15. Nov 2004 7:17   Titel:

andernfalls kann das online update helfen gestern war da ein patch für die atikarten bei glaub ich...
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy