Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
10Mbit fest einstellen
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
herman
Gast





BeitragVerfasst am: 23. Nov 2004 11:33   Titel: 10Mbit fest einstellen

moin moin,

ich habe erfolgreich Knoppix 3.6 installiert.
Da der Rechner aber ein paar Meter zu weit weg vom Hub steht ist die automatische Einstellung der Netzwerkarte auf 100MBit Full duplex nicht moöglich. Sobald ich aber mit dem mii-tool dies auf 10MBit hlaf duplex einstelle geht es wunderbar mit dem LAN.

Wie kann ich nun die Einstellung für die Netzwerkarte dauerhaft auf 10Mbit umstellen.

Unter /etc/network sind ein paar files dazu aber wo muss welcher Eintrag rein?

der herman
 

herman
Gast





BeitragVerfasst am: 23. Nov 2004 13:28   Titel: RE: 10Mbit fest einstellen

hier der interressante File.
Ich denke das da wo jetzt 'auto# steht was anders hin muss, ODER ??


# /etc/network/interfaces -- configuration file for ifup(Cool, ifdown(Cool

# The loopback interface
# automatically added when upgrading
auto lo eth0
iface lo inet loopback


iface eth0 inet dhcp
 

herman
Gast





BeitragVerfasst am: 23. Nov 2004 15:35   Titel: RE: 10Mbit fest einstellen

also mit dem mii-tool kann ich dies (unter root versteht sich) für die aktuelle session einstellen, aber nicht mehr.
Nach einem reboot ist alles wieder bei alten >> 100mbit

wer weiss wie ich was ändern muss?

merci

der herman
 

jochen
prolinux-forum-admin


Anmeldungsdatum: 14.01.2000
Beiträge: 699
Wohnort: Jülich

BeitragVerfasst am: 23. Nov 2004 15:51   Titel:

Im groben gibt es da zwei Möglichkeiten: Entweder Du setzt in einer boot.local/rc.local den mii-tool-Aufruf rein, so dass er bei jedem Booten ausgeführt wird, oder Du schaust, ob das Modul für die Netzwerkkarte einen Parameter kennt, dass die Karte direkt mit den passenden Parametern initialisiert wird. Ein "modinfo nic-modul" sagt Dir, was Du da einstellen könntest. Wenn es einen passenden Parameter gibt, müsstest Du den in eine options-Zeile in die /etc/modprobe.conf packen (/etc/modules.conf, falls Du noch den 2.4er Kernel verwendest).

Das war zwar etwas stichwortartig (sorry, bin in Eile), aber es hilft hoffentlich.

Jochen
_________________
Die grösste Lüge der EDV? "Mal eben..."
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

herman
Gast





BeitragVerfasst am: 24. Nov 2004 8:59   Titel: RE: 10Mbit fest einstellen

Hallo Jochen,

wie kann ich den mii-tool Befehl bootbar machen und welche boot.loacl/rc muss ich nemen.

merci
der herman
 

herman
Gast





BeitragVerfasst am: 01. Dez 2004 20:11   Titel: geht immer noch nicht :(

Also ich hab unter
file:/boot/

den file boot.0301 gefunden > was da steht verstehe ich aber nicht
Der relevante Eintrag sieht so aus :


#
# Ethernet (10 or 100Mbit)
#
CONFIG_NET_ETHERNET=y
# CONFIG_SUNLANCE is not set
CONFIG_HAPPYMEAL=m
# CONFIG_SUNBMAC is not set
# CONFIG_SUNQE is not set
CONFIG_SUNGEM=m
CONFIG_NET_VENDOR_3COM=y
CONFIG_EL1=m
CONFIG_EL2=m
CONFIG_ELPLUS=m
CONFIG_EL16=m
CONFIG_EL3=m
CONFIG_3C515=m
CONFIG_ELMC=m
CONFIG_ELMC_II=m
CONFIG_VORTEX=m
CONFIG_TYPHOON=m
CONFIG_LANCE=m
CONFIG_NET_VENDOR_SMC=y
CONFIG_WD80x3=m
CONFIG_ULTRAMCA=m
CONFIG_ULTRA=m
CONFIG_ULTRA32=m
CONFIG_SMC9194=m
CONFIG_NET_VENDOR_RACAL=y
CONFIG_NI5010=m
CONFIG_NI52=m
CONFIG_NI65=m
CONFIG_AT1700=m
CONFIG_DEPCA=m
CONFIG_HP100=m
CONFIG_NET_ISA=y
CONFIG_E2100=m
CONFIG_EWRK3=m
CONFIG_EEXPRESS=m
CONFIG_EEXPRESS_PRO=m
CONFIG_HPLAN_PLUS=m
CONFIG_HPLAN=m
CONFIG_LP486E=m
CONFIG_ETH16I=m
CONFIG_NE2000=m
CONFIG_SKMC=m
CONFIG_NE2_MCA=m
CONFIG_IBMLANA=m
CONFIG_NET_PCI=y
CONFIG_PCNET32=m
CONFIG_AMD8111_ETH=m
CONFIG_ADAPTEC_STARFIRE=m
CONFIG_AC3200=m
CONFIG_APRICOT=m
CONFIG_B44=m
CONFIG_CS89x0=m
CONFIG_TULIP=m
# CONFIG_TULIP_MWI is not set
# CONFIG_TULIP_MMIO is not set
CONFIG_DE4X5=m
CONFIG_DGRS=m
CONFIG_DM9102=m
CONFIG_EEPRO100=m
# CONFIG_EEPRO100_PIO is not set
CONFIG_E100=m
CONFIG_LNE390=m
CONFIG_FEALNX=m
CONFIG_NATSEMI=m
CONFIG_NE2K_PCI=m
CONFIG_FORCEDETH=m
CONFIG_NE3210=m
CONFIG_ES3210=m
# CONFIG_8139CP is not set
CONFIG_8139TOO=m
# CONFIG_8139TOO_PIO is not set
CONFIG_8139TOO_TUNE_TWISTER=y
CONFIG_8139TOO_8129=y
# CONFIG_8139_OLD_RX_RESET is not set
CONFIG_SIS900=m
CONFIG_EPIC100=m
CONFIG_SUNDANCE=m
# CONFIG_SUNDANCE_MMIO is not set
CONFIG_TLAN=m
CONFIG_VIA_RHINE=m
CONFIG_VIA_RHINE_MMIO=y
CONFIG_WINBOND_840=m
CONFIG_NET_POCKET=y
CONFIG_ATP=m
CONFIG_DE600=m
CONFIG_DE620=m


Weiterhin gibt es unter file:/etc/sysconfig/netcard auch noch nen schönen File , der da heißt netcard, da steht aber nur:

FULLNAME="Realtek|RTL-8139"
DRIVER="8139too"

Wo stelle ich nur die 10 Mbit ein.

es geht nach wie vor nur mit dem Komando :

mii-tool -F 10baseT-HD (als root)

Gruss

der herman
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 01. Dez 2004 21:44   Titel:

Trage den Befehl (mii-tool -F 10baseT-HD) in die Datei /etc/init.d/bootmisc.sh ein, am besten einfach ganz am Ende einfügen.
 
Benutzer-Profile anzeigen Private Nachricht senden

herman
Gast





BeitragVerfasst am: 02. Dez 2004 21:16   Titel: 10mbit geht immer noch nicht :(

Danke, hab ich eingetragen aber es steht leider immer noch :

mii-tool -v
eth0: negotiated 100baseTx-HD, link ok

hier der sciprt bootmisc.sh

hab ich das so richtig eingetragen??


#
# bootmisc.sh Miscellaneous things to be done during bootup.
#
# Version: @(#)bootmisc.sh 2.78 13-Nov-1999 miquels@cistron.nl
#

. /etc/default/rcS
#
# Put a nologin file in /etc to prevent people from logging in before
# system startup is complete.
#
if [ "$DELAYLOGIN" = yes ]
then
echo "System bootup in progress - please wait" > /etc/nologin
cp /etc/nologin /etc/nologin.boot
fi

#
# Wipe /tmp (and don't erase `lost+found', `quota.user' or `quota.group')!
# Note that files _in_ lost+found _are_ deleted.
#
[ "$VERBOSE" != no ] && echo -n "Cleaning: /tmp "
#
# If $TMPTIME is set to 0, we do not use any ctime expression
# at all, so we can also delete files with timestamps
# in the future!
#
if [ "$TMPTIME" = 0 ]
then
TEXPR=""
else
TEXPR="! -ctime -$TMPTIME"
fi
( cd /tmp && \
find . -xdev \
$TEXPR \
! -name . \
! \( -name lost+found -uid 0 \) \
! \( -name quota.user -uid 0 \) \
! \( -name quota.group -uid 0 \) \
-depth -exec rm -rf -- {} \; )
rm -f /tmp/.X*-lock
#
# Clean up any stale locks.
#
[ "$VERBOSE" != no ] && echo -n "/var/lock "
( cd /var/lock && find . -type f ! -newer /etc/mtab -exec rm -f -- {} \; )
#
# Clean up /var/run and create /var/run/utmp so that we can login.
#
[ "$VERBOSE" != no ] && echo -n "/var/run"
( cd /var/run && \
find . ! -type d ! -name utmp ! -name innd.pid ! -name random-seed \
! -newer /etc/mtab -exec rm -f -- {} \; )
: > /var/run/utmp
if grep -q ^utmp: /etc/group
then
chmod 664 /var/run/utmp
chgrp utmp /var/run/utmp
fi
[ "$VERBOSE" != no ] && echo "."

#
# Set pseudo-terminal access permissions.
#
if [ -c /dev/ttyp0 ]
then
chmod 666 /dev/tty[p-za-e][0-9a-f]
chown root:tty /dev/tty[p-za-e][0-9a-f]
fi

#
# Update /etc/motd.
#
if [ "$EDITMOTD" != no ]
then
uname -a > /etc/motd.tmp
sed 1d /etc/motd >> /etc/motd.tmp
mv /etc/motd.tmp /etc/motd
fi

#
# Save kernel messages in /var/log/dmesg
#
dmesg > /var/log/dmesg

# enable DMA
/sbin/hdparm -qd1 /dev/hdc
/sbin/hdparm -qd1 /dev/hda

mii-tool -F 10baseT-HD
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 02. Dez 2004 22:27   Titel:

Ja, eigentlich schon.

Versuch mal:

- den Befehl mit voller Pfadangabe einzutragen (z. B. /sbin/mii-tool ..., wenn's bei Dir dort ist).
- die Ausgabe des befehls zu loggen:

mii-tool -F 10baseT-HD &> /var/log/mii-tool.bootlog

Dann kannst Du die Ausgabe des Befehls mit

cat /var/log/mii-tool.bootlog

sehen. Wenn's dann nicht klappt schreib mal, was in der Logdatei steht.
 
Benutzer-Profile anzeigen Private Nachricht senden

herman



Anmeldungsdatum: 03.12.2004
Beiträge: 30

BeitragVerfasst am: 03. Dez 2004 16:16   Titel:

Hallo,

der File bootlog wird erstellt, bleibt aber leider leer Sad

#
# bootmisc.sh Miscellaneous things to be done during bootup.
#
# Version: @(#)bootmisc.sh 2.78 13-Nov-1999 miquels@cistron.nl
#

. /etc/default/rcS
#
# Put a nologin file in /etc to prevent people from logging in before
# system startup is complete.
#
if [ "$DELAYLOGIN" = yes ]
then
echo "System bootup in progress - please wait" > /etc/nologin
cp /etc/nologin /etc/nologin.boot
fi

#
# Wipe /tmp (and don't erase `lost+found', `quota.user' or `quota.group')!
# Note that files _in_ lost+found _are_ deleted.
#
[ "$VERBOSE" != no ] && echo -n "Cleaning: /tmp "
#
# If $TMPTIME is set to 0, we do not use any ctime expression
# at all, so we can also delete files with timestamps
# in the future!
#
if [ "$TMPTIME" = 0 ]
then
TEXPR=""
else
TEXPR="! -ctime -$TMPTIME"
fi
( cd /tmp && \
find . -xdev \
$TEXPR \
! -name . \
! \( -name lost+found -uid 0 \) \
! \( -name quota.user -uid 0 \) \
! \( -name quota.group -uid 0 \) \
-depth -exec rm -rf -- {} \; )
rm -f /tmp/.X*-lock
#
# Clean up any stale locks.
#
[ "$VERBOSE" != no ] && echo -n "/var/lock "
( cd /var/lock && find . -type f ! -newer /etc/mtab -exec rm -f -- {} \; )
#
# Clean up /var/run and create /var/run/utmp so that we can login.
#
[ "$VERBOSE" != no ] && echo -n "/var/run"
( cd /var/run && \
find . ! -type d ! -name utmp ! -name innd.pid ! -name random-seed \
! -newer /etc/mtab -exec rm -f -- {} \; )
: > /var/run/utmp
if grep -q ^utmp: /etc/group
then
chmod 664 /var/run/utmp
chgrp utmp /var/run/utmp
fi
[ "$VERBOSE" != no ] && echo "."

#
# Set pseudo-terminal access permissions.
#
if [ -c /dev/ttyp0 ]
then
chmod 666 /dev/tty[p-za-e][0-9a-f]
chown root:tty /dev/tty[p-za-e][0-9a-f]
fi

#
# Update /etc/motd.
#
if [ "$EDITMOTD" != no ]
then
uname -a > /etc/motd.tmp
sed 1d /etc/motd >> /etc/motd.tmp
mv /etc/motd.tmp /etc/motd
fi

#
# Save kernel messages in /var/log/dmesg
#
dmesg > /var/log/dmesg

# enable DMA
/sbin/hdparm -qd1 /dev/hdc
/sbin/hdparm -qd1 /dev/hda

/sbin/mii-tool -F 10baseT-HD &> /var/log/mii-tool.bootlog
 
Benutzer-Profile anzeigen Private Nachricht senden

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 03. Dez 2004 16:57   Titel:

Ich würde nicht sagen, die Datei bleibt leider leer, sondern zum Glück. Somit wurde das Programm ohne Fehler ausgeführt, in der Kommandozeile bekommst Du ja auch keine Meldung wenn alles geklappt hat.

Warum dann allerdings immer noch 100 Mbit eingestellt sind kann ich nicht sagen. Es sollte so klappen. Evtl. hat ja jemand noch ne Idee.
 
Benutzer-Profile anzeigen Private Nachricht senden

herman



Anmeldungsdatum: 03.12.2004
Beiträge: 30

BeitragVerfasst am: 04. Dez 2004 13:08   Titel: leideer immer noch nix

Hallo,

ok zum Glück bleibt die Datei leer, aber 10 Mbit kommen immer noch nicht von "alleine".

Kann ich den Befehl denn noch irgentwo einbauen das er automatisch beim start ausgeführt wird und zwar als 'root'

Gruss
der herman
 
Benutzer-Profile anzeigen Private Nachricht senden

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 04. Dez 2004 16:27   Titel:

Nein, es wird alles richtig ausgeführt. Das ist ja das komische. Auch dürfte der Befehl als root laufen. Wenn er's nicht tut, kommen ne Menge Fehler. Probier's mal:

Code:
$  /sbin/mii-tool -F 10baseT-HD
SIOCGMIIPHY on 'eth0' failed: Operation not permitted
SIOCGMIIPHY on 'eth1' failed: Operation not permitted
SIOCGMIIPHY on 'eth2' failed: Operation not permitted
SIOCGMIIPHY on 'eth3' failed: Operation not permitted
SIOCGMIIPHY on 'eth4' failed: Operation not permitted
SIOCGMIIPHY on 'eth5' failed: Operation not permitted
SIOCGMIIPHY on 'eth6' failed: Operation not permitted
SIOCGMIIPHY on 'eth7' failed: Operation not permitted
no MII interfaces found


Die Datei wird ja erstellt. Das heißt der Befehl wird ausgeführt. Das die Datei leer bleibt heißt, das kein Fehler aufgetreten ist.

Warum's nicht klappt weiß ich nicht, tut mir Leid.



P.S.: Hab's eben genau so probiert, bei mir funktioniert es.
 
Benutzer-Profile anzeigen Private Nachricht senden

herman



Anmeldungsdatum: 03.12.2004
Beiträge: 30

BeitragVerfasst am: 04. Dez 2004 16:56   Titel: jap

wenn ich das im Terminal Fenster eintippe dan geht's und nur als root
wenn ich kein root bin kommt der von Dir gezeigte Fehler.

trotzdem glaube ich das das mii-tool nicht beim systemstart ausgeführt wird.
da muß es doch noch einen anderen weg geben, oder ?
 
Benutzer-Profile anzeigen Private Nachricht senden

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 04. Dez 2004 18:20   Titel:

Sicher gibt es noch einen anderen Weg: Google mal nach System V Init-Skripten. Das ist mir etwas zu kompliziert, um es hier zu erklären. Die Methode per bootmisc.sh ist die quick'n'dirty-Methode, und funktioniert ja offensichtlich.

Ich sage es mal etwas anders: Wie sollte die Datei denn erstellt werden, wenn der Befehl nicht ausgeführt wird ? Er _wird_ ausgeführt. Wenn Du's nicht glaubst, tausche den Befehl doch mal gegen ein "echo bla", und guck ob entspechendes in der log-Datei landet.

Das Problem wird woanders liegen. Eine Idee von mir war, daß das Modul zu dem Zeitpunkt noch nicht geladen ist, wenn die bootmisc.sh ausgeführt wird. Dann wäre allerdings ne entsprechende Fehlermeldung in der log-Datei, daskann's also auch nicht sein.

Irgendwie muß das Problem woanders liegen, habe leider keine Ahnung wo.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy