Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Freigaben über Webmin und Daten austausch

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
bockel



Anmeldungsdatum: 12.12.2004
Beiträge: 8

BeitragVerfasst am: 12. Dez 2004 13:01   Titel: Freigaben über Webmin und Daten austausch

Ich komme aus der Windows Welt und habe wenig Erfahrung im Linux bereich und habe folgendes Problem.
Ich habe ein kleines Netzwerk mit 4 Arbeitsplätzen. 2 sind per Kabel angebunden und 2 per WLAN. Das OS ist Suse 9.1 und um was zu Konfigurieren habe ich Webmin installiert.
Auf einen Rechner sind Office Dateien die von allen PCs bearbeitet werden sollen. Auf diesen Rechner, ich nenne ihn mal PC 1, habe ich über Webmin ein Ordner freigegeben wo jeder schreibrechte drauf hat. Das erste Problem ist das ich sobald ich Rechte verteilt habe, ob User oder Gruppe, kein zugriff mehr hatte. Also habe ich jeden Zugriff erlaubt. Wenn jetzt aber jemand über das Netz die Dateien öffnet dann bearbeitet und Speichern will, speichert er sie nur ab und zu auf dem PC 1 meist aber in einer tmp Datei. Wie kann ich direckt auf PC1 über das Netz speichern? Oder Gibt es eine bessere Lösung? Liegt das an den Einstellungen von Open Office?

Gruß Bockel
 
Benutzer-Profile anzeigen Private Nachricht senden

tobi_odi



Anmeldungsdatum: 30.12.2003
Beiträge: 18
Wohnort: Dresden

BeitragVerfasst am: 13. Dez 2004 9:04   Titel:

Moin, moin,

ich habe auf meinem kleinen, privatem Netzwerk (Suse 9.0) NFS Server/ Clients laufen.
Im YaST gibst du unter NFS Server die zu exportierenden Ordner an und unter NFS Client mußt du nur den Host des anderen Servers angeben um die schon freigegebenen Ordner auszuwählen und z.B. unter /mnt/lan einzubinden. Optionen (Lesezugriff, Schreibberechtigung, ...) können ebenfalls in diesem Fenster vorgegeben werden.
Leider funktioniert das automatische Einbinden des zuletzt hochgefahrenen Rechners nicht, da er für den zuerst hochgefahrenen Rechner noch nicht vorhanden war. Das manuelle Einbinden dieses Rechners sollte von root aber mit "mount -t [Format reiserfs; ext2; o.ä] Host:/irgendwas /mnt/lan" funktionieren.

Außerdem ist "Der Koffler" ( http://www.pl-berichte.de/berichte/koflerlinux7.html ) für ambitionierte Linux-Einsteiger/ Anwender sehr zu empfehlen!


Gruß Thomas
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 13. Dez 2004 9:44   Titel:

Eigentlich immer
Code:
mount -t nfs [host]:[dir] [mount-dir]


Es ist egal, welches reale Dateisystem zugrunde liegt, es wird mit nfs angeboten.
 
Benutzer-Profile anzeigen Private Nachricht senden

bockel



Anmeldungsdatum: 12.12.2004
Beiträge: 8

BeitragVerfasst am: 13. Dez 2004 10:39   Titel: sobald neue Dateien in NFS-Ordner kommen hat man keine Schreibrechte mehr drauf

mit NFS funkt es wunder bar aber sobald ein User eine neue Datei erstellt hat nur noch der User schreibrechte und die andern nur noch Leserechte. Wie und wo kann ich das einstellen das alle Schreib und Leserechte haben.
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 13. Dez 2004 10:48   Titel:

Das liegt an der umask-Einstellung der User. Dadurch werden automatisch alle Dateien, die der User erstellt mit einer bestimmten Rechte-Maske ausgestattet. Versuch vielleicht mal
Code:

mount -t nfs -o umask 000 [host]:[dir] [mount-dir]

Ansonsten kannst du es auch bei den entsprechenden Usern in der ~/.bashrc oder ~/.profile einstellen. Einfach "umask 000" hinzufügen. Die erste Lösung ist allerdings empfehlenswerter, weil sich die umask-Einstellung sonst auf jegliche Dateien (lokal oder nicht lokal), die der User erstellt auswirkt.
 
Benutzer-Profile anzeigen Private Nachricht senden

bockel



Anmeldungsdatum: 12.12.2004
Beiträge: 8

BeitragVerfasst am: 13. Dez 2004 12:38   Titel: Super hat geklappt

vielen Dank
 
Benutzer-Profile anzeigen Private Nachricht senden

bockel



Anmeldungsdatum: 12.12.2004
Beiträge: 8

BeitragVerfasst am: 15. Dez 2004 9:01   Titel:

also mit den eintrag in .profile klappt das wunderbar aber mit den Befehl
mount -t nfs -o umask 000 [host]:[dir] [mount-dir]
mountet er erst garnich sondern gibt nur eine Fehlermeldun raus
ich habe eingegeben:
mount -t nfs -o umask 000 192.168.5.100:/home/tina/Documents/Datei /nfs
wobei das das Verzeichnis /home/tina... auf den NFS Server liegt und /nfs auf mein Rechner liegt.

Gruss
Bockel
 
Benutzer-Profile anzeigen Private Nachricht senden

bockel



Anmeldungsdatum: 12.12.2004
Beiträge: 8

BeitragVerfasst am: 15. Dez 2004 9:14   Titel:

Ach so das ist die Fehlermeldung:

buero4:~ # mount -t nfs - umask 000 192.168.5.100:/home/tina/Documents/Datei /nfs
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels

So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command

Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir

A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy