Anfängerfrage (erneutes Einbinden des Homeverzeichnisses nach Neuinstallation)

Antworten
Nachricht
Autor
goetstda

Anfängerfrage (erneutes Einbinden des Homeverzeichnisses nach Neuinstallation)

#1 Beitrag von goetstda » 20. Dez 2004 0:21

Hallo,

leider muss ich euch mit einer Anfängerfrage belästigen.
Ich habe mir Suse 9.2 installiert und hatte vorher Suse 9.0 mit einem Homeverzeichnis in einer separaten Partition.
Nach der Neuinstallation wollte ich nun das Homeverzeichnis wieder einbinden. Leider weiss ich nicht wie es geht und alles was ich bisher in Hilfen gefunden habe, hat mir leider auch nicht geholfen.

Anbei meine fstab:
/dev/hda6 / ext3 acl,user_xattr 1 1
/dev/hda7 /boot ext3 acl,user_xattr 1 2
/dev/hda9 /home ext3 noautor,user 0 0
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda5 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda8 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvd /media/dvd subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0

Vielleich kann mir jemand sagen, wie ich wieder mit meinem Homeverzeichnis arbeiten kann.

Vielen Dank im voraus.

Gruß
Stephan

Benutzeravatar
Hans Solo
prolinux-forum-admin
Beiträge: 601
Registriert: 20. Apr 2004 12:19
Wohnort: AT
Kontaktdaten:

#2 Beitrag von Hans Solo » 20. Dez 2004 9:10

hi

du musst in der zeile
/dev/hda9 /home ext3 noautor,user 0 0

das noautor (was ausserdem noauto heissen müsste) löschen.
dann müsste es wieder funktionieren

mfg
arno
[root@host]# cd /pub
[root@host]# more beer

goetstda

#3 Beitrag von goetstda » 20. Dez 2004 20:07

Hi,

hat leider nicht funktioniert.
Sobald ich das noauto herausnehme und neu starte bekomme ich folgende Fehlermeldungen:

- Could not read networ connection list /home/stephan/.DCOPserver_linux_O

- Einrichtungsdatei /home/stephan/.kde/share/config/krootimager
und
/home/stephan/.kde/share/config/kdeglobals
läßt sich nicht speichern.

KDE startet dann nicht.

Habe ich vielleicht etwas vergessen?

Danke und Gruß
Stephan

qwert

#4 Beitrag von qwert » 20. Dez 2004 23:13

wie sehen die verzeichnisrechte aus?
kann der user lesen und schreiben im /home verzeichnis?
wenn du es bei deiner erneuten installation nicht eingebunden hast werden die verzeichnisrechte einfach auf root gesetzt, und zwar so das der normale user keinen schreibzugriff hat.

Benutzeravatar
firedevil112
Beiträge: 1
Registriert: 21. Dez 2004 12:50

#5 Beitrag von firedevil112 » 21. Dez 2004 12:55

ich habes hin bekommen als ich nur defaults eingetragen habe ohne irgendetwas anderes.

mfg

goetstda

#6 Beitrag von goetstda » 22. Dez 2004 0:48

Nachdem ich den Eigentümer auf dem Homelaufwerk umbenannt und die Zugriffsrechte verändert habe, hat es funktioniert.
War ein harter Kampf für einen Anfänger, aber nur so lernt man weiter.

Vielen Dank nochmals für die Unterstützung.

Gruß
Stephan

Antworten