Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Auth-Problem bei Postfix mit Suse 8.1

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
jens osx
Gast





BeitragVerfasst am: 08. Jan 2005 1:42   Titel: Auth-Problem bei Postfix mit Suse 8.1

Hallo,

ich habe folgendes Problem in der Firma. Wir haben einen Linux-Mailserver und haben den Provider für den Email-Verkehr gewechselt. Per Samba Webshare habe ich von meinem OSX-Arbeitsplatz aus im Fetchmail die Daten Kontoname, Passwort und POP korrigiert. Als Auth-Methode zum Senden der Mails habe ich Password gewählt, wie vom Provider gefordert. Unter den Basis-Einstellungen von Postfix habe ich den SMTP-Server angegeben.

Nun kann ich über den neuen Provider die Mails empfangen, aber nicht senden. Fehlermeldung "530 Authentification required". Wo kann ich überall die Auth-Methode zum Versenden definieren, wenn nicht unter Fetchmail?

Ich würde gerne über ne Befehlszeile den Status abrufen. Dazu melde ich mich direkt am Rechner als Root an und gebe folgendes ein: /etc/postfix/main.cf. Dort sollte eigentlich die tatsächlichen Einstellungen stehen. Soweit komme ich aber erst garnicht. Fehlermeldung "Access denied". Habe ich als Root nicht eigentlich alle Rechte dazu?

Wer kann helfen?

Jens
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 08. Jan 2005 9:53   Titel:

hi

die authentifizierung am server eures providers musst du über postfix machen da fetchmail
ein reiner POP client ist.
http://www.tuxhausen.de/postfix_smtp_auth-3.html#41



ausserdem musst du die datei schon mit einem editor öffnen.
zb.
vi /etc/postfix/main.cf
und den status rufst du über
/etc/init.d/postfix status
ab.
mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

jens osx
Gast





BeitragVerfasst am: 09. Jan 2005 20:16   Titel:

cool. danke. werds direkt am Morgen mal versuchen.
Ein Leidensgenosse sprach auch mal von "SMTP after POP".

Weist du, wo ich diese Funktion eingeben kann im Postfix?

jens
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 09. Jan 2005 20:25   Titel:

hi

smtp after pop ist eine ander authentiefizierungsmethode.
das heist du darfst erst mails versenden wenn du kurz vorher dich mit pop angemeldet hast und damit am mailserver authentifiziert hast.

das ist glaub ich nicht das was du brauchst.


mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

jens osx
Gast





BeitragVerfasst am: 09. Jan 2005 20:43   Titel:

Da ich häufig mit Webmin die Postfix-Anwendung steuere, oder sie mich(!), und fast ausschließlich mit OSX zu tun habe, hab ichs nicht so drauf mit Befehlszeilen.

Nen Tipp wo ich unter Postfix den relevanten Haken setzen muß? Die Angabe unter den Mail Server Options - Auth Method PASSWORD schein ja nicht ganz zu reichen.

Nen Tipp?

Jens
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 09. Jan 2005 23:42   Titel:

hi

>>und fast ausschließlich mit OSX zu tun habe
das ist ja das geile an osx - es hat eine ordentliche kommandozeile *gg*

da ich webmin seit ca. 2 jahren nicht mehr verwende und auch auf meinem desktop
alles mit der kommandozeile mache kann ich dir leider nicht helfen bzw. deshalb weil ich auch keinen postfix am laufen habe.

sorry
mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

jens osx
Gast





BeitragVerfasst am: 10. Jan 2005 12:19   Titel:

Ha.
Geschafft.

Der Fehler lag an der sasl_passwd Datei. Hier war noch ein alter Eintrag drin, den ich über Webmin bei Postfix nicht einsehen konnte. Habe die Datei mit dem vi Editor überschrieben und mit dem postmap Befehl für Postfix konvertiert.

Was soll ich sagen. Nach dem Reload von Postfix funktionierte alles auf anhieb.

jens
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy