Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
xsane findet Scanner nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 13. März 2005 13:54   Titel: xsane findet Scanner nicht

Ich habe da ein kleines Problem. Ich kann meinen Scanner mit xsane nicht ansprechen. Ich erhalte stets die Meldung, das kein Gerät gefunden wurde.

Code:

Luna / # lsusb

Bus 002 Device 002: ID 03f0:1004 Hewlett-Packard DeskJet 970c/970cse
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 002: ID 04a9:2204 Canon, Inc. CanoScan FB630U
Bus 001 Device 001: ID 0000:0000


Code:

Luna / # lsusb -v -s 1:2

Bus 001 Device 002: ID 04a9:2204 Canon, Inc. CanoScan FB630U
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 Interface
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x04a9 Canon, Inc.
  idProduct          0x2204 CanoScan FB630U
  bcdDevice            0.01
  iManufacturer           0
  iProduct                3 CanoScan FB630U
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xa0
      Remote Wakeup
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass        16
      bInterfaceSubClass      1
      bInterfaceProtocol      0
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
        wMaxPacketSize         64
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
        wMaxPacketSize         64
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
        wMaxPacketSize         64
        bInterval               0
  Language IDs: (length=4)
     0409 English(US)


Es existiert auch in der Tat kein Device unter /dev/usb außer meinem Drucker:
Code:

Luna / # ls /dev/usb
lp0


Könnte dies dadurch verursacht werden, dass sich ein devfs-Demon um /dev kümmert und wenn ja, weiß jemand, wie ich die Gerätedatei erzeugen lassen kann?

ps: Es ist kein Rechteproblem. Ich habe xsane auch als root laufen lassen.

Gruß
Lateralus
 
Benutzer-Profile anzeigen Private Nachricht senden

rudifaxe
Gast





BeitragVerfasst am: 15. März 2005 1:10   Titel:

Welchen Typ von Scanner hast Du denn???
Fax
Smile
 

rudifaxe
Gast





BeitragVerfasst am: 15. März 2005 1:12   Titel:

Sorry, ist ein Canon... gerade gelesen.....
Hm- Wird der Scanner von Sane unterstützt und ist eine Firmware installiert??

Fax
Smile
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 15. März 2005 9:22   Titel:

Morgen.

Code:
Luna sane.d # ls /etc/sane.d/ | grep canon
canon.conf
canon630u.conf
canon_pp.conf


Der Canon630u ist ja genau mein Scanner. Ich denke also, dass er unterstützt wird.

Code:
Luna sane.d # cat canon630u.conf
# Options for the canonusb backend

# Autodetect the Canon CanoScan FB630u
usb 0x04a9 0x2204

# device list for non-linux-systems (enable if autodetect fails):
#/dev/scanner
#/dev/usb/scanner0


Leider existiert keines dieser Geräte, wie schon berichtet. Ein "find /dev | grep scan" findet gar nichts.

Code:
Luna sane.d # sane-find-scanner

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a SCSI driver for your SCSI adapter.

  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a driver for your USB host controller and have installed a
  # kernel scanner module.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.


Ich würde ja gerne einfach mal als root unter /dev ein device-file anlegen, aber ich habe keine Ahnung, welche Major und Minor Number ich da verwenden muss.

Ach ja: Firmware ist, glaube ich, nicht installiert. Ich hatte das Ding auch schon mal auf einem SuSE 9.1 laufen. Ich denke wirklich, dass der einzige Mangel das fehlende Device ist. Werd' mich mal ein wenig zum devfsd belesen.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy