Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Mounten mit Zusatzbefehlen?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Garfield
Gast





BeitragVerfasst am: 16. März 2005 9:31   Titel: Mounten mit Zusatzbefehlen?

Hallo,
das Mounten eines ZIP-Laufwerkes gelingt nicht, weil beim Booten und Laden des Moduls "imm" der Link /dev/sdb4 nicht erzeugt wird, wenn kein Medium eingelegt ist.
Dieses könnte man Lösen, indem man vor dem Mount-Befehl (bei eingelegtem Medium) einmal auf /dev/sdb zugreift, dann legt devfs nämlich /dev/sdb4 an.
Jetzt zur eigentlichen Frage : kann man irgendwie noch zusätzliche Befehle vor dem Mounten ausführen lassen? Ich verwende die Geräte-Links in KDE in der Kontrollleiste. Natürlich könnte ich ein Skript schreiben, aber mir wäre die Geräteliste lieber weil dort auch das Icon passend zum Mount-Zustand wechselt.

Garfield
 

brum
Gast





BeitragVerfasst am: 16. März 2005 15:22   Titel: mounten

Du verstehst den Begriff mounten etwas falsch.
Man kann keine Gehäuse mounten, sondern nur wirklich vorhandene Datenträger.

bye brum
 

Garfield
Gast





BeitragVerfasst am: 16. März 2005 17:00   Titel: Mounten

(Seufz), also ich erklär's noch mal gaaaanz langsam

- Systemstart : kein Medium im ZIP, Modul "imm" wird durch init-scripts geladen
- viel später : Medium einlegen, ZIP-Icon, klick, "Laufwerk einbinden", Meldung /dev/sdb4 existiert nicht, nachgucken in /dev, jawoll, existiert nicht.
- Medium drinlassen, ein "true > /dev/sdb" von Konsole eingeben, jetzt gibbet /dev/sdb4 und das mounten klappt dann auch

Also nun : kann ich irgendwie dem Geräte-Icon (KDE) beibringen, dass es vor dem mount-Versuch ein "true > /deb/sdb" absetzt, damit /dev/sdb4 auch sicher existiert?

Garfield
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 16. März 2005 17:36   Titel:

hi

schreib das "true > /deb/sdb" einfach in eine init file oder in
/etc/rc.d/rc.local

dann legt es das /dev/sdb bei jedem neustart an.

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Garfield
Gast





BeitragVerfasst am: 17. März 2005 8:07   Titel: Mounten

Hallo,

das funktioniert eben nicht. Ein ZIP-Medium ist normalerweise mit einer Partition 4 vorformatiert. Wenn beim Booten und Laden des IMM-Treibers (ZIP100 parallel) KEIN Medium im Laufwerk liegt, dann wird von DEVFS nur /dev/sdb angelegt.
Der richtige Verweis /dev/sdb4 (mit der 4 hin dran für die 4. Partition) wird NUR angelegt, wenn ein Medium drin liegt und somit ein Zugriff erfolgen kann.

Es ist auch keine Lösung, das Modul IMM erst beim Mounten automatisch laden zu lassen, weil ich 2 SCSI-Wechselplatten-LW habe. je nachdem welches zuerst benutzt wird, ist dann das ZIP-LW /dev/sda4 oder /dev/sdb4. In FSTAB ist aber /dev/sdb4 vorgegeben.

you see the problem?

Garfield
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy