Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Verbindungen zu einem Sambaserver trennen

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Fat_Fox_no log
Gast





BeitragVerfasst am: 21. März 2005 12:32   Titel: Verbindungen zu einem Sambaserver trennen

hi @all,

ich habe meinen sambaserver unter Suse Linux 9.2 mit yast konfiguriert und als benutzer erstmal nur den root user für samba eingerichtet, unter windows xp prof. hab ich dann versucht auf die freigaben zuzugreifen was nach eingabe des benutzers root und dessen passwort auch funktionierte, jetzt bekomme ich nachdem ich beide rechner runter gefahren hatte und am nächsten tag neu gestartet hatte, unter windows die fehlermeldung das mehrfachverbindungen zu einem Server unzulässig seien, nun interessiert mich wie ich rausfinde ob da noch verbindungen aktiv sind und wie ich die kappen kann, und als nächste frage, wie kann ich unter suselinux 9.2 neue sambabenutzer einrichten ?

für hilfe danke ich euch im Vorraus

Fat_Fox
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 21. März 2005 15:15   Titel:

hi

mit
smbstatus kannst du dir alle verbindungen anzeigen lassen.
an hand der PID kannst du dann den prozess killen.

mittels
smbpasswd -a <user>
legst du neue sambauser an - diese müssen aber auf linux ebene schon exestieren.

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Fat_Fox_no log
Gast





BeitragVerfasst am: 22. März 2005 7:23   Titel:

danke erstmal für die hilfe, das mit den usern hat gefunzt aber der status befehl liefert kein ergebniss, ich könnte schwören das mein windows da irgendwas durcheinander bringt, ich werd mal die ip des servers ändern und so tun als wär ich ein anderer server, vieleicht loggt das xp irgendwas mit von dem ich nix weiß.
 

S. Alsa
Gast





BeitragVerfasst am: 22. März 2005 20:59   Titel:

Wenn Du nur ein Explorer-Fenster mit der Anzeige der Services der Samba-Maschine hast, ist Windos verbunden! Beim benutzen der Services natürlich erst recht. Schließen hilft dann oft auch nicht mehr (Vielleicht eine Ewigkeit warten? Evtl. zugewiesene LW-Buchstaben lösen*), also wenigstens neu anmelden oder Neustart. Das mit den nicht erlaubten (Mehrfach-)Verbindungen unterschiedlicher Identität ist natürlich etwas schwach. Würde mich mal interessieren, ob das bei einem Windos-(Terminal-)Server auch so ist. Dos war halt nicht als Multiuser-System gedacht. Ist wohl aber inzwischen besser als die meisten dafür geschriebenen Programme.

Willst Du einen Service mit unterschiedlichen Rechten unter einer Windos-Anmeldung nutzen, legst Du ihn doppelt an:

[FREIGABE]
path = /der/selbe
# ro, für normale (bzw. alle) user
...

[FREIGABE_adm]
path = /der/selbe
# rw, nur für Admins
; unsichtbar
browseable = 0
; ginge auch mittels valid users :
admin users = ich, @admingroup
;; oder/und folgende Parameter sind gerade in diesem
;; Zusammenhang nuetzlich
;valid users = ...
;create mode = ...
;force user/group = ...
;inherit acls/permissions = ...
...

Ich hoffe es hilft etwas.

* Ordentliche Programme funktionieren _ohne_ Zuweisung irgendwelcher Laufwerksbuchstaben (\\SERVER\SERVICE\PATH sollte reichen). Und Massenspeicher lassen sich auch wie unter Unix (in ein Verzeichnis) mounten, man kommt also fast ohne diesen Buchstaben-Quatsch aus!
 

Fat_Fox_no log
Gast





BeitragVerfasst am: 01. Apr 2005 8:54   Titel:

also neustarten und neuanmelden bringt weder beim server noch beim client etwas, ich habe das gefühl das xp "weiß" aus irgend einem grunde das ich schonmal als ordentlicher benutzer auf dem server angemeldet war, was ja wie ich geschildert hatte schonmal alles wunderbar gefunzt hat, nun ging es aber nach dem ausschalten des gesamten systems ja nich mehr, normalerweise trennt das xp beim runterfahren alle verbindungen...ich weiß aber nicht mehr sicher ob ich nicht ev. erst server und dann client ausgeschaltet habe, in dem fall müsste aber das runterfahren des servers die verbindung auf jeden fall gekillt haben, das ändern der IP war erfolglos, in der smb.conf man-page stand was zu einem befehl der dem server erlaubt nach der eingegebenen zeit alle verbindungen zu trennen...eine art timeout...könnte das was helfen...und weiß vieleicht einer aus dem stehgreif wie die syntax war ?...dann muss ichs nicht nochmal suchen um das zu testen.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy