Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
SuSE 9.2 und Sil Image 3114 Sata Controller -> Probleme

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
mali



Anmeldungsdatum: 22.03.2005
Beiträge: 13
Wohnort: Leverkusen / NRW

BeitragVerfasst am: 22. März 2005 19:35   Titel: SuSE 9.2 und Sil Image 3114 Sata Controller -> Probleme

Hallo zusammen,

als erstes, habe schon überall gegoogelt und nachgeforscht, aber leider keine Antwort gefunden und bin am verzweifeln.

Will von Win weg und primär Linux nutzen. Aber bei der Intallation der 9.2 64 Bit Version wird meine Sata Platte nit erkannt. Läuft nicht unter RAID!!!
Warum nicht ?????? Crying or Very sad

Bitte um Verständnis für etvl. dumme Frage, aber bin halt ein Anfänger.

Danke schon mal.

Gruß

mali
 
Benutzer-Profile anzeigen Private Nachricht senden

jochen
prolinux-forum-admin


Anmeldungsdatum: 14.01.2000
Beiträge: 699
Wohnort: Jülich

BeitragVerfasst am: 23. März 2005 11:31   Titel:

Hi,

im 2.6.11er Kernel habe ich unter Device Drivers/SCSI device support/SCSI lowlevel drivers/Serial ATA (SATA) support einen Treiber für Silicon Image 3114 gefunden - zumindest sagt der Source, dass er den Controller kennt, auch wenn das scheinbar sonst nirgendwo erwähnt wird. Das Modul, dass zu laden ist, heisst "sata_sil.ko".

Kannst Du in einer Konsole (Mittels Strg-Alt-F1/2/3 oder so zu erreichen) ein "lsmod" eintippen und schauen, ob der Treiber geladen ist oder versuchen, ihn mittels "modprobe sata_sil" zu laden?

Jochen
_________________
Die grösste Lüge der EDV? "Mal eben..."
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

mali



Anmeldungsdatum: 22.03.2005
Beiträge: 13
Wohnort: Leverkusen / NRW

BeitragVerfasst am: 23. März 2005 23:52   Titel:

Hi,

danke schon mal für die Antwort. Habe leider nur den 2.6.8 Kernel.
Werde aber mal in der Konsole nachschauen und ggf. mir mal versuchen nen neuen Kernel zu kompilieren bzw. das Modul irgendwoher zu bekommen.

Meld mich dann wieder.

mali
 
Benutzer-Profile anzeigen Private Nachricht senden

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 24. März 2005 8:53   Titel:

Hi,

hier läuft eine SuSE 9.2 (32 Bit) in einer SuSE Grundkonfig mit sata_sil (und sata_promise).
Es muß für die Nutzung kein Kernel kompiliert werden ...
Code:

suse92:/ # uname -a
Linux suse92 2.6.8-24.11-default #1 Fri Jan 14 13:01:26 UTC 2005 i686 athlon i386 GNU/Linux
suse92:/ # lsmod | grep sata
sata_sil                8196  8
sata_promise            9604  0
libata                 41860  2 sata_sil,sata_promise
scsi_mod              111052  8 sg,st,sr_mod,sym53c8xx,scsi_transport_spi,sata_promise,libata,sd_mod
suse92:/ #

Ggf. solltest Du mal in den SuSE MLs nachschauen, ob dort etwas darüber steht ...
(http://lists.suse.com/)

Gruß
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

jochen
prolinux-forum-admin


Anmeldungsdatum: 14.01.2000
Beiträge: 699
Wohnort: Jülich

BeitragVerfasst am: 24. März 2005 12:35   Titel:

Hi,

das mit der "64bit-Version" hab ich glatt überlesen... Aber eigentlich sollte ein Treiber im Kerneltree es auch unter 64Bit tun... Für 2.4er-Kernel und frühe SuSE9.0 (SLES9?) Versionen scheint es Beta-64Bit-Treiber unter dieser Url zu geben: http://www.siliconimage.com/support/downloadresults.aspx?pid=28&bios=0&drivers=0&sataraid=0&
Ob die Dir weiterhelfen können, wage ich aber zu bezweifeln... Probier es lieber erst mal mit "sata_sil", wie auch Stormbringer gepostet hat! Ein "modprobe sata_sil" sollte alle weiteren notwendigen Module mitladen, ggf. wird noch ein "modprobe scsi_mod" benötigt.

Jochen
_________________
Die grösste Lüge der EDV? "Mal eben..."
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

mali



Anmeldungsdatum: 22.03.2005
Beiträge: 13
Wohnort: Leverkusen / NRW

BeitragVerfasst am: 24. März 2005 19:31   Titel:

Hallo,

so, habe mal nachgesehn und dabei ist rausgekommen, dass das modul sata_sil und sata_nv bei meiner Suse 9.2 64 Bit Version automatisch mitgeladen werden.

Habe mal probeweise Suse 9.1 oder 9.0 draufgemacht, und hier kann ich auf meine sata zu greifen bzw. linux darauf installieren.

Also jetzt weiss ich leider auch nit mehr weiter. Kann doch nit sein !!!!

@ storm, console outup: sata_sil bei dir = 8 bei mir = 0. Warum??? heißt das, dass es nicht geladen wurde???
@jochen, auf der Sil Image HP habe ich schon alles versucht, was für suse sein könnte. aber leider ohne erfolg oder ich war zu blöd dafür Sad

Braucht man für die 64er version nen sonder treiber??? eigentlich nit, müsste doch so gehen, oder???

gruß
mali
 
Benutzer-Profile anzeigen Private Nachricht senden

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 25. März 2005 6:07   Titel:

Was heißt denn überhaupt 'Läuft nicht unter RAID'?
Deine Platte sollte als ein sdXY (/dev/sdXY) device erkannt werden.
Evtl. einmal mittels yast - System - Partitionieren nachschauen.
Als einelne Platte sollte darauf zugegriffen werden können, nur auf einen unter MS WIndows (oder MS Dos, bzw. des Controller Bios) erstellten RAID Verbund wirst Du nicht zugreifen können - es ist halt ein Software RAID, für welches es keinen unterstützten Treiber gibt.

Gruß
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

mali



Anmeldungsdatum: 22.03.2005
Beiträge: 13
Wohnort: Leverkusen / NRW

BeitragVerfasst am: 27. März 2005 17:46   Titel:

Mit RAID meinte ich, dass ich meine Platte im Bios unter der Option Raid oder Sata; immer auf Sata hatte bzw. wg. Linux auf deaktiviert. Also , kein raidbetrieb auf meinem system. win xp bootet bei beiden ohne probleme. unter linux ist bei der opt SATA und Deaktiviert keine platte zu finden.

Aslo, unter Partionen im yast taucht diese sata nit auf. beim controller im yast wurde mein modul geladen --> nv_sata. unter lsmod auf der console wird es zusammen mit Sil_ata geladen

Question

kann auch nit manuell mounten.

mount -t ntfs /dev/sdXY /....... funtzt leider nicht.

gruß aus der Hoffnungslosigkeit
 
Benutzer-Profile anzeigen Private Nachricht senden

mali



Anmeldungsdatum: 22.03.2005
Beiträge: 13
Wohnort: Leverkusen / NRW

BeitragVerfasst am: 28. März 2005 22:55   Titel:

Hallo zusammen,

hatte heute die schnauze voll von dem Problemen und habe mir den 2.6.10er Kernel installiert. Meine Platte wird ohne Problem als hde erkannt. Die satamodule sind vom Namen her die gleichen. Naja, aber es hat geklappt.

es lebe linux mit seinen vor- und nachteilen Laughing

Aber trotzdem habe ich eine Frage an euch; habe linux 9.2 auf dvd. Ist es möglich die kernelversion auf der dvd durch den neu kompilierten Kernel zu ersetzten und den suse ordner auf einen dvdrohling bootfähig zu machen, damit ich bereits bei der installation auf die sataplatte zugreifen kann????

Vielen Dank für die Hilfe.

mali
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy