Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 17. Dez 2018 13:40

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 5 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 25. Mär 2005 10:25 
Hallo!
Ich hab mir eine externe 250GB Platte gekauft. Ist Ntfs formatiert.

Supermount ist am laufen, wenn die Platte eingesteckt wird, wird sie auch korrekt als z.B. /dev/sda1 erkannt und das Symbol auf dem Desktop erscheint. Jetzt gibts aber zwei Probleme:
1. Supermount trägt folgende Zeile in die fstab ein:
/dev/sda1 /mnt/removable auto umask=0,user,iocharset=iso8859-15,sync,kudzu,codepage=850,noauto,exec,users 0 0

als Dateisystem steht da "auto", das geht offensichtlich bei ntfs nicht. also von Hand ntfs eingetragen, jetzt lässt sich das ding mounten.

2. Problem: Als user hab ich keine leserechte für /mnt/removable. Obwohl ja die option "users" drin steht.

Wie kann man nun Supermount dazu bewegen, ntfs als Dateisystem reinzuschreiben und wie bekomme ich Leserechte als user? (Daß Schreiben auf ntfs nicht so einfach geht, weiß ich)

Das Ganze läuft unter Mandrake 10.1.

Mit dem Usb-Stick gehts übrigens einwandfrei. Da hab ich auch als user volle Rechte auf /mnt/removable.

Von Hand fstab editieren funzt übrigens nur bis zum nächsten ein-/ausstecken. Da wird die Zeile automatisch gelöscht und neu geschrieben.

Für Hilfe wäre ich sehr dankbar!

Gruß
Michael


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 25. Mär 2005 11:13 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 14. Jan 2000 15:37
Beiträge: 699
Wohnort: Jülich
Ich bin mir nicht sicher, ob Du das folgende auf Mandrake mit supermount anwenden kannst, weil ich die Infos von einem RedHat-System habe.

Schmeiss mal den EIntrag "kudzu" aus den fstab-Optionen (4. Spalte) raus. Diesen Eintrag nimmt zumindest RedHat als Erlaubnis, diese Zeile nach Belieben entfernen oder verändern zu dürfen, wenn kudzu erkennt, dass das Gerät an- oder abgesteckt wurde. Da supermount "nur" automatisch mountet, aber normalerweise nicht die /etc/fstab verändert, solltest Du dann nur noch einmal die Einstellungen nach Deinen Vorstellungen anpassen müssen.

Wenn supermount das FS mountet, wird als User wahrscheinlich root gelten, da ja das System selbst den Vorgang startet. Wenn der obige Tipp so funktioniert, wie ich mir das vorstelle, musst Du die Mount-Optionen nur um die folgenden Einträge ergänzen:
Zitat:
uid=value, gid=value and umask=value

Set the file permission on the filesystem. The umask value is
given in octal. By default, the files are owned by root and not
readable by somebody else.
(Auszug aus der mount-Manualpage)

Nun sollte Deine fstab-Zeile ungefähr so aussehen:
Code:
/dev/sda1 /mnt/removable ntfs umask=0,user,iocharset=iso8859-15,sync,codepage=850,noauto,exec,uid=X,gid=Y 0 0 
Für X als UID und Y für GID müsstest Du dann noch die numerischen Werte (einfach mal "id" als User eintippen) für deine normale Kennung eintippen.

Ich hoffe, das hilft weiter.

Jochen

_________________
Die grösste Lüge der EDV? "Mal eben..."


Nach oben
   
 Betreff des Beitrags: Klasse!
BeitragVerfasst: 25. Mär 2005 14:09 
Hallo nochmal!

Vielen Dank, superklasse! Der Tip mit dem kudzu war super, jetzt bleiben die Zeilen erhalten.

Hab jetzt folgende Einträge in der fstab:

/dev/sda1 /mnt/removable auto umask=0,user,iocharset=iso8859-15,sync,noauto,exec,users 0 0
/dev/sdb1 /mnt/removable2 auto umask=0,user,iocharset=iso8859-15,sync,noauto,exec,users 0 0

damit funktionieren beide Geräte, auch als user und gemischt hin- und her, und mit dem automatischen Desktopsymbol!

Vielen Dank nochmal!

Gruß
Michael


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 25. Mär 2005 17:06 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 14. Jan 2000 15:37
Beiträge: 699
Wohnort: Jülich
Schön, dass es funktioniert! :D

Als mögliche Verbesserung vielleicht noch folgendes:
  • Die Option "sync" bewirkt, dass jeder write-Syscall erst zurückkehrt, wenn die Daten auch wirklich auf der Platte sind. Bei Wechselmedien oder hotplugfähigen Geräten wird so die Gefahr von Datenverlust beim Abziehen des Gerätes ohne vorheriges Unmounten verringert. allerdings auf Kosten der Performance. Solltest Du also auch mal Geräte zum Speichern anschliessen, kannst Du daran noch drehen: Mit "sync" langsames Schreiben, aber etwas sicherer, oder ohne "sync" mit mehr Performance, aber dann bloss nicht das umount vergessen!
  • NTFS solltest Du normalerweise immer nur Read-only mounten. Vielleicht besser mal die Oprion "ro" (Read-only) hinzufügen? Kann aber auch sein, dass der NTFS-Treiber bei Mandrake von vorne herein so kompiliert ist, dass er gar keinen Schreibsupport bietet.
Viel Spass noch,
Jochen

_________________
Die grösste Lüge der EDV? "Mal eben..."


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Mär 2005 8:28 
Danke für den Tip nochmal, das Sync lasse ich dann besser stehen.

Also auch wenn ich das ding rw gemountet habe, schreiben kann ich trotzdem nicht drauf.
Kann aber die option "ro" nicht verwenden, da ich ja auch ab und zu einen Usb-Stick reinstecke und auf dem will ich schon schreiben. Sonst müsste ich jedesmal die fstab ändern.

Aber ich glaube, daß ich mich jetzt mal intensiv mit Captive beschäftige.

Gruß
Michael


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 5 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de