Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Sichere Neuinstallation von Suse 9.2 neben Windows

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
bine
Gast





BeitragVerfasst am: 30. März 2005 13:51   Titel: Sichere Neuinstallation von Suse 9.2 neben Windows

Hallo,

Ich hab zu diesem Thema eine Menge zu bereits vorhandenen Bootproblemen und möglichen Lösungen gefunden, mich interessiert aber mehr die Frage: wie vermeide ich das Problem, daß nach einer Suse Neuinstallation evtl. Windows nicht mehr bootet? Verstehe ich das richtig, bei vorhandenen Windows Partitionen kann es nach Installation von Suse aus zwei Gründen zu Bootproblemen kommen:
1. Wenn die Win Partition größer als 8 GB ist
2. Wenn man den Grub in den MBR schreiben läßt.
Ist das korrekt, oder gibt es noch andere mögliche Ursachen

Ich habe folgende Konfiguration (PC knapp 7 Jahre alt):
40 GB Platte, 1. Partition knapp 2 GB Windows 98
dann kommen einige Linux Partitionen (ein altes Corel Linux, und ein altes Suse 7.0), die löschen möchte, so daß ich damit etwa um die 7 GB freien Speicher habe, hier soll Suse 9.2 hin, liegt also noch innerhalb der 1024 Zylinder Grenze
Danach kommt Partition D mit Windows 2000, gefolgt von einer Reihe logischer Partitionen für daten etc.
Primäre Part. ist nur C mit Win 98
Bei den alten Linux systemen hatte ich es so gemacht, daß ich Lilo jeweils in die Linux Bootpart. geschrieben hatte, die Bootdateien in C kopiert und in Boot.ini eingetragen, so daß der NTloader erhalten blieb, klappte immer vorzüglich (leider schon ein par Jahre her, und ich weiß nicht mehr, wie ich das gemacht hab Crying or Very sad )

Da ich mein Win 2000 aus beruflichen Gründen täglich lebensnotwendig brauche, kann ich mir keine Experimente leisten und muß ganz sicher gehen, daß eine Neuinstallation von Suse 9.2 mir keine Bootprobleme beschert, Partitionstabellen zerfetzt oder Dateien beschädigt.

Deshalb meine Frage, gibt es noch weitere mögliche Ursachen, auf die ich achten muß, oder bin ich mit innerhalb der 1024 Zylinder Grenze auf der sicheren Seite, und natürlich Grub nicht in den MBR?
Und, was ist besser, die alten Linux Partitionen löschen und einfach als freien Speicher lassen bzw. die Partitionierung der Suse Installation zu überlassen, oder ist es besser, die vorab vorzuformatieren, also als Linux Part. vorzubereiten (swap, boot, root, home)?

Vielen Dank im Voraus
bine
 

chlor
Gast





BeitragVerfasst am: 30. März 2005 14:03   Titel:

hi,

eigentlich kannst du grub (der bootloader) auch in den mbr schreiben, ist ganz sicher viel komfortabler. suse sollte das auch erledigen. wenn du, und so ist es am unkompliziertesten, windows in der ersten partition deiner ersten festplatte installiert hast sehen die zeilen in deiner
/boot/grub/menu.lst

title Windows 95/98/NT/2000
root (hd0,0)
makeactive
chainloader +1

so aus, das sollte wie gesagt suse bereits für dich erledigt haben. falls aus irgendeinem grund nicht, sieht es eventuell so wie hier aus:

# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1

dann entfernst du die kommentarzeichen # am anfang der zeile. (hd0,0) steht für die erste festplatte und die dort angelegte erste partition.
hast du also windows dort installiert ist alles prima. ich rate dir jedenfalls grub in den mbr zu schreiben.

ich würde bei halbwegs aktueller 'durchschnitts hardware' nicht mit weiteren probs rechnen, aber du kannst ja auch hier nochmal schauen:
http://portal.suse.com/PM/page/search.pm?q=grub+windows&t=optionSdbKeywords&m=25&l=de&x=true
http://hardwaredb.suse.de/?LANG=de_DE

mit windows kenne ich mich zwar nicht mehr wirklich gut aus, aber ich meine, das du, falls doch was was schief geht, auch die windows cd booten kannst und mit 'reparieren' den alten bootsektor wieder herstellen kannst. das gleiche geht sicher auch mit suse, und dann editierst du, falls doch was ist, deine menu.lst wie oben beschrieben - also - keine panik, das roboten mit windows geht weiter wenn du willst.

viel spass und gutes gelingen
 

rudifaxe
Gast





BeitragVerfasst am: 30. März 2005 22:02   Titel:

Hallo biene,
ich betreibe seit vielen Jahren SuSE x.x und Win ME nebeneinander. Probleme mit dem Booten hatte ich bis dato noch nicht. Sollte aus irgendeinem Grund
Win nicht mehr starten, sprich der Bootvorgang klappt nicht mehr, ist es mit der Startdiskette ein Kinderspiel den Bootsektor zu reparieren. Allerdings ist Grub dann gelöscht. Das bedeutet, SuSE lässt sich dann nur noch mit der Bootcd SuSE starten und über Yast Grub neu installieren. aber wie gesagt, das dürfte wohl eher selten vorkommen.

Fax
Smile
 

bine
Gast





BeitragVerfasst am: 31. März 2005 5:28   Titel:

Vielen Dank für die Tips.
Also, ich habs installiert, und mein Windows ist noch da und bootet.
Aaaaaaber, nun hab ich Stunden verbracht mit Datensicherung, Installation und alles klappte wunderbar, Hardware perfekt erkannt, alles fein bis zum guten Schluß "Herzlichen Glückwunsch...etc. wenn Sie auf Beenden klicken können Sie sich anmelden". Und dann, statt Anmelden, alles, was passiert ist ein kleines Fensterchen in der Mitte eines schwarzen Bildschirms, das sagt:
Out of Range, dann folgen Auflösung, hor. und vert. Werte des Bildschirms, und Hz der Uhr...und das wars, nix tut sich dann mehr, da läßt sich auch nichts ändern, ist nur diese lakonische Anzeige.
Beim Reboot dasselbe. Reboot noch mit DVD, da ich nun den Grub ja in die Root Partition geschrieben hab und eigentlich als Nächstes nach dem Anmelden den Bootsektor in eine Datei kopieren wollte, für den NT Bootloader, aber dazu kam ich ja nicht.
Bei der Installation hat er doch Monitor und Grafikkarte erkannt, die ganze Zeit perfekte Darstellung, was kann das denn jetzt sein????
Und vor allem, wie läßt sich das beheben?

Hat wer ne Idee dazu?
Vielen Dank
bine
 

Jente
Gast





BeitragVerfasst am: 08. Apr 2005 1:43   Titel:

Wenn Linux hochgefahren ist (das ist es ja, wenn Du dieses unschöne Erlebnis hast) kannst Du Dich z.b. mit [Strg]+[Alt]+[F1] (es gehen auch die Funktionstasten [F2] bis [F6] auf einer Text-Konsole einloggen (am besten gleich als root). Dann starte durch den Befehl "sax" nochmals die Konfiguration des X-Servers. Wenn Du dann damit fertig bist kannst Du mit [Strg]+[Alt]+[F7] zu Deiner Fehlermeldung zurückkehren. Dort kille dann mit [Strg]+[Alt]+[Backspace] den nicht korrekt laufenden X-Server. Danach müsstest Du dann hoffentlich einen grafischen Login-Bildschirm bekommen und alles Weitere sollte auch funzen...
Jente
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy