Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Toshiba Portege 3490CT - extrem langsam?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
atomical



Anmeldungsdatum: 12.01.2003
Beiträge: 93

BeitragVerfasst am: 13. Apr 2005 21:43   Titel: Toshiba Portege 3490CT - extrem langsam?

Hallo!

Ich habe hier einen Toshiba Laptop Portege 3490CT - 128MB RAM, P3 700MHz.
Das Teil bootet mit dem Debian Kernel ohne erkennbare Fehlermeldungen durch aber während der Nutzung ist das Ding unerträglich langsam - der X-Server benötigt ca. 20 Sekunden zum Starten, Mozilla Firefox ca. 30 Sekunden und der Seitenaufbau / Scrollen kommt einer Diashow gleich. Ebenso verhlält es sich mit allen anderen Programmen (selbst hier beim Tippen kommen die Buchstaben zeitverzögert).
Die CPU Auslastung beim Programm starten / Webseiten rendern / Tippen liegt immer zwischen 45% und 100%.

Ich habe Debian Sarge bereits auf einem P2 266MHz installiert - da läuft es um einiges performanter ... nur woran liegt bei dem Laptop der Hund begraben?

Momentan verwende ich Debian Sarge - vorher hatte ich mit Gentoo (auf externer Maschine kompiliert) das gleiche Problem.

Hier ein paar Informationen zur Systemkonfiguration:

Code:
[root@pub] ~ (16G free)# hdparm /dev/hda                                                                                                    -=Mi 13.04.2005 22:10:58=-

/dev/hda:
 multcount    = 16 (on)
 IO_support   =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 12 (on)
 geometry     = 38760/16/63, sectors = 39070080, start = 0
[root@pub] ~ (16G free)# hdparm -i /dev/hda                                                                                                 -=Mi 13.04.2005 22:11:08=-

/dev/hda:

 Model=TOSHIBA MK2016GAP, FwRev=U0.32 A, SerialNo=41I38748T
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=46
 BuffType=unknown, BuffSize=0kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=39070080
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  sdma0 sdma1 sdma2 mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 *udma2 udma3 udma4
 AdvancedPM=yes: unknown setting WriteCache=enabled
 Drive conforms to: device does not report version:

 * signifies the current active mode
(udma3 und udma4 macht der IDE-Controller offenbar nicht)

Code:
[root@pub] ~ (16G free)# cat /proc/cpuinfo                                                                                                  -=Mi 13.04.2005 22:11:48=-
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 6
cpu MHz         : 700.035
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 1395.91


Code:
[root@pub] ~ (16G free)# lspci                                                                                                              -=Mi 13.04.2005 22:13:09=-
0000:00:00.0 Host bridge: Intel Corp. 82440MX Host Bridge (rev 01)
0000:00:00.1 Multimedia audio controller: Intel Corp. 82440MX AC'97 Audio Controller
0000:00:02.0 Communication controller: Lucent Microelectronics 56k WinModem (rev 01)
0000:00:04.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 13)
0000:00:06.0 PCI bridge: Toshiba America Info Systems: Unknown device 061b (rev 03)
0000:00:07.0 Bridge: Intel Corp. 82440MX ISA Bridge (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82440MX EIDE Controller
0000:00:07.2 USB Controller: Intel Corp. 82440MX USB Universal Host Controller
0000:00:07.3 Bridge: Intel Corp. 82440MX Power Management Controller
0000:00:09.0 IRDA controller: Toshiba America Info Systems FIR Port Type-DO
0000:00:0b.0 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to Cardbus Bridge with ZV Support (rev 20)
0000:00:0b.1 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to Cardbus Bridge with ZV Support (rev 20)
0000:01:04.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)


Die Ausgabe von dmesg direkt nach dem Booten:
Code:

Linux version 2.4.27-2-686 (horms@charles.lab.ultramonkey.org) (gcc version 3.3.5 (Debian 1:3.3.5-6)) #1 Thu Jan 20 11:10:41 JST 2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000ec000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000007fe0000 (usable)
 BIOS-e820: 0000000007fe0000 - 0000000007ff0000 (ACPI data)
 BIOS-e820: 0000000007ff0000 - 0000000008000000 (reserved)
 BIOS-e820: 00000000100a0000 - 00000000100b6e00 (reserved)
 BIOS-e820: 00000000100b6e00 - 00000000100b7000 (ACPI NVS)
 BIOS-e820: 00000000100b7000 - 0000000010100000 (reserved)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
127MB LOWMEM available.
On node 0 totalpages: 32736
zone(0): 4096 pages.
zone(1): 28640 pages.
zone(2): 0 pages.
ACPI: RSDP (v000 TOSHIB                                    ) @ 0x000f0150
ACPI: RSDT (v001 TOSHIB 750      0x00970814 TASM 0x04010000) @ 0x07fe0000
ACPI: FADT (v001 TOSHIB 750      0x00970814 TASM 0x04010000) @ 0x07fe0054
ACPI: DSDT (v001 TOSHIB 3480     0x20001201 MSFT 0x0100000a) @ 0x00000000
Kernel command line: root=/dev/hda1 ro
Local APIC disabled by BIOS -- reenabling.
Could not enable APIC!
Initializing CPU#0
Detected 700.035 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1395.91 BogoMIPS
Memory: 122760k/130944k available (1197k kernel code, 7796k reserved, 451k data, 116k init, 0k highmem)
Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode cache hash table entries: 8192 (order: 4, 65536 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 0383f9ff 00000000 00000000 00000000
CPU:             Common caps: 0383f9ff 00000000 00000000 00000000
CPU: Intel Pentium III (Coppermine) stepping 06
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20040326
ACPI: Interpreter disabled.
PCI: PCI BIOS revision 2.10 entry at 0xfed9b, last bus=21
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: ACPI tables contain no PCI IRQ routing entries
PCI: Probing PCI hardware (bus 00)
Transparent bridge - PCI device 1179:061b (Toshiba America Info Systems)
PCI: Using IRQ router PIIX/ICH [8086/7198] at 00:07.0
PCI: Found IRQ 11 for device 00:0b.0
PCI: Found IRQ 11 for device 00:0b.1
PCI: Sharing IRQ 11 with 00:00.1
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
COMX: driver version 0.85 (C) 1995-1999 ITConsult-Pro Co. <info@itc.hu>
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 8192 bind 16384)
Linux IP multicast router 0.06 plus PIM-SM
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 4180 blocks [1 disk] into ram disk...
Freeing initrd memory: 4180k freed
VFS: Mounted root (cramfs filesystem).
Freeing unused kernel memory: 116k freed
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide: late registration of driver.
PIIX4: IDE controller at PCI slot 00:07.1
PIIX4: chipset revision 0
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xbff0-0xbff7, BIOS settings: hda:DMA, hdb:pio
hda: TOSHIBA MK2016GAP, ATA DISK drive
blk: queue c8829cc0, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: attached ide-disk driver.
hda: 39070080 sectors (20004 MB), CHS=38760/16/63, UDMA(33)
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Adding Swap: 267112k swap-space (priority -1)
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
Real Time Clock Driver v1.10f
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@saw.sw.com.sg> and others
eth0: OEM i82557/i82558 10/100 Ethernet, 00:00:39:B4:00:35, IRQ 11.
  Board assembly 000000-000, Physical connectors present: RJ45
  Primary interface chip i82555 PHY #1.
  General self-test: passed.
  Serial sub-system self-test: passed.
  Internal registers self-test: passed.
  ROM checksum self-test: passed (0x04f4518b).
device-mapper: 4.1.1-ioctl (2004-04-07) initialised: dm-devel@redhat.com
Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Intel ISA PCIC probe: not found.
PCI: Found IRQ 11 for device 00:0b.0
PCI: Found IRQ 11 for device 00:0b.1
PCI: Sharing IRQ 11 with 00:00.1
Yenta ISA IRQ mask 0x0000, PCI irq 11
Socket status: 30000007
Yenta ISA IRQ mask 0x0000, PCI irq 11
Socket status: 30000011
cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
hdc: QSI DVD-ROM SDR-061A, ATAPI CD/DVD-ROM drive
ide1 at 0x320-0x327,0x32e on irq 11
ide_cs: hdc: Vcc = 5.0, Vpp = 0.0


Irgendwelche Ideen / Hinweise / Leidensgenossen? :confused:
 
Benutzer-Profile anzeigen Private Nachricht senden

atomical



Anmeldungsdatum: 12.01.2003
Beiträge: 93

BeitragVerfasst am: 14. Apr 2005 21:01   Titel:

Update ... noch ein paar Systeminfos
Code:
[root@pub] /home/serial (16G free)# hdparm -tT /dev/hda

/dev/hda:
 Timing cached reads:    80 MB in  2.03 seconds =  39.41 MB/sec
 Timing buffered disk reads:   26 MB in  3.03 seconds =   8.58 MB/sec


Code:
[root@pub] /home/serial (16G free)# cat /proc/interrupts
           CPU0
  0:     192647          XT-PIC  timer
  1:       1443          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  8:          4          XT-PIC  rtc
 11:     116911          XT-PIC  Toshiba America Info Systems ToPIC95, Toshiba America Info Systems ToPIC95 (#2), ide1, eth0
 12:      47632          XT-PIC  PS/2 Mouse
 14:      16519          XT-PIC  ide0
NMI:          0
LOC:          0
ERR:          0
MIS:          0


Code:
[root@pub] /home/serial (16G free)# free             -=Do 14.04.2005 21:59:45=-
             total       used       free     shared    buffers     cached
Mem:        127056     102340      24716          0       1900      30332
-/+ buffers/cache:      70108      56948
Swap:       267112        904     266208
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 15. Apr 2005 11:18   Titel:

Code:
0000:00:06.0 PCI bridge: Toshiba America Info Systems: Unknown device 061b (rev 03)


unbekannt == tut nichts
Irgendetwas wird wohl dessen Arbeit machen müssen, woduch es sich staut?

HTH, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

atomical



Anmeldungsdatum: 12.01.2003
Beiträge: 93

BeitragVerfasst am: 15. Apr 2005 13:50   Titel:

klopskuchen hat folgendes geschrieben::
Code:
0000:00:06.0 PCI bridge: Toshiba America Info Systems: Unknown device 061b (rev 03)


unbekannt == tut nichts
Irgendetwas wird wohl dessen Arbeit machen müssen, woduch es sich staut?

HTH, Klopskuchen


Meinst du?

Ich hab dazu was auf der Kernelmailingliste gefunden - offenbar ist das die PCI-Bridge für eine Dockingstation - und da hab ich keine.
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 15. Apr 2005 14:43   Titel:

Ich weiss nun nicht wie es in deinem Schleppi genau aussieht. Die besagte PCI-Bridge entspricht bei meinem x86
dem Bus für PCI-Steckkarten, analog zur ISA-Bridge für ISA-Erweiterungskarten.
Ob nun Erweiterungen angeschlossen sind oder nicht, wessen Bits kreuzen welchen Bus?
Im Detail kenn ich mich zu wenig aus aber ich wage einfach mal zu behaupten, das das nicht arbeitende Teil
bremsen kann da es an einem Knoten sitzt (mitsamt Daten-, Adress- als auch Steuerbus).

Disclaimer: "Bitte nicht zu Hause nachmachen! Alles Halbwissen!"

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

atomical



Anmeldungsdatum: 12.01.2003
Beiträge: 93

BeitragVerfasst am: 15. Apr 2005 15:54   Titel:

Hm ... gut.

Was könnte helfen? Ein neuer Kernel - vielleicht ein 2.6er?
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 15. Apr 2005 16:09   Titel:

Oder mal in die Doku vom "alten" gucken ob noch was rein könnte/ müsste.
Ich würd aber einen 2.6er vorziehen. (Mit 2.6.11 ist ja nun hoffentlich Ruhe mit
der chaotischen Experimentiererei.)

MfG, Klopskuchen

edit:
Du sagtest die CPU-Last liegt zwischen 45 und 100%.
Der Scheduler unter 2.6.x arbeitet etwas performanter als der
unter 2.4.x. Das Rendering ist ebenfalls schneller. Ich nutze 2.6.x erst
seit zwei Wochen dauerhaft (gab vorher Probleme mit Perepherie)->
X läuft merklich fixer.
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy