Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Dez 2018 12:31

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Tecra 8100 und Cardbus USB 2.0 Karte
BeitragVerfasst: 20. Apr 2005 22:01 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Hallo !

Ich habe einen Laptop Markte Toshiba Tecra 8100. Ich wollte den Laptop mit einer USB 2.0-Karte ausrüsten, habe also eine gekauft. Die Karte ist von der Firma trust, und hat einen NEC-Chipsatz. Es sollte also eigentlich kein Problem sein, der NEC-Chipsatz wird unterstützt. Hier die entsprechende Ausgabe von lspci:
Code:
0000:02:00.0 USB Controller: NEC Corporation USB (rev 43)
0000:02:00.1 USB Controller: NEC Corporation USB (rev 43)
0000:02:00.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
Wenn die Karte einstecke, bzw. das ohci-hcd Modul per Hand lade, bekomme ich folgende Ausgabe:
Code:
root@tecra:~# PCI: Error while updating region 0000:06:00.2/0 (11002000 != 11000000)
PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
PCI: Enabling device 0000:06:00.1 (0000 -> 0002)
PCI: Enabling device 0000:06:00.2 (0000 -> 0002)
uhci_hcd: probe of 0000:06:00.2 failed with error -16
hub 3-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
hub 3-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
Der Treiber schafft es also nicht, die Karte zu bedienen. Eine Ausgabe von lsusb bestätigt dies, es wird nur der interne USB-Anschluß angezeigt. Vor allem die Meldung mit "updating region" finde ich interessant, scheint irgendwie nen PCI-Problem zu sein. Weiß wer, was das genau bedeutet ?

Ich habe schon einiges versucht, hat nichts geholfen. Eine Cardbus-Ethernet-Karte (tulip) funktioniert einwandfrei.

Auf http://www.linux-usb.org/usb2.html habe ich einige Hinweise gefunden:
Zitat:
Some folk have problems with the CardBus versions, because Linux hasn't always managed to get the IRQs assigned correctly on their particular laptop make/model. (IRQs are a general problem, BIOS and ACPI problems abound.) Once such BIOS/PCI level problems get resolved, the ehci-hcd driver works with those CardBus configurations too.
Kann es damit zusammenhängen ? Allerdings will ja schon der ohci-Treiber nicht, mit ehci hab ich ja noch garnicht angefangen (geht nebenbei auch nicht). Ich habe mal nen bißchen mit kernel-Parametern rumprobiert (pci=bios, nobios, biosirq usw.), hat nichts gebracht. Wenn es daran liegt, wie kann ich diese IRQ-Probleme beseitigen ?

Weiter heißt es:
Zitat:
It may be very important to use an external power supply for the CardBus adapter.
Wie ist das zu verstehen ? Soll ich die Karte noch extra mit Strom versorgen ???? Dafür hat sie schlicht keinen Anschluß.

Ein paar Daten zum System:

- Knoppix HD-Installation
- Kernel 2.6.11-ac7 mit
vesafb-tng patch
gensplash patch
(selber kompiliert)


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 20. Apr 2005 22:36 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
P.S.:

Hier noch die komplette Ausgabe von lspci -v: Klick


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Apr 2005 15:02 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Problem gelöst: Zurück zu Saturn damit, habe dafür ne D-Link DUB-C2 mitgenommen, funktioniert !


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de