Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Routing problem

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Frage_von_Elwood
Gast





BeitragVerfasst am: 25. Apr 2005 17:16   Titel: Routing problem

Hallo Leute,

ich habe hier folgende Konstellation:
[cisco Router] - [hub] - [FW Suse m. 2 netzwerkkarten] - [hub] und auf dem Hub noch 3 Rechner.
Alle Rechner auf dem Hub sollen durch die FW gehen. Alle Rechner haben öffentliche IPs. Die FW steht mit beiden Netzwerkkarten im selben Netz.

Ich komme von aussen per ssh auf die FW drauf. Die Rechner auf dem hinteren Hub sehen sich gegenseitig. Von der FW sehe ich keine Rechner über eth0. Irgendwas am Routing ist falsch. Aber ich komme nicht drauf was.
eth1 steht in Richtung cisco und eth0 in Richtung hub mit den drei Rechnern. ich habe den Eindruck als wenn beide Karten nur in die Richtung cisco zeigen. Ich habe schon eine Route eingetragen die besagt dass die IP des einen rechners, der am hinteren hub hängt über eth0 zu erreichen ist, aber das hilft nicht. Benötigt eth0 einen Standard gateway? Liegt es daran? Es ist ein wenig gefährlich damit zu experimentieren, da ich nur über ssh (rechner steht in berlin) rankomme. Jemand eine idee?

Danke.
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 25. Apr 2005 18:02   Titel:

Code:
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
loopback        localhost       255.0.0.0       UG    0      0        0 lo
default         .               0.0.0.0         UG    0      0        0 eth0
# route add 192.168.1.0 netmask 255.255.255.0 eth0
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
loopback        localhost       255.0.0.0       UG    0      0        0 lo
default         .               0.0.0.0         UG    0      0        0 eth0


Also nach meiner Logik müsstest du einfach nur
Code:
route add xxx.xxx.xxx.0 eth0

ausführen... möglicherweise noch mit "netmask 255.255.255.0"

Auf jeden Fall brauchst du für die Rechner am HUB kein Gateway - du hast ja eine direkte Verbindung. Vielleicht liegt's aber auch den iptables-Regeln. Das wäre natürlich unschön, weil es sicher keine hübsche Arbeit ist per Remote-Login eine Firewall zu konfigurieren...
 
Benutzer-Profile anzeigen Private Nachricht senden

Frage_von_Elwood
Gast





BeitragVerfasst am: 25. Apr 2005 19:03   Titel: Routing

Hallo,

das hatte ich schon mit
Code:
route add -host xxx.xxx.xxx.xxx -dev eth0
versucht. Laut manpage v. route benötigt man keine Subnetmask dabei.

Aber welches Interface von der FW (eth0 oder eth1) benötigt einen default gw? Beide? Wenn ich bei beiden als default gw die cisco setze, habe ich die befürchtung, dass er alle Pakete an die eth1 statt an die eth0 sendet.

Firwall ist unten, die funktioniert eigentlich. Das Hauptproblem ist das Routing zwischen beiden Karten im gleichen Subnetz...
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 25. Apr 2005 19:14   Titel:

Achso... liegt eth1 und eth0 im gleichen Subnetz? Ja, oder? Ich glaube, dann brauchst du eine Bridge.

Hier endet dann aber auch mein Latein.
 
Benutzer-Profile anzeigen Private Nachricht senden

Frage_von_Elwood
Gast





BeitragVerfasst am: 26. Apr 2005 11:25   Titel: bridge

Sehr aufwendig dass mit der bridge. Ich habe es jetzt mit DNAT und SNAT versucht und in 30 min war der Spuck vorüber. Ist sauberer so und der Mensch hat wieder 3 IPs zu verfügung. Smile
Danke
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy