Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Dez 2018 12:11

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 8 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Parallelport CD
BeitragVerfasst: 26. Apr 2005 20:45 
Offline

Registriert: 09. Apr 2005 14:32
Beiträge: 12
hallo,
ich hatte hier schon einmal Hilfe zu diesem Thema gesucht und bin auch weiter gekommen.
Ich glaube jetzt fehlt nur noch eine Kleinigkeit um mein Problem zu lösen. Also: Auf meinem alten Toshiba Satellite Notebook (ohne CDROM) läuft Deli Linux (basierend auf Slackware)
Mit der entsprechenden Bootdiskette kann ich ein Parallelport CD ansprechen. Ich starte von Diskette, Lilo erscheint, gebe am Prompt ein: Ramdisk Root=/dev/hda1. Die Treibermodule werden an den Kernel übergeben und ich kann das Laufwerk benutzen. Dmesg verrät mir, das die Module Paride, friq und pg geladen werden. Wenn ich ohne diese Diskette starte, wird Linux ohne diese Module ausgeführt. (Ist wahrscheinlich logisch?!) Die Befehle modprobe paride, modprobe friq und modprobe pg werden ohne meckern angenommen, aber mount /mnt/cdrom liefert mir ein: you must specify the filesystem type. Auch wenn ich mit iso 9660 den Befehl erweitere kommt nix. Ich weiß einfach nicht wie ich die auf der Diskette vorhandenen, funktionierenden Module so an den Kernel übergeben kann das ich nicht jedesmal wenn ich das Laufwerk benutzen möchte vorher mit dieser Bootdiskette starten muß. Sorry, ist vieleicht ne dumme Frage aber ich bin Newbie und seh vieleicht den Wald vor lauter Bäumen nicht mehr. Weiß jemand weiter? Danke!


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Apr 2005 20:56 
Offline
prolinux-forum-admin

Registriert: 26. Jun 2004 21:18
Beiträge: 1444
> Auch wenn ich mit iso 9660 den Befehl erweitere kommt nix.
Auch keine Fehlermeldung?
Wie ist der Wortlaut des Befehls den du absetzt?

_________________
When all else fails, read the instructions .


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Apr 2005 21:23 
Offline

Registriert: 09. Apr 2005 14:32
Beiträge: 12
mount -t iso 9660 /dev/pcd0 /mnt/cdrom
the kernel does not recognize /dev/pcd0 as a block device (maybe 'insmod driver?)


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Apr 2005 22:14 
Offline
prolinux-forum-admin

Registriert: 26. Jun 2004 21:18
Beiträge: 1444
Also ein "ls -l /dev/pcd*" zeigt bei mir:
brw-rw---- 1 root cdrom 46, 0 1998-04-09 00:14 /dev/pcd0
brw-rw---- 1 root cdrom 46, 1 1998-04-09 00:14 /dev/pcd1
brw-rw---- 1 root cdrom 46, 2 1998-04-09 00:14 /dev/pcd2
brw-rw---- 1 root cdrom 46, 3 1998-04-09 00:14 /dev/pcd3
...vier blockorientierte Gerätedateien.

Wenn ich das richtig verstanden habe, bootet ein Kernel der auf der Diskette liegt und bindet das Dateisystem
auf der Platte als root-Verzeichnis ein? Dann vergleiche mal die configs der beiden Kernel (floppy/ HD) ob bei
dem Kernel auf Platte etwas was der Floppykernel drin hat fehlt.

Eine andere Möglichkeit wäre das verflixte udev. Falls du das verwendest befinden sich die Gerätedateien unter
irgendwelchen von udev dynamisch angelegten Links. Wie die heissen sollte aus /var/log/syslog ( ->dmesg) und/
oder /var/log/messages herauszupfrimeln sein.
Guck auch mal in /proc/devices.

ps.
> mount -t iso 9660 /dev/pcd0 /mnt/cdrom
iso9660 auseinander geschrieben gibt eigentlich eine Fehlermeldung?

_________________
When all else fails, read the instructions .


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Apr 2005 22:36 
Offline

Registriert: 09. Apr 2005 14:32
Beiträge: 12
sorry iso 9660 habe ich nur hier versehentlich auseinandergeschrieben


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Apr 2005 22:41 
Offline

Registriert: 09. Apr 2005 14:32
Beiträge: 12
ja ok, und auseinandergeschrieben wird wohl auseinander geschrieben :oops:


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Apr 2005 22:54 
Offline

Registriert: 09. Apr 2005 14:32
Beiträge: 12
ls -l /dev/pcd* zeigt auch bei mir vier blockorientierte Gerätedateien an. Und du hast richtig verstanden. Ich habe noch nicht überprüft ob die configs der der beiden Kernel unterschiedlich sind. (Sehr wahrscheinlich) Aber wie kriege ich die fehlenden Module übertragen? udev? Kenne ich gar nicht.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Apr 2005 23:13 
Offline

Registriert: 09. Apr 2005 14:32
Beiträge: 12
Oh verflixt, is schon spät! Ich muß ins Bett. Ich bedanke mich für die Aufmerksamkeit und freue mich für jeden weiteren Hinweiß! :wink:


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 8 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de