Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
USB Port-Wechsel bei reboot

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Dylan



Anmeldungsdatum: 03.05.2005
Beiträge: 2
Wohnort: Basel

BeitragVerfasst am: 03. Mai 2005 13:05   Titel: USB Port-Wechsel bei reboot

Huhu erstmal Smile bin neu hier Wink

Tja...ich arbeite gezwungenermassen auf RedHat 8.0. Ist leider so vom Arbeitgeber vorgegeben da gewisse Tools die dort Entwickelt wurden nur auf RedHat 8.0 laufen *rolleyes*...also ne andere Distribution zu nehmen geht nicht...

Nun das Problem ist folgendes:

Ich habe einen DELL GX280 mit RedHat 8.0 als Workstation installiert. Ich habe 6 USB Anschlüsse, 4 USB 2.0, 2 USB

Nun habe ich vier USB Geräte die Angeschlossen werden müssen.

- USB Keyboard
- USB Mouse
- 2x USB< Serial Wandler für Serial Modems

Nach der Installation wie gewohnt Mouse und Keyboard Konfiguriert, Modems ebenso...mache ich das erst Mal nen reboot...geht keins der 4 Geräte mehr...

Nach einiger Zeit herausprobieren habe ich dann festgestellt, dass nach jedem reboot die USB Ports vertauscht sind. D.h. das Modem das an USB0 war...hat nun plötzlich einen Port der nicht erkannt wird....jedoch bei nächstem reboot ist das gleiche Modem wieder an USB1...usw

mit:

# tail -f /var/log/messages

kann man ja relativ gut nachschauen wie wo was dran steckt...nu wollte ich fragen gibts ne Lösung für das Problem...also feste Zuordnung der Geräte zu einem Port, damit die Config nach einem reboot noch übereinstimmt...weil bis anhin musste ich halt jedes mal Austecken und wieder Einstecken und mit obigem Befehl schauen an welchem Port nun das Gerät eingesteckt wurde. Wäre super wenn ihr ne Lösung findet!!

Danke im Voraus
Dylan
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 04. Mai 2005 22:04   Titel:

Mit udev, welches bei euch sicher ausscheidet, ist es möglich Devices anhand ihrer Vendor-IDs wiederzuerkennen
und entsprechende Symlinks anzulegen. Evtl. geht das auch mit devfs wenn einkompilliert?

MfG, Klopskuchen

ps. Hab zwar keine Ahnung aber dafür jede Menge davon. Wink Musst mal in die devfs-Doku gucken, HTH.
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Dylan



Anmeldungsdatum: 03.05.2005
Beiträge: 2
Wohnort: Basel

BeitragVerfasst am: 10. Mai 2005 8:46   Titel:

Hmh...hab mich mal über das devfs erkundigt..und versucht was zu basteln...

Allerdings hab ich etwas gelesen, davon, dass devfs zuerst im Kernel eingebaut werden muss..resp aktiviert ist das richtig?

Weiter stellt sich dann die Frage wie ich z.B. ttyUSB0 dem Modem1 zuweisen...und ttyUSB1 dem Modem2 ?...

MfG
Dylan
 
Benutzer-Profile anzeigen Private Nachricht senden

T-fix



Anmeldungsdatum: 17.09.2005
Beiträge: 3

BeitragVerfasst am: 30. Nov 2005 13:48   Titel: USB-Drucker unter Suse 10.0

Hallo,

ich habe diesen alten Thread mal nach oben geholt, weil er möglicherweise ein Problem anspricht, mit dem ich mich auch seit einiger Zeit rumschlage:

Ich habe mir Suse 10.0 neu installiert. Darunter läuft u.a. ein USB-Drucker Canon Pixma IP3000 mit einem Turboprint-Treiber. Es hat mich tagelang beschäftigt, warum der Drucker mal funktioniert und mal nicht (Druckaufträge bleiben in der Druckschlange hängen). Dann habe ich gesehen, dass im Turboprint-Tool xtpsetup manchmal nach einem Reboot die Fehlermeldung erscheint "kann USB device nicht finden/einbinden...(sinngemäß)".

Als ich beim Suchen hier im Forum auf diesen Thread hier stieß, kam mir die Idee, dass es auch bei meinem Problem mit dem Drucker eventuell ein "Vertauschen" der Ports - und damit jedes zweite Mal nach Reboot kein Drucken - geben könnte.

Wie kann ich testen, ob es daran liegt? Und vor allem: Wie kann ich es abstellen? Ich habe leider keinen Schimmer von udev oder devfs...

T-fix
 
Benutzer-Profile anzeigen Private Nachricht senden

brum
Gast





BeitragVerfasst am: 01. Dez 2005 17:33   Titel: tp

Hallo,

ist zwar 'n bissl spät für 'ne Antwort, aber ich hatte folgendes Problem:

Mit Turboprint den Drucker eingebunden (Etwa?)

usb://Gerät/Druckername

Nach einer Woche ging es nicht mehr zu drucken.
Habe Drucker umgehängt (Auswahl)

/dev/usb/lp0

und seit dem Druckt das Teil. Lt. Hersteller ist das usb://... nur ein Alias, den man nur wirklich braucht, hat man mehrern Druckern angeschlossen.

Warum das so ist ?? Vielleicht hat das was mit dem ufs zu tun? Druckerdevice wird ja erst erstellt, wenn Drucker Strom bekommt.

Darum habe ich auch bei der Tintenstansabfrage - das braucht volle Rechte aufs Device und chmod fällt da also aus - das Tool mit sudo im Icon versehen und in der /etc/sudo diese Rechte dort ohne Passwort vergeben.

bye brum
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy