Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Video-Wiedergabe mit Ati Rage Mobility

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 24. Jul 2005 9:12   Titel: Video-Wiedergabe mit Ati Rage Mobility

Hallo !

Ich habe mir vor kurzem einen gebrauchten Laptop zugelegt, einen ACER Travelmate 529TXV (P3-850, 256MB, ATI Rage Mobility). Ich habe Kanotix 2005-3 aufgespielt, soweit läuft alles gut. Allerdings ruckelt die Videos ziemlich. Habe AVI-Dateien mit xine abgespielt, sowohl im Fenster als auch im Vollbildmodus ruckeln Videos.

Also kurz mal mit top nachgeguckt: Klick. Wie man sieht, benötigt schon der xserver ca. 33% der CPU-Zeit, xine den Rest. Wie kann das sein ? Der Laptop meiner Freundin hat 500 MHz und spielt Videos problemlos ab. Es ist sogar noch Idle-Zeit übrig. Warum bekommt ein 850 MHz-Gerät das nicht hin. Liegt es am Grafikchip bzw. Treiber ?

Ein paar Angaben zum System:

- Kanotix 2005-03, alle Updates eingespielt, erfolgreich auf xorg umgestellt
- Kernel selber kompiliert: 2.6.12.3 mit Gensplash Patch und vesafb-tng. Hier die Konfiguration: Klick
- xorg.conf
- lspci
- cpuinfo
- free
- hdparm /dev/hda
- hdparm /dev/hdc
- lsmod
- glxinfo
- xwininfo
- Xorg.0.log
- xvinfo.txt


Hat jemand ähnliche Erfahrungen gemacht, oder eine Idee was man noch machen kann ?
 
Benutzer-Profile anzeigen Private Nachricht senden

Alex.MH
Gast





BeitragVerfasst am: 31. Jul 2005 14:43   Titel:

Hi,

du verwendest den original Xorg ATI-Treiber, der aber die Features deiner Grafikkarte vermutlich nicht nutzen kann.

Mit dem Treiber von ATI (https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27) sollte es gehen, wenn er deinen Chip unterstuetzt. Allerdings ist der Treiber von ATI unter aller Sau und stuerzt, je nach Kernel Version, mehr oder weniger haeufig ab.

Gruss,
Alex
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 02. Aug 2005 16:16   Titel:

Hi !

Danke für die Antwort. Der ATI-Treiber unterstützt leider nur FireGL und Radeon-Karten, die Rage Mobility also nicht (hat einen mach64-Chip, schon etwas älter ;).

Inzwischen habe ich beobachtet, daß nicht alle Videos Probleme bereiten. Aber warum das eine Probleme macht das andere nicht habe ich noch nicht herausgefunden.

Auch DVD-Wiedergabe ruckelt so stark, daß man nicht vernünftig gucken kann. Das komische ist, daß die CPU noch nicht mal ausgelastet ist.
 
Benutzer-Profile anzeigen Private Nachricht senden

Alex.MH
Gast





BeitragVerfasst am: 02. Aug 2005 19:17   Titel:

Hi,

ich arbeite hier selber an einem P3-1Ghz Laptop (nicht viel schneller als deiner), allerdings mit einer Nvidia GeForce 2 Go Grafikkarte. Wenn ich Videos abspiele, dann benoetigt das so ungefaehr 30% CPU Last - vermutlich greift hier aber die Hardwarebeschleunigung meiner Grafikkarte.

Schau doch mal auf deine CPU Last. Wenn sie auf 100% ist, dann liegts vermutlich wirklich daran, dass fuer deine GK kein beschleunigter Treiber zur Verfuegung steht.

Gruss,
Alex
 

Alex.MH
Gast





BeitragVerfasst am: 02. Aug 2005 19:21   Titel:

Oops,

man sollte halt Beitraege vollstaendig lesen, bevor man postet Wink

Keine CPU-Last bei Dir? Vermutlich wartet dann der Kernel wirklich auf etwas - z.B. das die Grafikkarte den Screen fertig gemalt hat, bevor der Video-Puffer wieder umgeschaltet wrid.

Auf jedenfall merkwuerdig.

Gruss,
Alex
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 02. Aug 2005 20:26   Titel:

Komisch ist es auf jeden Fall.

Also Hardwarebeschleunigung bin ich mir nicht sicher. Der Laptop ist wie gesagt gebraucht. Bin mir nicht sicher, ob der alte Chip da viel beschleunigt. Allerdings habe ich schon die DRI-Treiber installiert. So wie ich es verstanden habe sind die aber eher für 3D-Anwendungen wichtig (weiß das wer genauer ?). DRI funktioniert laut Ausgabe von glxinfo.

Auch ohne Beschleunigung müßten 850 MHz ausreichen ein Video wiederzugeben.

Ich habe da noch zwei Theorien:

- nen Bug im Treiber. In dem Fall hilft hoffentlich irgendwann mal ein Update von x.org
- der X-Server muß irgendwie das Format umwandeln, z. B. von 16 auf 24 Bit umrechnen. Nen ähnliches Problem hatte ich schon mal bei Return to Castle Wolfenstein: Wenn der Desktop auf 24 bzw. 32 Bit läuft, das Spiel aber auf 16, so kostet die Umrechnung ganz schön CPU-Zeit.

Habe in Xine die "Post-Processing Quality" runtergedreht, jetzt geht's schon besser (für .avi-Dateien).Für DVDs habe ich mal ogle ausprobiert, das funktioniert wesentlich besser. Zumindest kann man die DVD gucken, auch wenn die Framerate nicht so toll ist. (ca. 15-20 FPS). Aber die ständigen Aussetzer sind weg.

Was mich wundert ist, daß sonst niemand das Problem zu haben scheint. Zumindest war google nicht sehr ergiebig.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy