Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Cron-Job läuft nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Hofer
Gast





BeitragVerfasst am: 19. Aug 2005 0:32   Titel: Cron-Job läuft nicht

Hi,

als Newbie hab ich ein Prob und komme nicht weiter:

Folgender Script läuft nicht als Cron job

Script test.sh

#!/bin/sh
/usr/local/sbin/sntop2 -w -e /usr/local/httpd/htdocs/online1.hmtl -f /etc/sntoprc -o >/dev/null

Mache ich da was grundsätzlich falsch??
Gruß
Höfi
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 19. Aug 2005 6:37   Titel:

hi

funktioniert das script wenn du es manuel aufrufst?
und wie schaut dein crontab eintrag aus?

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Hofer
Gast





BeitragVerfasst am: 19. Aug 2005 20:08   Titel:

Folgende Fehlermedlung erhalte ich über Webmin:

Error opening terminal:
>unknown.

Beim googeln habe diverse Hinweise gelesen, dass man Umgebungsvariablen setzen kann.
Da ich mich hier nicht auskenne, wäre ich auf Eure Mithilfe angewiesen.

Bin für jede Unterstützung dankbar.

Gruß
Hofer
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 19. Aug 2005 20:17   Titel:

Moin Hofer,

Hans Solo fragte:
Zitat:
funktioniert das script wenn du es manuel aufrufst?
und wie schaut dein crontab eintrag aus?


Wäre schon mal was wert wenn wir das wüssten. Die webmin-Meldung "unknown" erhärtet nämlich den Verdacht das das Prob im Bereich von Hans' Fragestellung liegt.

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Hofer
Gast





BeitragVerfasst am: 20. Aug 2005 0:28   Titel:

Hi,

per script läuft das ganze ohne Proleme.

crontab -l sagt folgendes:

1,4,....usw * * * * /usr/local/name

Bin weiterhin ratlos.

Gruß
Hofer
 

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 20. Aug 2005 0:43   Titel:

@hofer
naja das hilft auch nicht weiter.
was steht genau in der /etc/crontab
ein richtiger eintrag schaut folgendermassen aus.
40 0 * * * root /pfad/zu/dem/test.sh
oder
40 0 * * * root /usr/local/sbin/sntop2 -w -e /usr/local/httpd/htdocs/online1.hmtl -f /etc/sntoprc -o >/dev/null

weil /usr/local/name zeigt nicht auf dieses script und "usw" hab ich auch noch nicht in einem crontab gesehen.

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Hofer
Gast





BeitragVerfasst am: 20. Aug 2005 20:32   Titel:

hi Hans,

scheint doch schwieriger zu sein als ich dachte.
Nun - ich verwende Suse 9.3

da steht dann das ganze in (für den user root)

/var/spool/cron/tabs

1,5,..... * * * /usr/local/sbin/test.sh

sorry, hoffe das ist nun verständlicher.

gruß
Hofer
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy